Ravens PHP Scripts: Forums
 

 

View next topic
View previous topic
Post new topic   Reply to topic    Ravens PHP Scripts And Web Hosting Forum Index -> RavenNuke(tm) v2.5x
Author Message
scorpious
Worker
Worker



Joined: Dec 03, 2005
Posts: 153

PostPosted: Mon Jun 24, 2019 12:17 am Reply with quote

Hi All

I have tried to install the RavenNuke-master-php7

I get the the following errors when installing the database using the installSQL.php

The exact error message that your MySQL server reported is:
MySQL Error # 4 at line 127 in file installSQL.php ==> Specified key was too long; max key length is 1000 bytes

Error in rn_core.sql at line 258:
CREATE TABLE `nuke_users_config` (config_name varchar(255) NOT NULL default '', config_value longtext, UNIQUE KEY config_name (config_name)) ENGINE=MyISAM;

Server info:
Server version: 10.1.38-MariaDB-0+deb9u1 - Debian 9.8
Apache/2.4.25 (Debian)
PHP version: 7.0.33-8+0~20190531121058.14+stretch~1.gbpe7d4ff

I have tried to install phpbb to see if I get the same error, however that installs without any errors.

Cheers for any help

Scorp
 
View user's profile Send private message
neralex
Site Admin



Joined: Aug 22, 2007
Posts: 1542

PostPosted: Mon Jun 24, 2019 2:02 pm Reply with quote

Hi, which collation-type / charset you chosed for the database?

_________________
Github: RavenNuke 
View user's profile Send private message
scorpious







PostPosted: Mon Jun 24, 2019 3:45 pm Reply with quote

Hi neralex

collation-type is utf8mb4_general_ci
I have added DEFAULT CHARSET=utf8, so now it reads ENGINE=MyISAM DEFAULT CHARSET=utf8;
and all tables loads

cheers
scorp
 
neralex







PostPosted: Mon Jun 24, 2019 10:27 pm Reply with quote

I had the same issue with MariaDB and Debian 9.8. Create a new database with the collation-type: utf8_general_ci and try the installation again.
 
scorpious







PostPosted: Tue Jun 25, 2019 3:06 am Reply with quote

Hi neralex

Thanks for the reply
I created a new database with utf8_general_ci and everything installed without any errors

Many thanks
Scorp
 
djmaze
Subject Matter Expert



Joined: May 15, 2004
Posts: 727
Location: http://tinyurl.com/5z8dmv

PostPosted: Mon Jul 08, 2019 4:30 am Reply with quote

scorpious wrote:
I created a new database with utf8_general_ci and everything installed without any errors

utf8 creates new issues as it doesn't support 4 byte UTF-8 (that's why mysql/mariadb has utf8mb4).
So things like emoji's will crash
 
View user's profile Send private message Visit poster's website
neralex







PostPosted: Mon Jul 08, 2019 12:52 pm Reply with quote

djmaze, I know that but with this old package it makes no sense to switch over to utf8mb4, because there a bunch of tables, which need a whole redefinition in order to work with it.
 
Display posts from previous:       
Post new topic   Reply to topic    Ravens PHP Scripts And Web Hosting Forum Index -> RavenNuke(tm) v2.5x

View next topic
View previous topic
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum


Powered by phpBB © 2001-2007 phpBB Group
All times are GMT - 6 Hours
 
Forums ©