Ravens PHP Scripts: Forums
 

 

View next topic
View previous topic
Post new topic   Reply to topic    Ravens PHP Scripts And Web Hosting Forum Index -> RavenNuke(tm) v2.5x
Author Message
jlajax
Ardent RavenCMS Supporter



Joined: Oct 12, 2006
Posts: 244
Location: Jacksonville, Florida

PostPosted: Fri Aug 02, 2013 7:22 pm Reply with quote

Greetings good people,
I am receiving a white page at the new user activation page. When a user registers there is no registration confirmation message or email notification. From admin mode GOD and Super I get the same results when I try to approve new members. New user registration is set to require admin approval. I have already done a RavenNuke_v2_5 software reinstall and received no errors in the upload, all files uploaded. There is nothing in the server logs.

With error reporting turned on I get this:

include_once(/home/content/43/11381743/html/html/includes/tegonuke/mailer/mailer.php) [function.include-once]: failed to open stream: No such file or directory in /home/content/43/11381743/html/html/mainfile.php on line 187

Warning: include_once() [function.include]: Failed opening '/home/content/43/11381743/html/html/includes/tegonuke/mailer/mailer.php' for inclusion (include_path='.:/usr/local/php5_3/lib/php') in /home/content/43/11381743/html/html/mainfile.php on

In the space between the tabs and Username (User ID) in User's Administration: Users:

Warning: include_once(/home/content/43/11381743/html/html/includes/tegonuke/mailer/mailer.php) [function.include-once]: failed to open stream: No such file or directory in /home/content/43/11381743/html/html/mainfile.php on line 187

Warning: include_once() [function.include]: Failed opening '/home/content/43/11381743/html/html/includes/tegonuke/mailer/mailer.php' for inclusion (include_path='.:/usr/local/php5_3/lib/php') in /home/content/43/11381743/html/html/mainfile.php on line 187
Comments? Questions? Thanks folks.
 
View user's profile Send private message
spasticdonkey
RavenNuke(tm) Development Team



Joined: Dec 02, 2006
Posts: 1693
Location: Texas, USA

PostPosted: Sat Aug 03, 2013 5:49 am Reply with quote

Just to be clear, you are using v2.5 not 2.51?

Is the include path in the error messages correct? i.e. does it have "html" twice on your server?
html/html/includes/tegonuke/mailer/mailer.php
 
View user's profile Send private message Visit poster's website
doffer83
Worker
Worker



Joined: Apr 17, 2011
Posts: 117
Location: Amsterdam

PostPosted: Sat Aug 03, 2013 3:38 pm Reply with quote

I dont know if it is allowed but I have also a question about the registration in rn 2.51

I need to make it possible to register and logon with space (raven nuke) and rtl characters. One time some one told to change the function in public- your_account module

admins 2 just the same. example The administrator

But in this version it the code is mach different

ps

I am almost done with upgrade without loosing any article or user .. great job and well done Ravennuke.. much beter than phpnuke. I like it really Smile ai G

_________________
We are sorry that Tony Soprano is dead, We wish Assad the Syrian maffia boss had died instead. RIP Tony 
View user's profile Send private message Visit poster's website
neralex
Site Admin



Joined: Aug 22, 2007
Posts: 1548

PostPosted: Sat Aug 03, 2013 5:00 pm Reply with quote

doffer83, login names should not contain spaces. What you can do is creating accounts with a "_" like "The_User" and then you could use str_replace in the needed areas etc.

Code:
$username = str_replace('_',' ',$username);

_________________
Github: RavenNuke 
View user's profile Send private message
doffer83







PostPosted: Sat Aug 03, 2013 7:24 pm Reply with quote

neralex wrote:
doffer83,

Code:
$username = str_replace('_',' ',$username);


okey what aboute the forign lanugages

on the next page I can found the code I can add to make it possible .. but I don't know what to change with this recent version of rn

[ Only registered users can see links on this board! Get registered or login! ]

or thise code
Code:
pre_match("/[^ء-يa-zA-Z0-9


I am not sure what to replace of the check function

Code:
function ya_userCheck($username) {

   global $stop, $user_prefix, $db, $ya_config;
   if ((empty($username)) || (preg_match('/[^\p{L}\p{N}\p{Pd}\p{Pc}]/u', $username))) $stop = '<div class="text-center">' . _ERRORINVNICK . '</div><br />';
   if (strlen($username) > $ya_config['nick_max']) $stop = '<div class="text-center">' . _YA_NICKLENGTH . '</div>';
   if (strlen($username) < $ya_config['nick_min']) $stop = '<div class="text-center">' . _YA_NICKLENGTH . '</div>';
   if ($ya_config['bad_nick'] > '') {
      $BadNickList = explode("\r\n", $ya_config['bad_nick']);
      $j = count($BadNickList);
      for ($i = 0;$i < $j;++$i) {
         if (preg_match('/' . $BadNickList[$i] . '/i', $username)) $stop = '<div class="text-center">' . _NAMERESTRICTED . '</div><br />';
      }
   }
   if (strrpos($username, ' ') > 0) $stop = '<div class="text-center">' . _NICKNOSPACES . '</div>';

function ya_userCheckB($username) {
   global $user_prefix, $db, $ya_config;
   $return = 'true';
   if ((empty($username)) || (preg_match('/[^\p{L}\p{N}\p{Pd}\p{Pc}]/', $username))) $return = 'false';


Please one try again.

Thank you
 
neralex







PostPosted: Sun Aug 04, 2013 2:19 am Reply with quote

We are going here off topic. I only meant your issue with the spaces in the login names and not a solution for your arabic language! How it was written by montego and nuken in the other thread, you should really wait on the next release - arabic language is not supported in the current release. rtl type and arabic characters without a utf-8 charset is not the best choice!

And again - login names should not contain spaces! Sure is it possible to code but its not recommended. It exists a field in the users db-table for the real name that the user can fill while the registration or later in the your_account settings with free spaces. But in the most modules it was used the username instead of the real name. So i would suggest you to change the username variables in the modules where you really need it. To change it in the whole CMS could costs a lot of time and if the new version is released you must starting from scratch...
 
doffer83







PostPosted: Sun Aug 04, 2013 5:36 am Reply with quote

neralex, I see. Thanks for your explain . I understand and I 'll keep it without spaces. I even don't want change the whole CMC cose I like it as it is.

Danke
 
spasticdonkey







PostPosted: Sun Aug 04, 2013 10:40 am Reply with quote

Even with improvements in our next release (support for rtl, utf8, etc) I doubt, at least initially, there will be support for non-English characters in usernames. I could be wrong, but don't remember seeing it as a priority, amongst all the other work we have to do yet. As nerelex stated, it would require alot of edits to the code as well as shortlinks.

jlajax, you make any progrss on your issue?
 
doffer83







PostPosted: Sun Aug 04, 2013 11:47 am Reply with quote

spasticdonkey, with some tweak I add and a little bit help of you on the forum I made thise version of RN working for us.

When I am done I will start an new topic and I will share the tweaks for non-English languages.

I also will share my language files when it is finished.

^_^
 
jlajax







PostPosted: Sun Aug 04, 2013 4:49 pm Reply with quote

No the address read correctly when navigating the site. RavensScripts RavensScripts
 
jlajax







PostPosted: Sun Aug 04, 2013 4:50 pm Reply with quote

The site functions fine otherwise near as I can tell
 
montego
Site Admin



Joined: Aug 29, 2004
Posts: 9457
Location: Arizona

PostPosted: Fri Aug 09, 2013 9:44 pm Reply with quote

jlajax, please make sure that all the files were properly uploaded.

I, too, am a bit concerned about the double "html" in your path, but it may be legitimate... only you can tell by checking the path to your user's home directory.

(You may want to remove the up-front paths in your post... usually not a good idea to post the whole path out in a public forum.)

_________________
Where Do YOU Stand?
HTML Newsletter::ShortLinks::Mailer::Downloads and more... 
View user's profile Send private message Visit poster's website
jlajax







PostPosted: Mon Aug 26, 2013 5:45 pm Reply with quote

Greetings,

I am seeing this in several of my RN 2.5 out of box and upgrades. The one thing they have in common is I added a required phone during registration. I get a 500 response. The html/html is correct it doesn’t resolve that way in the browser but server side it is the path to the site(s). Anything else I can answer for you?

RavensScripts RavensScripts RavensScripts RavensScripts RavensScripts RavensScripts
 
fkelly
Former Moderator in Good Standing



Joined: Aug 30, 2005
Posts: 3312
Location: near Albany NY

PostPosted: Tue Aug 27, 2013 8:05 am Reply with quote

jlajax .. sorry this has gone on so long and that the thread has gone off in so many directions. Looking back at your original question, the line in mainfile that is giving you problems is:

Code:
include_once NUKE_INCLUDE_DIR . 'tegonuke/mailer/mailer.php';


Mainfile executes on every page load of a RN system, so a problem with it cannot be isolated to just a change in Your Account such as requiring a phone number. The messages you are posting indicate that the system can't find /mailer/mailer.php. The constant NUKE_INCLUDE_DIR is only set in one place in your system and is not reset by Your Account or any other module that I know of.

Can you confirm whether this happens whenever you access the system or only when you are doing something user registration related? Can you look at your file system in Cpanel or some other tool and see whether in your base directory (the same one that the mainfile.php file is in) there is a /includes directory and within that there is a /tegonuke directory and within that a mailer.php file?

If all that checks out you could possibly do a temporary modification to mainfile to do something like this:
echo '<br />' . NUKE_INCLUDE_DIR . '<br />';
include_once NUKE_INCLUDE_DIR . 'tegonuke/mailer/mailer.php';

and see what the value of the NUKE_INCLUDE_DIR is. It should be the same for every page load whether it's Your Account related or not.
 
View user's profile Send private message Visit poster's website
jlajax







PostPosted: Tue Aug 27, 2013 8:27 am Reply with quote

I added the phone required through the admin panel. I never noticed it in 2.4. I'll look into the rest of it this evening when I get back.

RavensScripts RavensScripts RavensScripts RavensScripts RavensScripts RavensScripts
 
jlajax







PostPosted: Sun Sep 01, 2013 11:01 am Reply with quote

Quote:
see whether in your base directory (the same one that the mainfile.php file is in) there is a /includes directory and within that there is a /tegonuke directory and within that a mailer.php file?


I have the standard 2.5 distro downloaded from here and the distro I have does not have tegonuke in the includes directory. I load the distro to the server and unzip on the server to the directory I want it in and then delete the stuff I don't need outside of the html directory.

Here is what I see on my end:
My base files unzipped from distro local computer
Image

Here is what is in the server root:
Image

RavensScripts
 
nuken
RavenNuke(tm) Development Team



Joined: Mar 11, 2007
Posts: 2024
Location: North Carolina

PostPosted: Sun Sep 01, 2013 11:30 am Reply with quote

Something must have gone wrong when you extracted the package. Both the 7zip and tgz package have the tegonuke folder in the includes directory. Also, the latest release is RN 2.51

_________________
Tricked Out News 
View user's profile Send private message Send e-mail Visit poster's website
jlajax







PostPosted: Sun Sep 01, 2013 11:55 am Reply with quote

So I went and checked further I am messing something up I looked in the archived distro and the folder is there... extracting

RavensScripts
 
jlajax







PostPosted: Sun Sep 01, 2013 12:55 pm Reply with quote

That resolved the issue quite well. I don’t know how I did it but in the little mods I make I somehow deleted an entire folder, it has been corrected. I perpetuated it with WINMERGE doing the upgrades. I know what to do. That is one of the things so cool about learning this system... if I mess it up too bad I can always go back to the original pristine files and start over. Thanks so much! I am learning the system and you guys as always are the absolute best!

RavensScripts RavensScripts RavensScripts RavensScripts RavensScripts RavensScripts RavensScripts
 
Display posts from previous:       
Post new topic   Reply to topic    Ravens PHP Scripts And Web Hosting Forum Index -> RavenNuke(tm) v2.5x

View next topic
View previous topic
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum


Powered by phpBB © 2001-2007 phpBB Group
All times are GMT - 6 Hours
 
Forums ©