Ravens PHP Scripts: Forums
 

 

View next topic
View previous topic
Post new topic   Reply to topic    Ravens PHP Scripts And Web Hosting Forum Index -> Converting/Creating Blocks
Author Message
nextgen
Worker
Worker



Joined: Sep 28, 2006
Posts: 235

PostPosted: Wed Apr 21, 2010 5:34 am Reply with quote

With the move of the Forums Includes files in ravennuke into the modules/Forums/includes it made the forums collapsing block throw out errors because it is still looking for the root/includes/constants.php when it is actually now in the modules/forums/includes/constants.php Would someone update the download so all future users can use it and have no issues. I have the debugger from http://www.code-authors.com/ and it shows me a bunch of errors from the block. Here is a screenshot.

Image
 
View user's profile Send private message Send e-mail
Palbin
Site Admin



Joined: Mar 30, 2006
Posts: 2583
Location: Pittsburgh, Pennsylvania

PostPosted: Wed Apr 21, 2010 5:41 am Reply with quote

Are trying to use this block on a RN site? If so a new block is included in the package. It will not work on a non RavenNuke site unless the jQuery library is loaded.

_________________
"Debugging is twice as hard as writing the code in the first place. Therefore, if you write the code as cleverly as possible, you are, by definition, not smart enough to debug it." — Brian W. Kernighan. 
View user's profile Send private message
nextgen







PostPosted: Wed Apr 21, 2010 7:37 am Reply with quote

a center block that collapses ? I see a side block but no other collapsing blocks.
 
nextgen







PostPosted: Wed Apr 21, 2010 7:39 am Reply with quote

It is working fine now, just need to correct the path to the constants.php. No errors at all. Just wanted to post in case others find the same issue.
 
Palbin







PostPosted: Wed Apr 21, 2010 1:46 pm Reply with quote

Does your block look like the one here? [ Only registered users can see links on this board! Get registered or login! ]
 
nextgen







PostPosted: Wed Apr 21, 2010 6:08 pm Reply with quote

exactly like that one. Could there be a newer version ?
 
Palbin







PostPosted: Wed Apr 21, 2010 8:19 pm Reply with quote

The block on the site in your profile is not using the latest version of the block. I can tell by looking at it. The newest block is included in the package so I am not sure how you got that one.
 
luckson
New Member
New Member



Joined: Aug 02, 2008
Posts: 22
Location: NaGaLim

PostPosted: Sat Aug 14, 2010 4:06 am Reply with quote

I have problem with this block too! The "Show/Hide" doesn't work when click... M not using the latest RN version though. V2.30.01 RN is the last version i installed/upgraded in 2009.
Any suggestion will be much appreciated.
my site is [ Only registered users can see links on this board! Get registered or login! ]

_________________
Nagalim/Nagaland 
View user's profile Send private message Visit poster's website
Palbin







PostPosted: Sat Aug 14, 2010 9:28 am Reply with quote

You need to download the main jQuery library, and place it in includes/jquery. Then add the following to header,php between the head tags.
Code:


<script type="text/javascript" language="JavaScript" src="includes/jquery/jquery.js"></script>


You may need to change "jquery.js" to what ever you call it. I do not think the block requires any plug-ins, but I can not remember.
 
luckson







PostPosted: Sun Aug 15, 2010 2:27 am Reply with quote

Prolly the problem is with my theme. It works like a charm with Fisubice theme... tested both in IE and Firefox... it looks awkward in Google Chrome though ...
 
spasticdonkey
RavenNuke(tm) Development Team



Joined: Dec 02, 2006
Posts: 1693
Location: Texas, USA

PostPosted: Sun Aug 15, 2010 10:00 am Reply with quote

The collapse button seemed to work ok for me on your site using latest of IE and Firefox. Although sometimes other JS errors can cause issues, i got a JS warning in IE with:
Code:
<img width="170" height="94" border="0" align="left" src="frontpage/signup.png" style="margin-right: 10px;" onmouseover="this.src=''frontpage/signup1.png'';" onmouseout="this.src=''frontpage/signup.png'';" alt="" />


try changing to:
Code:
<img width="170" height="94" border="0" align="left" src="frontpage/signup.png" style="margin-right: 10px;" onmouseover="this.src='frontpage/signup1.png'" onmouseout="this.src='frontpage/signup.png'" alt="" />
 
View user's profile Send private message Visit poster's website
Display posts from previous:       
Post new topic   Reply to topic    Ravens PHP Scripts And Web Hosting Forum Index -> Converting/Creating Blocks

View next topic
View previous topic
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum


Powered by phpBB © 2001-2007 phpBB Group
All times are GMT - 6 Hours
 
Forums ©