Ravens PHP Scripts: Forums
 

 

View next topic
View previous topic
Post new topic   Reply to topic    Ravens PHP Scripts And Web Hosting Forum Index -> Installation Help
Author Message
tntplus1
New Member
New Member


Joined: Nov 22, 2010
Posts: 14

PostPosted: Tue Nov 23, 2010 2:54 pm Reply with quote

Hi everyone,

Please help me with this: after I installed RavenNuke[tm] Version 2.40.01 Released [.7z pkg. 6.51meg] on Vista Ultimate SP1, I got a blank page with the message "Nice Try!!" when I tried to access Only registered users can see links on this board! Get registered or login! or Only registered users can see links on this board! Get registered or login! localhost/index.php. I followed the installation instruction from Only registered users can see links on this board! Get registered or login!

My installation + configuration went smoothly with no error. I have only index.php in my wwwroot/ dir (no index.html file there) and I also verified that users have "read & write" access to the following files (
1. .htaccess
2. .staccess
3. /cache
4. /uploads/File
5. /uploads/Flash
6. /uploads/Image
7. /uploads/Media )

Still I got the "Nice Try!!" blank pages when accessing admin.php and index.php.

Following is my system info:
Vista Ultimate SP1, IIS 7, PHP 5.2.14, and MySQL 5.1.52, browser(s): FireFox 3.6.12 and/or IE 8. This Vista box is my local testing site. My IIS + PHP + MySQL work fine.

Please, can someone tell me what's wrong and how to fix it.

Thanks very much in advance.

 
View user's profile Send private message
tntplus1
PostPosted: Tue Nov 23, 2010 3:04 pm Reply with quote

Hi,

It's me again. I'd like to add that after successful installations of Raven Nuke, I already renamed the installation directory. Still the blank pages appear when I tried /localhost/admin.php or index.php.

Please help me fix this.

Thanks very much.
 
nuken
RavenNuke(tm) Development Team


Joined: Mar 11, 2007
Posts: 2024
Location: North Carolina

PostPosted: Tue Nov 23, 2010 3:28 pm Reply with quote

In your rnconfig.php find this line:
Code:
$bypassNukeSentinelInvalidIPCheck = false;  


and change it to true.

_________________
Only registered users can see links on this board! Get registered or login! 
View user's profile Send private message Send e-mail Visit poster's website
tntplus1
PostPosted: Wed Nov 24, 2010 9:29 am Reply with quote

Hi nuken,

Thanks for your reply. In my rnconfig.php, I changed $bypassNukeSentinelInvalidIPCheck = false; to $bypassNukeSentinelInvalidIPCheck = true; and even rebooted my PC. Still the blank pages with the message "Nice Try!!" remain whenever I accessed admin.php and index.php. Please help me! Raven Nuke team, could you please check the logic of your code to see which case(s) trigger that message and how to fix it.

Thank you so much.

P.S.: also, please show me how to turn on Raven Nuke logging. Maybe the logs would give some hints of what's going wrong. Thanks.
 
Palbin
Site Admin


Joined: Mar 30, 2006
Posts: 2583
Location: Pittsburgh, Pennsylvania

PostPosted: Wed Nov 24, 2010 10:08 am Reply with quote

Only registered users can see links on this board! Get registered or login!

_________________
"Debugging is twice as hard as writing the code in the first place. Therefore, if you write the code as cleverly as possible, you are, by definition, not smart enough to debug it." — Brian W. Kernighan. 
View user's profile Send private message
tntplus1
PostPosted: Wed Nov 24, 2010 3:16 pm Reply with quote

Hi Nuken,

Thanks for your reply. I set the $bypassNukeSentinelInvalidIPCheck = true;
still the blank pages with the message "Nice Try!!" remain when I accessed index.pp and admin.php. Please help me fix this. Raven Nuke team, could you please check the logic of the code to see what triggers that message and how to fix it.
Also, please show to how to turn on logging for raven nuke and where to look for the log files.

Thanks very much.
 
Palbin
PostPosted: Wed Nov 24, 2010 3:40 pm Reply with quote

Read the topic I posted. It will solve your problems. This is only a problem because you are tying to run the site locally.
 
nuken
PostPosted: Wed Nov 24, 2010 3:45 pm Reply with quote

The Link Palbin posted should answer your questions and get you up and running.
 
tntplus1
PostPosted: Fri Nov 26, 2010 5:53 pm Reply with quote

Hi guys,

Thanks for your answers and the link. I encountered the exact problem as mentioned in the link. In includes/ipban.php, after I added echo $ip;
//if(!ereg('^([0-9]{1,3})\\.([0-9]{1,3})\\.([0-9]{1,3})\\.([0-9]{1,3})$', $ip)) die('Nice try!!');

The display is ::1, and I could see the admin login page, but I cannot log in. I entered the security code, but it does not let me in.

I restored the ipban.php to "if(!ereg('^([0-9]{1,3})\\.([0-9]{1,3})\\.([0-9]{1,3})\\.([0-9]{1,3})$', $ip)) die('Nice try!!');" and disabled IPv6, still did not solve anything. Blank pages with "Nice Try!!".

Please someone help me! Yes, I am using a local system. But Raven Nuke should run on local sites as well; otherwise, there's no way that users can fully test their local site before having it hosted.

Thanks.
 
nuken
PostPosted: Fri Nov 26, 2010 6:26 pm Reply with quote

Have you turned on error logging?

In config.php change
$display_errors = true;

in rnconfig.php change
$loglevel = 1;

You should be able to view your errors in rnlogs/dblog
make sure dblog is 777
paste the errors you get when you try to login as admin.
 
Palbin
PostPosted: Fri Nov 26, 2010 8:20 pm Reply with quote

tntplus1 wrote:
Hi guys,

Thanks for your answers and the link. I encountered the exact problem as mentioned in the link. In includes/ipban.php, after I added echo $ip;
//if(!ereg('^([0-9]{1,3})\\.([0-9]{1,3})\\.([0-9]{1,3})\\.([0-9]{1,3})$', $ip)) die('Nice try!!');

The display is ::1, and I could see the admin login page, but I cannot log in. I entered the security code, but it does not let me in.

I restored the ipban.php to "if(!ereg('^([0-9]{1,3})\\.([0-9]{1,3})\\.([0-9]{1,3})\\.([0-9]{1,3})$', $ip)) die('Nice try!!');" and disabled IPv6, still did not solve anything. Blank pages with "Nice Try!!".

Please someone help me! Yes, I am using a local system. But Raven Nuke should run on local sites as well; otherwise, there's no way that users can fully test their local site before having it hosted.

Thanks.


If you disabled IPv6 what do you get when you echo the IP?
 
hicuxunicorniobestbuildpc
Life Cycles Becoming CPU Cycles


Joined: Aug 13, 2009
Posts: 967
Location: Netherland

PostPosted: Tue Nov 30, 2010 2:05 am Reply with quote

I guess 127.0.0.1 is already blocked by admin and that is why you can't access. I think you need to remove this ip manually in phpMyadmin

remember Only registered users can see links on this board! Get registered or login! is the same as Only registered users can see links on this board! Get registered or login!

I made a test on Windows 7 Ultimate Edition and no problem. Just to let you know.
 
View user's profile Send private message Visit poster's website
Palbin
PostPosted: Tue Nov 30, 2010 9:05 pm Reply with quote

If someone could try this revised ipban.php it would be appreciated. Please note that PHP 5.2+ is required. You will also have to have $bypassinvalidipcheck set to true if you are using IPv6.

Code:


<?php

/************************************************************************/
/* PHP-NUKE: Web Portal System                                          */
/* ===========================                                          */
/*                                                                      */
/* Copyright (c) 2004 by Francisco Burzi                                */
/* http://phpnuke.org                                                   */
/*                                                                      */
/* This program is free software. You can redistribute it and/or modify */
/* it under the terms of the GNU General Public License as published by */
/* the Free Software Foundation; either version 2 of the License.       */
/************************************************************************/

if (realpath(__FILE__) == realpath($_SERVER['SCRIPT_FILENAME'])) {
   header('Location: ../index.php');
   exit('Access Denied');
}

global $bypassNukeSentinelInvalidIPCheck, $db, $prefix;

$ip = $_SERVER['REMOTE_ADDR'];
$ipv4 = filter_var($ip, FILTER_VALIDATE_IP, FILTER_FLAG_IPV4);
$ipv6 = filter_var($ip, FILTER_VALIDATE_IP, FILTER_FLAG_IPV6);
if(!$ipv4 && (!$ipv6 && !$bypassNukeSentinelInvalidIPCheck)) die('Invalid IP Address!');

$numrow = $db->sql_numrows($db->sql_query('SELECT `id` FROM `' . $prefix . '_banned_ip` WHERE `ip_address`="' . $ip . '"'));
if ($numrow != 0) {
   echo '<br /><br /><center><img src="images/admin/ipban.gif" /><br /><br /><b>You have been banned by the administrator</b></center>';
   die();
}

if ($ipv4) {
   $ip_class = explode('.', $ip);
   $ip = $ip_class[0] . '.' . $ip_class[1] . '.' . $ip_class[2] . '.*';
   list($ip_address) = $db->sql_fetchrow($db->sql_query('SELECT `ip_address` FROM `' . $prefix . '_banned_ip` WHERE `ip_address`="' . $ip . '"'));
   $ip_class_banned = explode('.', $ip_address);
   if (isset($ip_class_banned[3]) && $ip_class_banned[3] == '*') {
      if ($ip_class[0] == $ip_class_banned[0] && $ip_class[1] == $ip_class_banned[1] && $ip_class[2] == $ip_class_banned[2]) {
         echo '<br /><br /><center><img src="images/admin/ipban.gif" /><br /><br /><b>You have been banned by the administrator</b></center>';
         die();
      }
   }
}

?>
 
Display posts from previous:       
Post new topic   Reply to topic    Ravens PHP Scripts And Web Hosting Forum Index -> Installation Help

View next topic
View previous topic
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum


Powered by phpBB © 2001-2007 phpBB Group
All times are GMT - 6 Hours
 
Forums ©