Ravens PHP Scripts: Forums
 

 

View next topic
View previous topic
Post new topic   Reply to topic    Ravens PHP Scripts And Web Hosting Forum Index -> Installation Help
Author Message
sqzdog
Involved
Involved


Joined: Sep 22, 2003
Posts: 252

PostPosted: Sat Aug 27, 2005 12:38 pm Reply with quote

I upgraded from 7.0 to 7.6, using all the upgrade scripts in order.

I get this when I go to mysite/index.php

Quote:
Fatal error: Call to undefined function: sql_connect() in /home/sqzdog/public_html/mainfile.php on line 132


Now, this is what Line 132 has to say:

Quote:
$dbi = sql_connect($dbhost, $dbuname, $dbpass, $dbname);




Oh, I tried to download the connection test but it won't download off of NukeCops for some reason.

Would it hurt to run the upgrade scripts again, if necessary?

My 7.0 had sentinel on it. Could this have anything to do with it?
 
View user's profile Send private message Send e-mail
hitwalker
Sells PC To Pay For Divorce


Joined:
Posts: 5661

PostPosted: Sat Aug 27, 2005 4:57 pm Reply with quote

oh boy...
just take out the sentinel you had and check also if all proper files are uploaded /or overwritten..
it simple means there isnt any connection with your database,at this moment your site doesnt even know what its looking for..
to narrow down the errors take out sentinel and check the upgrade procedure...
also use the new config file and put in your database info..
 
View user's profile Send private message
sqzdog
PostPosted: Sat Aug 27, 2005 5:26 pm Reply with quote

Ok, I have done all that, including dropped the nsn db. I still get the same error message. I also reloaded all the new 7.6 files. Still get the same error.
 
hitwalker
PostPosted: Sat Aug 27, 2005 5:30 pm Reply with quote

well if you want,pm me your login info for ftp ...
 
hitwalker
PostPosted: Sat Aug 27, 2005 5:47 pm Reply with quote

well as im looking at all the contents...
do you have a lot of content,or modified stuff ?
im looking at the analizer file and mysql part seems ok but a lot of php warnings.
But i doubt if that would affect,but sure is a security risk.

And a question..
Can you tell HOW you upgraded?
from 7.0 to 7.6 or from 7.0 to 7.1 etc...
 
sqzdog
PostPosted: Sat Aug 27, 2005 5:50 pm Reply with quote

I installed the 7.6 files, and then ran the upgrade scripts, one by one, to the final 7.5 to 7.6. There was alot of modified stuff.

On another note, I just did a clean install of 7.7 under the folder "new". If I can copy all my data from the old sqzdog_nuke6 db to the sqzdog_nuke database than I can go from there. I just don't know how to transfer sql stuff.
 
sqzdog
PostPosted: Sat Aug 27, 2005 5:51 pm Reply with quote

Actually, I ran the upgrade scripts first, then installed the files, overwriting the old ones. I did do a complete backup though.
 
hitwalker
PostPosted: Sat Aug 27, 2005 5:57 pm Reply with quote

well you messed up at a few places i guess.
its back to life again but not sure how far..
 
sqzdog
PostPosted: Sat Aug 27, 2005 5:59 pm Reply with quote

I've been working on this thing for 8 hours now. Thanks for getting it going. I'll look around and see if everything is working. Do you mind telling me where I messed up (if it isn't too extensive)

Thanks again Hitwalker.
 
hitwalker
PostPosted: Sat Aug 27, 2005 6:02 pm Reply with quote

well you say you upgraded but you didnt realy.
if you did your ftp would show the proper date on changed files.
thats how i knew..
your old sql_layer.php file was 2kb,but should have been like 11kb.
i overwritten the includes,the admin files and the root follows..
 
hitwalker
PostPosted: Sat Aug 27, 2005 6:12 pm Reply with quote

im almost done..
i strongly suggest you clean up a litle cause you have some junk here and there...
and what about the collection htaccess files?
Is that a hobby?
 
sqzdog
PostPosted: Sat Aug 27, 2005 6:13 pm Reply with quote

hahaha! I have no idea! Never used them before!
 
hitwalker
PostPosted: Sat Aug 27, 2005 6:41 pm Reply with quote

Ok im done,i deleted the analyzer cause thats to old.
I overwritten all files and upgraded the forum to 2.0.17.
If you have any forum problems ( i dont think so) but if you get any do address them to chatserv.

The site is 7.6 patched 3.0,whitch is good enough...its exactly the same as i have.

A few suggestions = delete everything that you dont use or need...lol Smile

Im finished....good luck.
 
sqzdog
PostPosted: Sat Aug 27, 2005 6:43 pm Reply with quote

Thanks alot. I was using WS-FTP to transfer the files. I guess they didn't overwrite them. Have a great weekend.
 
hitwalker
PostPosted: Sat Aug 27, 2005 6:45 pm Reply with quote

you to... Smile
 
hitwalker
PostPosted: Sat Aug 27, 2005 6:49 pm Reply with quote

forgot..do install sentinel again,the newest...
 
sqzdog
PostPosted: Sat Aug 27, 2005 6:52 pm Reply with quote

i will. Thanks
 
hitwalker
PostPosted: Sat Aug 27, 2005 6:53 pm Reply with quote

Smile
 
Display posts from previous:       
Post new topic   Reply to topic    Ravens PHP Scripts And Web Hosting Forum Index -> Installation Help

View next topic
View previous topic
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum


Powered by phpBB © 2001-2007 phpBB Group
All times are GMT - 6 Hours
 
Forums ©