Ravens PHP Scripts: Forums
 

 

View next topic
View previous topic
Post new topic   Reply to topic    Ravens PHP Scripts And Web Hosting Forum Index -> KISSQ General Support
Author Message
Jeruvy
New Member
New Member



Joined: Jul 29, 2003
Posts: 9

PostPosted: Tue Jul 29, 2003 4:15 pm Reply with quote

Hi there. I too am having trouble with the formatting of this modules. Everything seems to work, but the following situation has me befuddled.

When you click the link to the 'stock quotes' module it renders a normal page where the stock quote section is in the center, and the two columns on the left and right have the normal content.

Now the module displays everything fine, except for the right column which takes on some wierdness of its own. This column gets very screwed up. Specifically it affects the 'survey' block and adds the 'Portfolio Summary' content from the 'stock quote' module completely (price tables and all) and inserts this between the survey question and the choices. Almost like it was automatically creating a poll for itself...

The right column then no longer displays anything. For users the remaining blocks get displayed in the center column, for admin's it does not display ANY blocks.

Thanks...

J.
 
View user's profile Send private message
Raven
Site Admin/Owner



Joined: Aug 27, 2002
Posts: 17087

PostPosted: Tue Jul 29, 2003 6:56 pm Reply with quote

This is a documented problem. Look in the KISSQ forum and you will see that I have acknowleged this. I am trying to figure out what causes it and as I said in those other threads, set $index=0; and that will suppress the right blocks.
 
View user's profile Send private message
Jeruvy







PostPosted: Wed Jul 30, 2003 2:59 pm Reply with quote

Quote:
This is a documented problem. Look in the KISSQ forum and you will see that I have acknowleged this. I am trying to figure out what causes it and as I said in those other threads, set $index=0; and that will suppress the right blocks.


Well that suggestion doesn't do it for me. I did have a look at the code and I noticed that for some reason $content is being picked up by the survey module, I'm assuming this is some sort of global variable, that shouldn't be.

I modifed the file as thus: Added line 651

Code:
 unset($content); 


This corrected it. Now I'm also having trouble with the javascript all of a sudden. I was also not getting the options properly displayed in the section above this (makes me think this code is really wonky...) so I fixed this by modifying line 643 as thus:

Code:
<td align="center" colspan=12><a href="javascript:document.stock.actionSubmit.value='Get Quote';document.stock.submit();"  onMouseOver="status='Get Quote';return true;">Get Quote</a><?if ($REGISTERED) {?><br /><a href="javascript:document.stock.actionSubmit.value='Add to Portfolio';document.stock.submit();" onMouseOver="status='Add to Portfolio';return true;">Add to Portfolio</a><br /><?if ($REGISTERED) {?><a href="javascript:document.stock.actionSubmit.value='Update Portfolio';document.stock.submit();" onMouseOver="status='Update Portfolio';return true;">Update Portfolio</a><br /><a href="javascript:document.stock.actionSubmit.value='Delete From Portfolio';document.stock.submit();" onMouseOver="status='Delete From Portfolio';return true;">Delete From Portfolio</a><?}}?><?if (!$this_deleted) {?><br /><a href="javascript:document.stock.actionSubmit.value='Show/Download History';document.stock.submit();" onMouseOver="status='Show/Download History';return true;">Retrieve <b><?=$Symbol?></b> History</a> From:<input name="showHistoryFromDate" size="12" value="<?=$defHistoryDate?>"><?}?>



But I'm still getting 'document.stock.actionSubmit' is null or not an object errors from modules.php?name=Stock_Quote whenever I click on those links....

J.
 
Raven







PostPosted: Wed Jul 30, 2003 3:40 pm Reply with quote

Make sure $loadSQAtStartup = FALSE; and not TRUE.
 
Jeruvy







PostPosted: Fri Aug 01, 2003 11:57 am Reply with quote

Quote:
Make sure $loadSQAtStartup = FALSE; and not TRUE.


Yup, that fixed that problem also. The line 643 suggestion had no affect on fixing it, so I would leave it alone (changed mine back).

So anyone having trouble with this block add my simple fix, and set this variable to FALSE ONLY will allow it to work for you.

The reason I set this to TRUE was I was having trouble loading the module from certain pages, but I haven't been able to recreate this error.

J.
 
Raven







PostPosted: Fri Aug 15, 2003 6:18 pm Reply with quote

I am readying a bug fix release for KISSQ. Your line 651 code slapped me in the head! Of course $content would cause nuke to have a migraine. That's what all the blocks use, so the very next block in the loading order got slammed! In the bug fix release I have renamed all the $content instances. Thanks!
 
Dude
New Member
New Member



Joined: Jul 09, 2003
Posts: 7

PostPosted: Sat Aug 16, 2003 6:14 am Reply with quote

Hi,

Where can I find the download for version 3.2?

Embarassed
 
View user's profile Send private message
Raven







PostPosted: Sat Aug 16, 2003 6:39 am Reply with quote

In the Download area.
 
Dude







PostPosted: Sat Aug 16, 2003 6:47 am Reply with quote

Hi,

I can only find 3.1

Cool
 
Dude







PostPosted: Sat Aug 16, 2003 6:49 am Reply with quote

He, he.

It just popped up on the list Laughing

Thank's alot
 
Display posts from previous:       
Post new topic   Reply to topic    Ravens PHP Scripts And Web Hosting Forum Index -> KISSQ General Support

View next topic
View previous topic
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum


Powered by phpBB © 2001-2007 phpBB Group
All times are GMT - 6 Hours
 
Forums ©