Ravens PHP Scripts: Forums
 

 

View next topic
View previous topic
Post new topic   Reply to topic    Ravens PHP Scripts And Web Hosting Forum Index -> KISGB General Support
Author Message
KnightWolfJK
New Member
New Member



Joined: Jul 25, 2003
Posts: 7

PostPosted: Fri Jul 25, 2003 11:45 pm Reply with quote

I'm sure this is simply something I've overlooked, but the following happens when I attempt to edit an entry:
* A single password box is returned in which I enter the password
* I change information in the entry and click "Update"
* A page is returned requiring User ID and Password
* Upon entering the User ID and Password and clicking Submit, I'm returned to the guestbook without changes being made

I looked through config.explain and the FAQ, and searched the forum as well. As far as I could tell I'm the first to be as large a nincompoop to have this issue Smile

I'm using
Code:
$admin_from_web = true;

$secure_site = false;
$lock_admin_to_myIP = false;
$allow_msg_lvl_edit_by_admin = true;

What else am I missing?
Thanks...
 
View user's profile Send private message
Raven
Site Admin/Owner



Joined: Aug 27, 2002
Posts: 17087

PostPosted: Sat Jul 26, 2003 7:57 am Reply with quote

Since you talk about editing entries, I assume then that you can enter entries, just not edit them, correct?

What server are you using, IIS or Apache? Nuke or not?

Please rename the syschk.php script to something else and PM me the link so I can see your setup. be sure to reference this thread in your PM.
 
View user's profile Send private message
Raven







PostPosted: Sat Jul 26, 2003 4:25 pm Reply with quote

I am not having any problems at all. Every edit I have made to the message works perfectly. I made no changes. Try it again. Also, I don't get the extra password screen that you are talking about.
 
KnightWolfJK







PostPosted: Sun Jul 27, 2003 5:42 am Reply with quote

Okay, I figured it out... kisgb didn't like punctuation used as part of the password. I changed back to my original password and had the problems I mentioned.

My original password was 7chars alphanumeric with a %. I tried the same seven characters with a #- same problem. I edited the password to simply be 8chars alphanumeric, and it works like a charm.

Thanks...
 
edgregory
New Member
New Member



Joined: Nov 19, 2002
Posts: 5

PostPosted: Wed Aug 06, 2003 10:30 pm Reply with quote

Everything else seems to function okay, but I cannot edit or delete messages using the Admin menu.

I even edited the files on the server via Telnet and the changes were not reflected in the page built by the script.

Embarassed
 
View user's profile Send private message Send e-mail Visit poster's website
Raven







PostPosted: Wed Aug 06, 2003 10:34 pm Reply with quote

Did you modify your permissions on user.prefs.php and kisgb.csv.php to 666?
 
edgregory







PostPosted: Wed Aug 06, 2003 11:09 pm Reply with quote

They were both 766. I changed them to 666. No apparent difference.

I click edit for a message, click delete, get a response "DEMO Successful", but there is no real change.
 
Raven







PostPosted: Wed Aug 06, 2003 11:14 pm Reply with quote

That is a permissions error or you don't have
$admin_from_web = true;

The kisgb folder must be permission 766. The two files I mentioned before must be either 766 or 666 or 777. It doesn't matter as long as they are at least 666.
 
Raven







PostPosted: Wed Aug 06, 2003 11:29 pm Reply with quote

Ed, if this is for a nuke install, make sure that the modules folder permissions are also 766.
 
edgregory







PostPosted: Wed Aug 06, 2003 11:37 pm Reply with quote

Now I can't even access index.php in the KISBG root.

Instead of acting like it was changing files that it didn't really change, I am now getting permission errors. On everything.
 
Raven







PostPosted: Wed Aug 06, 2003 11:40 pm Reply with quote

??? Change everything to 777
 
edgregory







PostPosted: Wed Aug 06, 2003 11:43 pm Reply with quote

It's not a Nuke install.

This site was just that close <indicating a tiny space between two fingers> to being turned over to the client.

I know these scripts work fine. I just can tell what I'm doing wrong here.

The site is: http://www.musiccitygatorclub.org/newerindex.htm

I'd pull out my hair if I had any.

-Ed
 
Raven







PostPosted: Wed Aug 06, 2003 11:47 pm Reply with quote

KISGB will not have any effect on the rest of your site. I have to goto bed right now, but if you want me to look into this in the morning, please pm me with your site url, id, password and your ftp site, id and pw.
 
Display posts from previous:       
Post new topic   Reply to topic    Ravens PHP Scripts And Web Hosting Forum Index -> KISGB General Support

View next topic
View previous topic
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum


Powered by phpBB © 2001-2007 phpBB Group
All times are GMT - 6 Hours
 
Forums ©