Ravens PHP Scripts: Forums
 

 

View next topic
View previous topic
Post new topic   Reply to topic    Ravens PHP Scripts And Web Hosting Forum Index -> RavenNuke(tm) v2.5x
Author Message
blaci
New Member
New Member



Joined: Feb 16, 2009
Posts: 22

PostPosted: Mon Apr 19, 2021 11:01 pm Reply with quote

This system doesn't like me. I did a whole new installation. Database latin1_swedish_ci
I didn't touch the files. Not for language files either. I turned on the Hungarian language everywhere. Both in the administration menu for profile editing and in the forum administration. After that, as a user, I can't create new topics. The page will load I fill in the topic and text box and then click submit. He throws it back to creation without an error message. What should I do to make the forum work properly in Hungarian?
Thank you in advance for your help.
 
View user's profile Send private message
blaci







PostPosted: Tue Apr 20, 2021 8:16 am Reply with quote

I was able to figure out that the module / Forum / language / lang_hungarian / lang-main.php has something to do with the error. If I replace this file with the English lang_main.php file, this error will not occur. In this case, however, the characters ŰŐ etc do not appear in the topic box.
 
neralex
Site Admin



Joined: Aug 22, 2007
Posts: 1671

PostPosted: Tue Apr 20, 2021 12:11 pm Reply with quote

Let us start from scratch with some infos about your used php-version and your used database-application. Do you use mysql or maria-db?

_________________
Github: RavenNuke 
View user's profile Send private message
blaci







PostPosted: Tue Apr 20, 2021 1:29 pm Reply with quote

Hello! mysql and php 7.3
 
neralex







PostPosted: Tue Apr 20, 2021 1:54 pm Reply with quote

I have to test it at the next weekend with hungarian-language files. But I'm using for my german umlauts the database collation: utf8_general_ci but do not change in this case the Content-Type within the _CHARSET constant in the hungarian language-file. The _CHARSET constant should be:

php Code:
define('_CHARSET','ISO-8859-1');


Otherwise you will risk a database collation mismatch which could cause your described issues.
 
blaci







PostPosted: Tue Apr 20, 2021 2:12 pm Reply with quote

Do I understand correctly? Set database matching to utf-8?
 
neralex







PostPosted: Tue Apr 20, 2021 2:24 pm Reply with quote

Yes but only the database collation, not the Content-Type!


Last edited by neralex on Wed Apr 21, 2021 12:35 am; edited 2 times in total 
blaci







PostPosted: Tue Apr 20, 2021 3:59 pm Reply with quote

Unfortunately, it didn't work out. Database matching was set by utf8_general_ci. The Hungarian language file is ISO-8859-1.
Still, the same problems as before.
 
blaci







PostPosted: Tue Apr 20, 2021 4:29 pm Reply with quote

Unfortunately, my service provider once switched to a database application. You forgot to notify me. Now I noticed that it is no longer mysql but MariaDB. Could this be the cause of the error?
 
neralex







PostPosted: Thu Apr 22, 2021 11:37 pm Reply with quote

There is a known issue with MariaDB.
 
Display posts from previous:       
Post new topic   Reply to topic    Ravens PHP Scripts And Web Hosting Forum Index -> RavenNuke(tm) v2.5x

View next topic
View previous topic
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum


Powered by phpBB © 2001-2007 phpBB Group
All times are GMT - 6 Hours
 
Forums ©