Ravens PHP Scripts: Forums
 

 

View next topic
View previous topic
Post new topic   Reply to topic    Ravens PHP Scripts And Web Hosting Forum Index -> v2.3 RN Documentation
Author Message
jackel
Worker
Worker



Joined: Jan 15, 2009
Posts: 145
Location: Iowa, USA

PostPosted: Sun Mar 08, 2009 12:40 pm Reply with quote

I know this sounds dumb But im getting ready to go live with my site and my pastor need to know everything that needs to be installed on his server to get ravennuke running right I know mysql php 5.0 or higher phpadmin GD support can you give me a text file or point where i can find this info lol I know from the install what we need lol but i hope to make this a smooth transition

Thanks

Chris

PS i know its kinda retarded question Smile
 
View user's profile Send private message
jackel







PostPosted: Sun Mar 08, 2009 12:44 pm Reply with quote

OMG lol i found it told yea brain fart moment
 
trunks
Worker
Worker



Joined: Oct 05, 2007
Posts: 152
Location: United Kingdom

PostPosted: Sun Mar 08, 2009 1:03 pm Reply with quote

and for those that come accross this issue in the future, its all included in the download Smile
 
View user's profile Send private message Visit poster's website MSN Messenger
jackel







PostPosted: Sun Mar 08, 2009 1:05 pm Reply with quote

ROTFL uhhuh Laughing
 
montego
Site Admin



Joined: Aug 29, 2004
Posts: 9457
Location: Arizona

PostPosted: Tue Mar 10, 2009 6:51 am Reply with quote

More specifically even, in the HowToInstall Manual within the download.

_________________
Where Do YOU Stand?
HTML Newsletter::ShortLinks::Mailer::Downloads and more... 
View user's profile Send private message Visit poster's website
bdmdesign
Worker
Worker



Joined: May 11, 2009
Posts: 154
Location: Winsen/Luhe; Germany

PostPosted: Tue Sep 22, 2009 10:17 am Reply with quote

I have a problem with the php.ini and the raven nuke:

These settings are recommended for PHP in order to ensure full compatibility with RavenNuke™. However, RavenNuke™ should still operate if your settings do not quite match the recommended.
Recommended settingsDirective Recommended Actual

Safe Mode OFF OFF
Display Errors ON ON
File Uploads ON ON
Magic Quotes GPC ON OFF <----
Magic Quotes Runtime OFF OFF
Register Globals OFF OFF
Output Buffering ON OFF <----
Session auto start OFF OFF


I have copy the ini in the rootfolder of the raven but the installer dont use it. In the cutom ini the are Output Buffering & Magic Quotes GPC ON. The ravennuke version is the 2.30.02. Did need the 2.4.x the same configuration? I cant change the original php.ini.
 
View user's profile Send private message Visit poster's website
fkelly
Former Moderator in Good Standing



Joined: Aug 30, 2005
Posts: 3312
Location: near Albany NY

PostPosted: Tue Sep 22, 2009 10:25 am Reply with quote

2.4 will be happiest with the same settings that 2.3.02 was happiest with. The ini file is used by PHP when it starts ... there is no way the installer can "use" it. I would not worry about these settings unless a problem occurs, generally we have coded "around" them.
 
View user's profile Send private message Visit poster's website
bdmdesign







PostPosted: Tue Sep 22, 2009 10:30 am Reply with quote

Ok i hope its works. I will change from Platinum to Raven
 
montego







PostPosted: Wed Sep 23, 2009 9:10 pm Reply with quote

The installer will work no problem. It is really showing you what RN would work best with. The core of RN really works with magic quotes on or off. My personal preference is OFF, but it could create security issues with older poorly coded modules/add-ons. We have a FAQ on the output buffering so if you run into any "headers already sent" issues, you will need to set this to ON; check the FAQ if need be.
 
bdmdesign







PostPosted: Thu Sep 24, 2009 1:03 am Reply with quote

Thanx, the installer works fine, but not on a Localhost Rolling Eyes

I will read the faq later.

Thanx for the answer.
 
montego







PostPosted: Thu Sep 24, 2009 5:27 pm Reply with quote

bdmdesign wrote:
the installer works fine, but not on a Localhost


Does for me every time using XAMPP for both Windows and for Linux. You might want to switch if you are not using this distro.
 
bdmdesign







PostPosted: Fri Sep 25, 2009 3:43 am Reply with quote

On my localhost the core-tabeles are not loaded correctly. But ist ok now. I have copy the tabels from my online Server. The Raven Nuke was nice. I will use it
 
jakec
Site Admin



Joined: Feb 06, 2006
Posts: 3048
Location: United Kingdom

PostPosted: Fri Sep 25, 2009 5:58 am Reply with quote

Can you confirm what you are using for your localhost?
 
View user's profile Send private message
bdmdesign







PostPosted: Fri Sep 25, 2009 6:46 am Reply with quote

Its only the first step in the Installer from RavenNuke 2.4.x

My PHP Info:

PHP Version 5.2.9

Edit: fkelly, I deleted your phpinfo (and more) listing. Never post this stuff publicly. Even if it is just a localhost environment I'd bet you use the same passwords on your web hosted systems and hackers could look at your cookie settings and try to use them. Just don't, it is way too much information about your systems.
 
bdmdesign







PostPosted: Mon Sep 28, 2009 12:50 pm Reply with quote

bdmdesign wrote:

Edit: fkelly, I deleted your phpinfo (and more) listing. Never post this stuff publicly. Even if it is just a localhost environment I'd bet you use the same passwords on your web hosted systems and hackers could look at your cookie settings and try to use them. Just don't, it is way too much information about your systems.


I dont Use the same Password on my Online Space and Local Wink
 
fkelly







PostPosted: Mon Sep 28, 2009 1:18 pm Reply with quote

Quote:

I dont Use the same Password on my Online Space and Local


Good, but you still don't want to post your phpinfo data online. Really.
 
bdmdesign







PostPosted: Mon Sep 28, 2009 1:22 pm Reply with quote

Ok, thanx for the tip
 
jakec







PostPosted: Mon Sep 28, 2009 1:28 pm Reply with quote

......but are you using XAMPP or another distro for your localhost?
 
bdmdesign







PostPosted: Mon Sep 28, 2009 1:32 pm Reply with quote

I use opensuse also an Lamp
 
bdmdesign







PostPosted: Tue Sep 29, 2009 7:39 am Reply with quote

Soo i have try now the 2.3 and the same problem:

The installer didnt install the core tabels on my localhost.

Only the core tabels are dont installed, all other works.

I dont will rewrite the sql files, can i get the core files from you?
 
fkelly







PostPosted: Tue Sep 29, 2009 8:01 am Reply with quote

Very difficult to interpret what you are saying bdmdesign. At this point you want to be starting with RN 2.4. If you have problems with the installer you need to tell us exactly what the problems are, what any messages are and tell us exactly what steps you are taking. The installer needs the right data in config.php for instance to even find your database.
 
bdmdesign







PostPosted: Tue Sep 29, 2009 8:43 am Reply with quote

fkelly wrote:
Very difficult to interpret what you are saying bdmdesign. At this point you want to be starting with RN 2.4. If you have problems with the installer you need to tell us exactly what the problems are, what any messages are and tell us exactly what steps you are taking. The installer needs the right data in config.php for instance to even find your database.


Also:

I have installed it local and use a Linux Apache Mysql Php

The config file has all right data in it. I open my Browser and start the installer:

The installer says Database connected, Ok

Next spep: i click on fist step (install core files in db)
Now it must come an % number, but its call me no filles installed.

I click on the second step: Here is all right, the tabels are installed

All php files have CHMOD 777

Tryed Versions: 2.3 & 2.4 its the same.

The first step dont work local from the installer script.

Online its ok. My php.ini is ok

Did you understand me now....
 
fkelly







PostPosted: Tue Sep 29, 2009 8:54 pm Reply with quote

Bmp ... we have a language problem but that's okay. I've tried to use my primitive foreign language skills in Mexico to order a meal and if folks had not been patient with me I would have starved. So can we back up ...

are you trying to install on both a localhost type system and a web system? Or what?

I am guessing you want to do a clean install. And looking at your notes and using intuition I am thinking maybe you need to drop your pre-existing backed up tables before you run the install. I've seen situations where a user's privileges don't allow them to drop existing tables the way the installer does and perhaps you are getting caught up in that.
 
bdmdesign







PostPosted: Wed Sep 30, 2009 3:04 am Reply with quote

I had install the rn 2.4 on my Onlinespace and all was fine, the installer installebd all tables in the Database. Ok.

I have gprs as Internet connektion, thats bad. So i use Nuke Systems Local to make my themes, Modules and Blocks.

I installed the rn 2.4 & rn 2.3 Local in a clean Database.

Config is ok, than i run the installer, its connected to the Database, thats ok. Than i click on "fisrst Step" nothing is doing, if i click on "second Step" the tables was installed from the second Step. all other steps works , too. Only the first step dont works.
 
fkelly







PostPosted: Wed Sep 30, 2009 6:35 am Reply with quote

Are there pre-existing tables? If so, drop them separately from the installer and try it again and let us know. We have seen some situations where the installer doesn't have the privileges needed to drop the tables.
 
Display posts from previous:       
Post new topic   Reply to topic    Ravens PHP Scripts And Web Hosting Forum Index -> v2.3 RN Documentation

View next topic
View previous topic
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum


Powered by phpBB © 2001-2007 phpBB Group
All times are GMT - 6 Hours
 
Forums ©