Ravens PHP Scripts: Forums
 

 

View next topic
View previous topic
This forum is locked: you cannot post, reply to, or edit topics.   This topic is locked: you cannot edit posts or make replies.    Ravens PHP Scripts And Web Hosting Forum Index -> Raven's RavenNuke(tm) v2.00.00 - v2.02.00 Distro
Author Message
theduncan
Hangin' Around


Joined: Mar 09, 2006
Posts: 26

PostPosted: Fri Mar 24, 2006 3:53 pm Reply with quote

Had NIM (from gnaunited.com) running great with PHPNUKE 7.6 patched to 3.2.

Decided to switch to Ravenscript's Nuke for the added features
added and pre-configured (WYSIWYG editor and Sentinel security
among others)as well as the SUPERB comunity and support. I figured it would be best to run what most here run since this seems one of the best places for support both for newbs like me and up to hard core PHPNukers like many others here.

so I installed Ravens 76version2 ( which included the 3.1 patch supposedely so I take it as 7.6 3.1)

Patched it with 3.2 so that now it registers as Raven 76ver2.2 when I "analyze " (analyze.php file from download)

installed NIM and now When I go to NIM Admin (which should let me either install db or configure since the DB should still be there, as I am using the same db that my original 7.6.3.2 was on) it tells me that NIM does not support my
version of PHPNUKE please update.

I know that the current NIM is designed to work with the 3.2 patch and nothing lower.

I have tried reinstalling NIM but I only got the same notification.

I am wondering if there is something in the Ravenscript version of Nuke
that notates the Nuke Version differently so that NIM doesnt recognize it.

If so, where would that be, and can I change it to notate that it is 7.6.3.2? Or is there something else that could be causing this?

I have emailed and posted at Gnaunited, and the developer has been of great help to me in the past, but while waiting to hear back from him I wanted to post here since his module did run perfectly for me with a native 7.6.3.2 .


Anyhelp would greatly be appreciated.

Thanks.
 
View user's profile Send private message
kguske
Site Admin


Joined: Jun 04, 2004
Posts: 6383

PostPosted: Fri Mar 24, 2006 4:28 pm Reply with quote

Without knowing what NIM is looking for, it would be difficult to answer. But if you get an answer from the NIM developers, we will gladly investigate alternatives for making it work with RavenNuke.

_________________
I google, therefore I exist...
Only registered users can see links on this board! Get registered or login!
 
View user's profile Send private message
montego
Site Admin


Joined: Aug 29, 2004
Posts: 9449
Location: Arizona

PostPosted: Fri Mar 24, 2006 5:15 pm Reply with quote

Ask them if they have hardcoded their tool to check against the nuke $version variable...

_________________
Only registered users can see links on this board! Get registered or login!
Only registered users can see links on this board! Get registered or login! 
View user's profile Send private message Visit poster's website
theduncan
PostPosted: Fri Mar 24, 2006 6:13 pm Reply with quote

will do and will follow up when I get a response, as I think many would enjoy this module, as it is key for me allowing friends and family etc to IM while behind strict firewalls and on Secured or Validated systems/clients (not allowed to download or install any apps other than those approved and secured)

I'll post the response for help or the solution of I get it from the dev.

Thanks again
 
evaders99
Former Moderator in Good Standing


Joined: Apr 30, 2004
Posts: 3221

PostPosted: Fri Mar 24, 2006 11:16 pm Reply with quote

Well hopefully we'll have the next RavenNuke with Patched 3.2. That should solve the problem I expect

_________________
- Only registered users can see links on this board! Get registered or login! -

Need help? Only registered users can see links on this board! Get registered or login! 
View user's profile Send private message Visit poster's website
theduncan
PostPosted: Sat Mar 25, 2006 4:19 pm Reply with quote

SOLVED!

The Developer at Gnaunited.com Alex I believe simply had me add

$Version_Num = "7.6";

to the bottom of mainfile.php before the closing ?>:

And that fixed it..

Looks like it wasnt the 3.2 patch not being recognized but rather that Ravens mainfile was lacking that bit ,or had it in a different loc, that NIM was looking for. Or so it would seem

The module is super handy, and when the next version comes out will be perhaps one of the most valuable for my users who are limited by validated systems or office rules by not being allowed to download or install Instant messengers.

MUUUUCH better than the "other" IM for Nuke.. Tried it hated it.

I just wanted to post the solution here since so often people forget to after their stuff is back up and running Smile
 
montego
PostPosted: Sat Mar 25, 2006 4:24 pm Reply with quote

Actually, the reason I asked is that RavenNuke76 uses a different version number format. Wink No-one has ever relied on that being "accurate" before... until now! Smile
 
montego
PostPosted: Sat Mar 25, 2006 4:25 pm Reply with quote

Yeah... I know, I had the wrong variable name, but the same result.

killing me
 
kguske
PostPosted: Sat Mar 25, 2006 6:42 pm Reply with quote

Curious - since there are multiple "other" IMs for Nuke - of which were you referring?
 
theduncan
PostPosted: Sun Mar 26, 2006 1:08 am Reply with quote

The only IMs I was aware of that did not either require you to use an external source-site (like e-messenger etc.) or to have a standard IM installed on your system was Nuke Instant Messenger 121.

I'm sure there are others, and Im sure that I missed some, but the ones I have seen most often used or discussed are either the 121 or NIM.

121 was ok, but didnt have the smilies and junk that everyone loves, with NIM I can with the least effort add any of my own as well as for some reason it doesnt seem as glitchy. (that could just be me, but that has been my experience)


(by the way kguske, and I will post this as another topic if I cant find an answer scouring this forum: How can I add the "insert/upload image" function to the FCKeditor in Ravenscripts version? As I believe you were the ace that ported it for it. as well as is it possible to have the same visual toolbar show up in the forum textarea?)
 
kguske
PostPosted: Sun Mar 26, 2006 7:35 am Reply with quote

Thanks. See Only registered users can see links on this board! Get registered or login! for info on uploading images. We did not add it to the forums because the forums use bbcode instead of html.
 
theduncan
PostPosted: Sun Mar 26, 2006 4:36 pm Reply with quote

thanks Kguske, but my question is how to use the SAME TOOLBAR for the "Submit News" as is present in the Admins "NEWS" module, or at least one with an "INSERT IMAGE" feature so that USERS can insert images.

I may have something screwed up, but my "Submit News" version of the FCKeditor toolbar has no options for Insert/Edit images, Flash, page break, insert form, Image Button, button, radio button, checkbox, textfield, text area etc.

I dont neccessarrily need all that but with my users who are allowed to submit news, I have no problem allowing them to have and use all of that,(and i figure it easier to use that toolbar config as is as opposed to altering it to some custom form).

Once I have that up, then I am sure that I will likely have to pay more attention to the folders/files/directories associated with them. But currently they arent options at all.

I will post this as a new post as well.

Thanks,
 
kguske
PostPosted: Sun Mar 26, 2006 8:17 pm Reply with quote

The reason Submit News doesn't have those options is that there is no way to secure them completely, and most sites allow non-administrators to use that functionality. If you want to allow it (which I don't recommend), just change the toolbar from NukeUser to PHPNukeAdmin.
 
gnaunited
New Member
New Member


Joined: Feb 15, 2006
Posts: 2

PostPosted: Mon Apr 17, 2006 12:25 pm Reply with quote

I just thought I would comment on the NIM problem real fast:

NIM is made for PHP-Nuke 7.0 - 7.7. It has full compatibility for all of the admin security features and all of that fun stuff, so NIM needs to know the exact version of Nuke that is being used. I suppose that I could set the version number in the NIM admin section, but then you run into upgrade problems. Plus also by using that system, NIM will know if you are using some custom branded Nuke version that probably has lost support for one or more of the features that NIM needs. So, in short, the $Version_Num variable should be used for legacy support, even if you think that no one uses it.

Plus - NIM has been in development for over three years, and has used many different JS systems. We have finally found one that not only works 99% of the time, but also is not affected by server failure and other little problems. That is why it doesn't seem to be glitchy either. (Except for FF, which has some wierd little problems when it comes to the JS code)
 
View user's profile Send private message
theduncan
PostPosted: Mon Apr 17, 2006 1:33 pm Reply with quote

followup- after chatting with gnaunited, we found that it was a simple matter of adding a small line at the end of the mainfile (I think) stating the PHP-Nuke Version. (which I think is either not included or resides elsewhere in the RavensScript version of nuke than the standard install.

Everything worked great after that.
 
gnaunited
PostPosted: Mon Apr 17, 2006 3:12 pm Reply with quote

The variable $Version_Num is created after getting the version number from the database. Raven's version does not do this for some reason, thus whenever NIM would try to determine the version it would fail automatically.
 
kguske
PostPosted: Mon Apr 17, 2006 4:43 pm Reply with quote

Thanks gnaunited, glad to see you're still around!
 
Display posts from previous:       
This forum is locked: you cannot post, reply to, or edit topics.   This topic is locked: you cannot edit posts or make replies.    Ravens PHP Scripts And Web Hosting Forum Index -> Raven's RavenNuke(tm) v2.00.00 - v2.02.00 Distro

View next topic
View previous topic
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum


Powered by phpBB © 2001-2007 phpBB Group
All times are GMT - 6 Hours
 
Forums ©