Prerequisites

3.1. Prerequisites

In the INSTALL file of PHP-Nuke, we read the following about its requirements:

In order to setup PHP-Nuke the folowing prerequisits are necessary.

...The above doesn't mean it will not work with other configurations, OS's, DB's, etc, but we only provide INSTALL instructions for the above configuration. In fact PHP-Nuke works under Windows (all), FreeBSD, OS/2, MacOS, etc.

Important PHP 4.1.0 or later needed!
 

From the INSTALL file, we see that you must have at least PHP 4.1.0 to use PHP-Nuke 6.5 and later. This is an important piece of information that you should ckeck before proceeding. See Warning: Invalid argument supplied for foreach().

You see, it is always a good idea to read the INSTALL file that comes with a software package.

To see the PHP version you are running and do also a small test on your configuration, you can run the test.php file as described in Section 3.9.1.1.

Note PHP-Nuke and databases other than MySQL
 

From PHP-Nuke version 5.3, Francisco added a new SQL abstraction layer. It enables PHP-Nuke to support databases other than MySQL, like mSQL, PostgreSQL, PostgreSQL_local, ODBC, ODBC_Adabas, Sybase and Interbase.

For the Microsoft Internet Informaion Server (IIS), some tests we have done were positive, some others indicated that a special configuration was needed.


Help us make a better PHP-Nuke HOWTO!

Want to contribute to this HOWTO? Have a suggestion or a solution to a problem that was not treated here? Post your comments on my PHP-Nuke Forum!

Chris Karakas, Maintainer PHP-Nuke HOWTO

 

Site Info v2.2.2

Last SeenLast Seen
Server TrafficServer Traffic
  • Total: 344,036,150
  • Today: 34,902
Server InfoServer Info
  • Dec 14, 2017
  • 12:57 pm PST
 
 

Daily Inspiration