Ravens PHP Scripts: Forums
 

 

View next topic
View previous topic
This forum is locked: you cannot post, reply to, or edit topics.   This topic is locked: you cannot edit posts or make replies.    Ravens PHP Scripts And Web Hosting Forum Index -> Raven's RavenNuke(tm) v2.02.02 Distro
Author Message
mrbilly
Worker
Worker


Joined: Jun 07, 2006
Posts: 114

PostPosted: Mon Jun 12, 2006 9:34 am Reply with quote

hey everyone...a further small probelm...i am using the new RavenNuke76 v2.02.02 Distro

There is only one account registered right now, (which is the admin users account).

When I log into the account and go to the YOUR INFO module,
I notice that although I have enterd nothing in the field, the YOUR ICQ field has a zero in it ('0').

I deleted it and clicked on 'save changes', but it will not go away. I cannot even change this '0' to some other text, (instead of having just nothing in the field)

I did a search and I see this problem and fix listed for nuke 7.6, ut i tried the advise and it didnt do nothing on this version of php-nuke i have

Does anyone know about this and how to fix it?


Last edited by mrbilly on Mon Jun 26, 2006 6:08 pm; edited 1 time in total 
View user's profile Send private message
kguske
Site Admin


Joined: Jun 04, 2004
Posts: 6383

PostPosted: Mon Jun 12, 2006 7:19 pm Reply with quote

Are you logged in as a site user, in addition to being logged in as an admin user? The change may not be saved if you aren't logged in as a site user. The zero in the ICQ field must be the default.

_________________
I google, therefore I exist...
Only registered users can see links on this board! Get registered or login!
 
View user's profile Send private message
gregexp
The Mouse Is Extension Of Arm


Joined: Feb 21, 2006
Posts: 1497
Location: In front of a screen....HELP! lol

PostPosted: Mon Jun 12, 2006 8:42 pm Reply with quote

im thinkin the same thing...mrbilly...ready to try another shot at messin with ur database?

Try this...ull notice (the same way u edited the amount of data the field could hold) on that page a spot for Default...i bet its set to zero...i think this is an accident as ravens distro is not set to this by default

if this is the case ..I hope this fixes ur problems

BTW...guys absolute GREAT job on the ravennuke....its funny im looking for errors..lol..havent found one yet....although would be nice if it was made into one simple page....like write somethin in the index.php like if(define('INSTALL', true));
{
all code
}
else{
include installer.php
}

something like that so that it can all be done from one page. instead of loading 2 different pages.
Just a sudjestion to make it even easier...believe me, Its easy as can be.

_________________
For those who stand shall NEVER fall and those who fall shall RISE once more!! 
View user's profile Send private message Send e-mail Visit poster's website AIM Address Yahoo Messenger MSN Messenger ICQ Number
mrbilly
PostPosted: Tue Jun 13, 2006 2:44 am Reply with quote

hi kguske & darklord...i have logged in as though i am a registered user of the website and this is what happens...

When I log into the account and go to the YOUR INFO module,
I notice that although I have enterd nothing in the field, the YOUR ICQ field has a zero in it ('0').

I deleted it and clicked on 'save changes', but it will not go away. I cannot even change this '0' to some other text, (instead of having just nothing in the field)

I did a search and I see this problem and fix listed for nuke 7.6, but i tried the advise and it didnt do nothing on this version of php-nuke i have.

Also, i have checked my database using PHPMyAdmin to see what darklord has explained...I do not see anything being set to 'Zero', but I do see a field set to 'Null' and wonder if that is what darklord refers to?

The fileds in that table that do have information are set as follows...


Field - user_icq

Type - VARCHAR

Length/Values* - 15

Collation - latin1_swedish_ci

Null - null

Default - NULL


Is this all correct?
 
Guardian2003
Site Admin


Joined: Aug 28, 2003
Posts: 6792
Location: Ha Noi, Viet Nam

PostPosted: Tue Jun 13, 2006 5:27 am Reply with quote

When a user creates an account 'NULL' should be stored there by default. When a user updates their profile, it seems '0' is getting inserted.
I think the '0' is being added as part of the security routine (to prevent users from entering links or commands within the field) - it checks to see if the value is an integer (a number) and obviously 'NULL' is not a number so '0' gets inserted as it has to have a value of some sort otherwise an error is generated.
 
View user's profile Send private message Send e-mail
mrbilly
PostPosted: Tue Jun 13, 2006 3:56 pm Reply with quote

So what do I do to remmedy the scenario I currently have and that I have explained previosuly?
 
Guardian2003
PostPosted: Tue Jun 13, 2006 4:09 pm Reply with quote

I just want to confirm you tried the fix posted here by Evaders Only registered users can see links on this board! Get registered or login!
and after deleting the '0' from the table it is still the same?
 
mrbilly
PostPosted: Tue Jun 13, 2006 4:34 pm Reply with quote

Hi again Guardian2003.

Yes...(in the file located at modules/Your_Account/index.php) I located the following code....

$user_icq = intval($user_icq);


...and i simply deleted it.

I then tried deleting the 0 from the icq field and I also tried changing it to something else. However the problem still persists. Sad
 
Guardian2003
PostPosted: Tue Jun 13, 2006 4:38 pm Reply with quote

It should have been replaced, not deleted.
Where you deleted that line, you need now add
Code:
if (preg_match('/^[0-9]+$/', $user_icq)) { $user_icq = intval($user_icq); } 

else { $user_icq = ""; }
 
mrbilly
PostPosted: Tue Jun 13, 2006 5:58 pm Reply with quote

Aaaaah...THANK YOU SO MUCH Guardian2003!!! :clap: Dance-Y

The problem has now been solved with the help of your last piece of advise. Wave

The confusion was in the posting you refered to at Only registered users can see links on this board! Get registered or login!

The last piece of advise there is to simply delete the whole line...or at least, thats what i read it to mean...so i did that.

Anyhow, onwards and upwards.

Thank you again. Smile
 
Guardian2003
PostPosted: Tue Jun 13, 2006 6:04 pm Reply with quote

No problem, glad you are happy again Smile
 
Display posts from previous:       
This forum is locked: you cannot post, reply to, or edit topics.   This topic is locked: you cannot edit posts or make replies.    Ravens PHP Scripts And Web Hosting Forum Index -> Raven's RavenNuke(tm) v2.02.02 Distro

View next topic
View previous topic
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum


Powered by phpBB © 2001-2007 phpBB Group
All times are GMT - 6 Hours
 
Forums ©