Ravens PHP Scripts: Forums
 

 

View next topic
View previous topic
Post new topic   Reply to topic    Ravens PHP Scripts And Web Hosting Forum Index -> Themes
Author Message
tinas
New Member
New Member


Joined: May 10, 2006
Posts: 13

PostPosted: Fri May 12, 2006 11:13 am Reply with quote

I am sorry for starting a new topic on this. I got a lot of helpful advice in my other post, and I had posted this question there, but since it is unrelated to my initial question it may be overlooked, so I am trying again.

For some reason, my left sideboxes are all styled the way that i want them (I started with the Fisubice Theme from Raven and then modified it to get the look I want. But like I say, my Left Side boxes all have a background and are looking correct, on the right side the top and bottom graphic is showing but the content of the sideboxes doesn't have the background.

Now, I do not see that there is a file any place that defines left box vs. right box. I assume it all reads from themes/MYTHEME/blocks.html

Is this wrong ? Is there something else I am missing ?

You can see this performance live at :
Only registered users can see links on this board! Get registered or login!

Thanks so much for any advice you can give - I have been trying to figure this out for 3 days now Sad

Tina S.
 
View user's profile Send private message
hitwalker
Sells PC To Pay For Divorce


Joined:
Posts: 5661

PostPosted: Fri May 12, 2006 4:12 pm Reply with quote

hi,

i didnt forget about you but was caught up in other stuff...
but jaded is here the theme lady ....lol
so you can also pm her if realy needed...

the design of your blocks background is done inside blocks.html

play with this piece..

<td bgcolor="#F4F6FB"><table width="100%" border="0" cellspacing="0" cellpadding="4">
<tr>
<td>$content</td>
</tr>
 
View user's profile Send private message
tinas
PostPosted: Fri May 12, 2006 5:04 pm Reply with quote

Thank you Hitwalker, but my problem is that only the right side is not appearing as it should.

The left side blocks have all the formatting that I placed in my blocks.html (including the background that is not showing on the right side) but my right side is missing the background on the content portion. This is why I asked if maybe there was a file that defined Left one way and Right the other.

I hope that makes more sense.

I understand that you have a life away from here, and I certainly didn't mean to imply that i wasn't getting help, more that maybe because my original topic was not on this same issue, maybe I should start a new thread addressing this particular issue.
 
hitwalker
PostPosted: Fri May 12, 2006 5:10 pm Reply with quote

well im not sure if it has anything to do with it but if i rightclick on the blocks for background image it shows ... Only registered users can see links on this board! Get registered or login!

but thats not there...
 
tinas
PostPosted: Fri May 12, 2006 5:25 pm Reply with quote

That is an easy fix ( uploading the image into that folder ) thank you- sometimes I don't even think about the obvious Wink

But, what it doesn't answer is this : Is there a file that defines Left Blocks look like... and another file that defines Right Blocks look like....

You see what I am saying ? It seems that if blocks.html controls ALL blocks, then why is my image working on the left and not on the right;)


Tina
 
tinas
PostPosted: Fri May 12, 2006 5:27 pm Reply with quote

Oh and on another note, that fix makes my blocks look like I want them too. They should be seperate like they are on the right - not with the solid like they are on the left.

Again I am at my same thoughts, there must be some place that is telling each side to display besides just the blocks.html

Tina
 
hitwalker
PostPosted: Fri May 12, 2006 5:37 pm Reply with quote

well maybe im missing something but to me both blocks look the same.
and no....there isnt any other configuration of your blocks,besides blocks.html
its called inside your theme.php but that just includes your blocks.html
 
tinas
PostPosted: Fri May 12, 2006 5:49 pm Reply with quote

Hitwalker - first let me say thank you so much for your patience and diligence in dealing with me on this.

If you look at my fix (all i did was load the proper image into the /images folder) at Only registered users can see links on this board! Get registered or login! you will see that on the right hand side each block starts with a top image, then the content has a background then there is a bottom image. After the block there is a blank black space where my page background shows through. But on the left hand side that blank space is missing, the background is running all the way down the left side of the screen and each block doesn't distinctly end and a new one start, since that background is continuing.

There definitely must be something that defines left and right seperately, because there are two completely different looks on each side in this case.

Again Thank you for your time and patience, and I have a semi fix. I guess I am just asking at this point for future reference with other themes I may develop.

Tina
 
hitwalker
PostPosted: Fri May 12, 2006 5:56 pm Reply with quote

ah i see what you mean now...
but i tried to duplicate it hoping i could see whats missing but that didnt help..
i suggest you contact jaded and im sure she will help you....
 
tinas
PostPosted: Fri May 12, 2006 6:01 pm Reply with quote

Thank You very much for your help.

Hopefully Jaded will see this post and help me understand. I really don't wanna PM someone for no "real" reason Wink

Tina
 
hitwalker
PostPosted: Fri May 12, 2006 6:03 pm Reply with quote

im sure she doesnt mind,she has more things to do then monitoring the forum here...just pm here,the sooner your problem is fixed.
 
Nomad
Client


Joined: Jan 21, 2006
Posts: 87
Location: Arizona

PostPosted: Fri May 12, 2006 6:17 pm Reply with quote

Check your table html. I noticed that on your rendered code, you are missing a <tr> right after one of the tables. I dont know if that is the problem, but it definitly isnt showing.

this is the piece of code
Code:


<table width="178px" background="images/7px.gif" border="0" cellspacing="19" cellpadding="0">
     <td><font class="content">


You start a <td> right after the <table> but you need a <tr> before every <td>.

Something like:

Code:


<table width="178px" background="images/7px.gif" border="0" cellspacing="19" cellpadding="0">
    <tr>
     <td><font class="content">

_________________
Nomad!~! 
View user's profile Send private message Visit poster's website AIM Address
tinas
PostPosted: Fri May 12, 2006 6:37 pm Reply with quote

Thanks Nomad...

But that apparently is further proof of my theory that there are 2 files controlling this not just one...

Here is my blocks code :
Code:
<table width="178px" border="0" cellspacing="0" cellpadding="0">

  <tr>
    <td height="25px" align="center" background="themes/Mentat/images/cellpic3.gif"><font class="block-title"><strong>$title</strong></font></td>
  </tr>
  <tr>
   <td><table width="178px" background="images/7px.gif" border="0" cellspacing="19" cellpadding="0">
                <td><font class="content">$content</font></td>
  </tr></table></td></tr>
  <tr>
    <td><img src="themes/Mentat/images/cellpic1.gif" alt="Mentat Records" width="178" height="27" /></td>
  </tr>
</table><br />


I don't see any missing tags in this ???

I didn't edit tables.php other than colors either and I don't see any missing elements in it either

Tina Evil or Very Mad
 
jaded
Theme Guru


Joined: Nov 01, 2003
Posts: 1006

PostPosted: Fri May 12, 2006 9:26 pm Reply with quote

please zip up your theme as it is with your changes and list a url to it. I will then load it up and try to fix your issue. I clearly see what you are talking about. You are just lucky that I noticed this thread. Next time do like hit said, click the pm button. It is much faster and I do not mind at all. Thanks

_________________
Themes BB Skins Only registered users can see links on this board! Get registered or login!
Graphic Tees Only registered users can see links on this board! Get registered or login!
Paranormal Tees Only registered users can see links on this board! Get registered or login!
Ghost Stories & More Only registered users can see links on this board! Get registered or login! 
View user's profile Send private message Visit poster's website
tinas
PostPosted: Sat May 13, 2006 9:14 am Reply with quote

Sent via PM Jaded. Thanks Smile
 
jaded
PostPosted: Sat May 13, 2006 4:43 pm Reply with quote

okay, here are your problems. they will fix your blocks as you want them.

first in blocks.html you have
Code:
   <td><table width="178px" background="images/7px.gif" border="0" cellspacing="19" cellpadding="0">

                <td><font class="content">$content</font></td>


you need to make the path

Code:
<td><table width="178px" background="themes/Mentat/images/7px.gif" border="0


second in your header.html file you have

Code:
<table width="100%" cellpadding="0" cellspacing="0" border="0" align="center">

<tr valign="top">
  <td valign="top" width="1" style="background-image: url(themes/Mentat/images/7px.gif)">


you need to change 7px.gif to pixel.gif


If you do this the blocks will show as you want. Thanks and good luck!
 
tinas
PostPosted: Sat May 13, 2006 5:05 pm Reply with quote

Thank You Jaded !

Superb Smile

Tina S.
 
Display posts from previous:       
Post new topic   Reply to topic    Ravens PHP Scripts And Web Hosting Forum Index -> Themes

View next topic
View previous topic
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum


Powered by phpBB © 2001-2007 phpBB Group
All times are GMT - 6 Hours
 
Forums ©