Ravens PHP Scripts: Forums
 

 

View next topic
View previous topic
Post new topic   Reply to topic    Ravens PHP Scripts And Web Hosting Forum Index -> How To's
Author Message
Nomad
Client


Joined: Jan 21, 2006
Posts: 87
Location: Arizona

PostPosted: Thu Mar 16, 2006 11:11 pm Reply with quote

I just installed nuke teasury 2006 (ver 1.1.1). I followed the instructions to a Tee! I even made a seperate mysql database for the IPN data. As soon as I refreshed my page, all of my modules vanished! I was like woe! . javascript:emoticon('Shocked') It killed my site. I then found that:
  1. If I removed the donat-o-meter block my modules showed back up. This was removed by ftp because i couldnt access my admin control panel (apc).
  2. If I accessed the "Donate" module, it opened but broke my theme and the admin links at the top of the page dissappeared.
  3. If i logged into the "treasury" admin module, it also broke my theme.


I searched the forums for days, reading all Nuke Treasury post, but couldnt find my problem. So I began to hack at the code and narrowed the problem down to the nuke treasurey config file...but all it did was access the database. javascript:emoticon('Question')

I worked on this until I realized that I set up the database with the same user as I did for my phpnuke installation. When I corrected this, it worked perfectly. This might seem obvious to the experienced web master, but to the untrained eye, I didnt even know that this mattered. So Im posting this message for anyone else with the same issue:

The fix was to do this:
For my web host (Raven Web Hosting), You have to assign a user to every database that you setup.
Make sure that you assign a different user to the nuke treasury database. DO NOT USE THE SAME USER THAT IS ASSIGNED TO YOUR NUKE DATABASE.
Now if you didnt create a seperate database, then this probably doesnt apply to you.........Very Happy

_________________
Nomad!~! 
View user's profile Send private message Visit poster's website AIM Address
montego
Site Admin


Joined: Aug 29, 2004
Posts: 9449
Location: Arizona

PostPosted: Fri Mar 17, 2006 6:58 am Reply with quote

Yes, I have never used a separate database. Never saw the value in it. Thanks for posting this, though, in case others run into the same problem.

_________________
Only registered users can see links on this board! Get registered or login!
Only registered users can see links on this board! Get registered or login! 
View user's profile Send private message Visit poster's website
Display posts from previous:       
Post new topic   Reply to topic    Ravens PHP Scripts And Web Hosting Forum Index -> How To's

View next topic
View previous topic
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum


Powered by phpBB © 2001-2007 phpBB Group
All times are GMT - 6 Hours
 
Forums ©