Ravens PHP Scripts: Forums
 

 

View next topic
View previous topic
Post new topic   Reply to topic    Ravens PHP Scripts And Web Hosting Forum Index -> How To's
Author Message
dark-dude
Worker
Worker


Joined: Jun 29, 2003
Posts: 146
Location: Oklahoma

PostPosted: Wed Jan 21, 2004 10:12 pm Reply with quote

OK My box went south so we did another one and reloaded everything just like it was.....before it did i did DB Backup from admin section and saved it to my drive. After everything was back up and running..i made a database in phpmyadmin called nuke and went to sql and opened the sql file i saved. after a few mins i get this error and a few others if i remove these.
Code:
Error


SQL-query : 

CREATE TABLE nuke_Guestbook(

id int( 9 ) NOT NULL AUTO_INCREMENT ,
name varchar( 50 ) CHARACTER SET latin1 NOT NULL ,
email varchar( 60 ) CHARACTER SET latin1 NOT NULL ,
url varchar( 70 ) CHARACTER SET latin1 NOT NULL ,
date int( 11 ) DEFAULT '0' NOT NULL ,
host varchar( 60 ) CHARACTER SET latin1 NOT NULL ,
COMMENT text CHARACTER SET latin1 NOT NULL ,
nukeuser smallint( 1 ) DEFAULT '0',
PRIMARY KEY ( id )
)

MySQL said:


#1064 - You have an error in your SQL syntax.  Check the manual that corresponds to your MySQL server version for the right syntax to use near 'character set latin1 NOT NULL,
   nukeuser smallint(1) DEFAULT


how can I fix this?????

_________________
DaRk-DuDe 
View user's profile Send private message Send e-mail Visit poster's website AIM Address Yahoo Messenger MSN Messenger ICQ Number
dark-dude
PostPosted: Wed Jan 21, 2004 10:15 pm Reply with quote

OK i removed the nuke_Guestbook tables and then i get this error
Code:
Error


SQL-query : 

CREATE TABLE nuke_autonews(

anid int( 11 ) NOT NULL AUTO_INCREMENT ,
catid int( 11 ) DEFAULT '0' NOT NULL ,
aid varchar( 30 ) CHARACTER SET latin1 NOT NULL ,
title varchar( 80 ) CHARACTER SET latin1 NOT NULL ,
time varchar( 19 ) CHARACTER SET latin1 NOT NULL ,
hometext text CHARACTER SET latin1 NOT NULL ,
bodytext text CHARACTER SET latin1 NOT NULL ,
topic int( 3 ) DEFAULT '1' NOT NULL ,
informant varchar( 20 ) CHARACTER SET latin1 NOT NULL ,
notes text CHARACTER SET latin1 NOT NULL ,
ihome int( 1 ) DEFAULT '0' NOT NULL ,
alanguage varchar( 30 ) CHARACTER SET latin1 NOT NULL ,
acomm int( 1 ) DEFAULT '0' NOT NULL ,
associated text CHARACTER SET latin1 NOT NULL ,
PRIMARY KEY ( anid ) ,
KEY anid( anid )
)

MySQL said:


#1064 - You have an error in your SQL syntax.  Check the manual that corresponds to your MySQL server version for the right syntax to use near 'character set latin1 NOT NULL,
   bodytext text character set
 
BamBamPSK
Regular
Regular


Joined: Nov 11, 2003
Posts: 61

PostPosted: Wed Jan 21, 2004 10:17 pm Reply with quote

i have noticed that when doing a back up from the admin panel on the site itself the file is empty and no db gets stored......correct me if im wrong but it has happened every time i did it thru the admin panel on the site

_________________
Image 
View user's profile Send private message
dark-dude
PostPosted: Wed Jan 21, 2004 10:17 pm Reply with quote

Ok removed nuke_autonews table and went again and get this:
Code:
Error


SQL-query : 

CREATE TABLE nuke_bannerclient(

cid int( 11 ) NOT NULL AUTO_INCREMENT ,
name varchar( 60 ) CHARACTER SET latin1 NOT NULL ,
contact varchar( 60 ) CHARACTER SET latin1 NOT NULL ,
email varchar( 60 ) CHARACTER SET latin1 NOT NULL ,
login varchar( 10 ) CHARACTER SET latin1 NOT NULL ,
passwd varchar( 10 ) CHARACTER SET latin1 NOT NULL ,
extrainfo text CHARACTER SET latin1 NOT NULL ,
PRIMARY KEY ( cid ) ,
KEY cid( cid )
)

MySQL said:


#1064 - You have an error in your SQL syntax.  Check the manual that corresponds to your MySQL server version for the right syntax to use near 'character set latin1 NOT NULL,
   PRIMARY KEY (cid),
   KEY c
and goes on and on :/
 
dark-dude
PostPosted: Wed Jan 21, 2004 10:20 pm Reply with quote

mine has all the tables.....they just error when I try to reload em
 
dark-dude
PostPosted: Wed Jan 21, 2004 10:22 pm Reply with quote

Quote:
BamBamPSK Posted: Thu Jan 22, 2004 2:17 pm Post subject:

--------------------------------------------------------------------------------

i have noticed that when doing a back up from the admin panel on the site itself the file is empty and no db gets stored......correct me if im wrong but it has happened every time i did it thru the admin panel on the site
it should save the whole DB for you.
 
Raven
Site Admin/Owner


Joined: Aug 27, 2002
Posts: 17086

PostPosted: Wed Jan 21, 2004 10:28 pm Reply with quote

I was checking the default nuke sql and this setup 'CHARACTER SET latin1' is not in there. Just as an experiment, delete all occurences of 'CHARACTER SET latin1' and see what happens.
 
View user's profile Send private message
dark-dude
PostPosted: Wed Jan 21, 2004 10:36 pm Reply with quote

wow i did a replace on the whole file replacing CHARACTER SET latin1 with blank and saved it and it took it right off.....thanks raven you da man again. Hope all my info is there now hehe
 
Display posts from previous:       
Post new topic   Reply to topic    Ravens PHP Scripts And Web Hosting Forum Index -> How To's

View next topic
View previous topic
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum


Powered by phpBB © 2001-2007 phpBB Group
All times are GMT - 6 Hours
 
Forums ©