Ravens PHP Scripts: Forums
 

 

View next topic
View previous topic
Post new topic   Reply to topic    Ravens PHP Scripts And Web Hosting Forum Index -> Themes
Author Message
dubLeE
Regular
Regular


Joined: Jan 12, 2006
Posts: 60

PostPosted: Sat Feb 18, 2006 11:34 am Reply with quote

ok for the past 2+ weeks i been coding a theme i made and i basically just editted and what not the code from another theme and worked from there, since im not that experienced in PHP yet but im getting there... anyways im having a problem with spacing...and i tried many many things yet nothing seems to work...
Only registered users can see links on this board! Get registered or login! is where im setting the theme up... as you can see theres a space between the open table thing at the top and the story content...

also theres another spacing problem between the blocks, theres a 1 pixel gap there that i dont want...

so is anyone available to help me...
i dont think id be allowed to paste the theme.php code here since the theme im messing around is from a commercial theme...

preferably MSN or AIM would work...any coders experianced in Nuke theming please help me...

MSN: Only registered users can see links on this board! Get registered or login!
AIM: nXxdubLeExL

thanks
 
View user's profile Send private message Visit poster's website AIM Address MSN Messenger
fkelly
Former Moderator in Good Standing


Joined: Aug 30, 2005
Posts: 3312
Location: near Albany NY

PostPosted: Sat Feb 18, 2006 8:06 pm Reply with quote

Hard to diagnose this without seeing the code to the theme. Try doing a view source on the output and see where the extra spacing is, then work backwards to see what PHP code generates that. You could even capture the html code thru view source and put it in an editor and edit it just to try to narrow down where the problem lies (keep saving and viewing in a browser), then work back thru the PHP that generates the html.

I took a quick look at view source of your page and I see some br's where maybe you wouldn't want them? It would also be helpful if you would post more specifically where your perceived problems are. It looks like you are saying there is a gap after the characters asd at the bottom of the message but I can't be sure. A 1px gap would be hard to even notice, maybe you could be more specific about where that is?
 
View user's profile Send private message Visit poster's website
dubLeE
PostPosted: Sat Feb 18, 2006 9:04 pm Reply with quote

yeah i saw the br and i tried removing ALL br's from the code but that didnt work...

heres a screenshot... Only registered users can see links on this board! Get registered or login!
(disregaurd the other half of the screenshot, didnt realize itll screenshot both of my moniters...)

see in circle 1, theres 2 lines there... theres a 1+ px gap there... it looks like its the image but its not because i made the that entire section have a bgcolor...

and then the space in circle 2 which shows a br in the view source but taking out all the br's didnt work eight...

can you contact me on AIM or MSN or me contact you...

heres a link to my coding... i wasnt able to post the code into the post... kept saying the html tags werent allowed even though i put the code tags around it all Only registered users can see links on this board! Get registered or login!

thanks
 
fkelly
PostPosted: Sun Feb 19, 2006 9:50 am Reply with quote

HI:

What you have posted may be useful if there is someone out there who is very familiar with themes and who can spend some time on it. I've mucked a bit with themes but by no means am an expert and I'm up to my eyeballs in other stuff right now.

One thought I had was: this is based on a commercial theme? Does that theme work for you right out of the box and did the problems start to occur as you modified it? If so, you might want to go back to square one with the commercial theme unmodified and reintroduce your changes one at a time to determine which one is causing the problem. I know that in some theme directories where I was developing I wound up with something like a dozen different "versions" of the theme at various stages before I was finished. Introducing changes to styles in particular can cause things to move all around and I've found that "one at a time" is the best approach.

Sorry I can't be of more immediate help but what you posted will help if there is someone out there who can. Or maybe the folks who wrote the commercial version of your theme can look at it?
 
dubLeE
PostPosted: Sun Feb 19, 2006 3:03 pm Reply with quote

its an Mtechnik theme, Hybrid... and he had the spacing there already between the blocks and tables and story... so yeah its been there since the beginning.. so i tried finish up as much as i could thinking maybe itll go away or something but it didnt... but im thinking it might just be the way RavenNuke was coded because when i use the Hybrid theme alone the right blocks dont show up at all...
 
fkelly
PostPosted: Sun Feb 19, 2006 3:16 pm Reply with quote

Well I don't have Mtechnik or Ravennuke so now I have to leave you to your own devices. I don't see how the statement about right blocks fits in here though. If the theme ALWAYS had what you consider "extra" spacing in then Ravennuke wouldn't have anything to do with that. What do you mean by when you use the Hybrid theme alone? You mean on some other version of Nuke? Right blocks are usually controlled by a setting of index_file (it can be turned on or off). Most standard modules, with the exception of news I believe, have it turned off.

If Mtechnik is promoting a commercial theme that has spacing you want removed you really might do better to get (him, her?) to remove it or at least get them to look at the postings you've made and tell you what to change. They would be the experts with that theme and having other people try to figure it out might not be effective.
 
dubLeE
PostPosted: Mon Feb 20, 2006 2:01 pm Reply with quote

anyone else able to shed some light on this by any chance?
 
Guardian2003
Site Admin


Joined: Aug 28, 2003
Posts: 6793
Location: Ha Noi, Viet Nam

PostPosted: Mon Feb 20, 2006 2:44 pm Reply with quote

As fkelly pointed out, right block visibility is set with index_file but as you didnt answer his (her?) question we dont know if that fixed that particular issue.

This is a very old theme you are using, looking at the code the first open table shows an if/else logic based on the active module. One of those modules (Sections) was dropped from nuke quite some time ago, around V7.4 ish
 
View user's profile Send private message Send e-mail
dubLeE
PostPosted: Mon Feb 20, 2006 5:54 pm Reply with quote

so i should try to build off of a more modern theme?
 
Guardian2003
PostPosted: Mon Feb 20, 2006 6:37 pm Reply with quote

Which theme to use is very much a personal tatse thing. I for example absolutely hate dark themes, yet others love them.
If I had the time and needed do make a theme myself, I would base it on the current fisubice theme, however, the work involved to make it 'dark' might be more than you have time for so by all means, search around for a theme advertised to work with 7.6 and up.
 
dubLeE
PostPosted: Mon Feb 20, 2006 9:43 pm Reply with quote

i tried working with FiSubIce but i ran into alotta problems with the coding...

and turning a light theme into a dark is no problem at all, just a bunch of CSS work...

i only use the theme.php of a theme because i dont know the coding for all the variables and layouts and what not...

but yeah imma juss find a theme that is for 7.6 or up
 
dubLeE
PostPosted: Tue Feb 21, 2006 2:54 pm Reply with quote

can someone point to a site or to themes that are for 7.6+ ....

greatly appreciated
 
fkelly
PostPosted: Tue Feb 21, 2006 6:26 pm Reply with quote

Raven and his associates can address this better than I, but any themes that come with his distribution have to be for 7.6 and up. So, even if you didn't want to load the full distribution you could probably extract the themes directory in Ravennuke and work with what's in there. And heck, there's a lot of themes distributed with the official Nuke distribution from phpnuke.org and if you just chose 7.6 you'd get them. Assuming that you are patched to 3.1, I'd check the patch distribution to see if there are any fixes before I loaded the theme. Actually since I have the patch distribution on my hard drive I just did and yes there are fixes so you'll want those too. But of course the Raven distribution is already patched, I just don't know what themes are in there. Maybe some one who has it can post a list or you can just download it and see for yourself.

Incidentally your site looked great to me when I looked at it a couple days ago. You are a lot fussier than I am about graphics.
 
dubLeE
PostPosted: Thu Feb 23, 2006 4:02 pm Reply with quote

ok thanks everyone for trying to help with that last problem...in the end didnt fix it but i found a work around for it so its all good...

ok now i have run into 2 other critical problems that cant seem to fix...

first of all..as you can see in the header with the logins, well i tried using the variables ($theuser) for the login to set all that up but i couldnt figure out how i could set it all up individually so that i can have my own layout and spacing of the text boxes and what not...

and second...(you have to login for this so i made an account user: demo password: demo)
now click Your_Account... as you can most likely see its all messed up and weird looking... how would i go about fixing this...
 
Display posts from previous:       
Post new topic   Reply to topic    Ravens PHP Scripts And Web Hosting Forum Index -> Themes

View next topic
View previous topic
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum


Powered by phpBB © 2001-2007 phpBB Group
All times are GMT - 6 Hours
 
Forums ©