Ravens PHP Scripts: Forums
 

 

View next topic
View previous topic
This forum is locked: you cannot post, reply to, or edit topics.   This topic is locked: you cannot edit posts or make replies.    Ravens PHP Scripts And Web Hosting Forum Index -> Raven's RavenNuke(tm) v2.00.00 - v2.02.00 Distro
Author Message
craigmack
Hangin' Around


Joined: Jan 07, 2006
Posts: 35

PostPosted: Tue Feb 14, 2006 9:51 pm Reply with quote

Hello im using your new distro RavenNuke76 v2.02.0 and i tried to install codezwiz.com Czuser info 5 block. I got it working but not sure if this is a bug or not, the problem was the security code wouldn't show up with this code

Code:


if (extension_loaded("gd") AND ($gfx_chk == 2 OR $gfx_chk == 4 OR $gfx_chk == 5 OR $gfx_chk == 7)) {
   if ($Version_Num < 7.5) {
       $security_code_url = "modules.php?name=Your_Account&op=gfx&random_num=$random_num";
   } elseif ($Version_Num >= 7.5) {
       $security_code_url = "?gfx=gfx&random_num=$random_num";
   }


So i changed it to this and it works fine

Code:


if (extension_loaded("gd") AND ($gfx_chk == 2 OR $gfx_chk == 4 OR $gfx_chk == 5 OR $gfx_chk == 7)) {
   if ($Version_Num < 7.5) {
       $security_code_url = "?gfx=gfx&random_num=$random_num";
   } elseif ($Version_Num >= 7.5) {
       $security_code_url = "?gfx=gfx&random_num=$random_num";
   }


Its not showing your distro as newer then 7.5 so it was trying to use this
modules.php?name=Your_Account&op=gfx&random_num=$random_num"; and that don't work.
Hope this makes sense i'm pretty tired at this point.
 
View user's profile Send private message
Raven
Site Admin/Owner


Joined: Aug 27, 2002
Posts: 17086

PostPosted: Tue Feb 14, 2006 9:58 pm Reply with quote

The Version_Num field is not a standardized field so you can put anything you want in it. By writing code as codewiz has done, they are expecting that field to be in a standard, codified state, which it isn't. So, whatever you have to do to get a third party addon to work, go for it. If it were me, since I know I'm using v7.6, I'd just remove that if/elseif logic altogether as your modified code is working because it is not understanding what is in there - it's not really working the way he designed it to. You cannot depend on that field for logic checking as he has designed it.
 
View user's profile Send private message
craigmack
PostPosted: Tue Feb 14, 2006 10:06 pm Reply with quote

Whatever it takes sounds good to me. I was just telling you because i have 2 other sites that don't run your distro and i didn't have to change nothing so i didn't know if it was a bug or not.
 
Raven
PostPosted: Tue Feb 14, 2006 10:10 pm Reply with quote

And I appreciate you letting me know. That's just another little gem to know in the event we come across one of those things that we just can't explain Wink
 
zbv2net
New Member
New Member


Joined: Feb 26, 2007
Posts: 13

PostPosted: Wed Mar 21, 2007 8:03 am Reply with quote

any one knows how to make it to run on raven nuke 2.10.00
 
View user's profile Send private message
Display posts from previous:       
This forum is locked: you cannot post, reply to, or edit topics.   This topic is locked: you cannot edit posts or make replies.    Ravens PHP Scripts And Web Hosting Forum Index -> Raven's RavenNuke(tm) v2.00.00 - v2.02.00 Distro

View next topic
View previous topic
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum


Powered by phpBB © 2001-2007 phpBB Group
All times are GMT - 6 Hours
 
Forums ©