Ravens PHP Scripts: Forums
 

 

View next topic
View previous topic
Post new topic   Reply to topic    Ravens PHP Scripts And Web Hosting Forum Index -> WYSIWYG - Raven's RavenNuke(tm) v2.x Distro
Author Message
Duncan
New Member
New Member


Joined: Dec 21, 2005
Posts: 21

PostPosted: Tue Jan 31, 2006 2:22 pm Reply with quote

First of all let me say how great I think this integration is. Well done!

When I try editing stories that have already been made before this FCK integration was installed, the images do not appear in the editor - only the image box/holder. Is this right or have I done something wrong?

Images appear when I write a new article in the wsyiwyg interface and upload the images within that.

Any ideas or is there no way around that?

Cheers for all the hard work

Duncan
Glasgow, Scotland
 
View user's profile Send private message
Guardian2003
Site Admin


Joined: Aug 28, 2003
Posts: 6792
Location: Ha Noi, Viet Nam

PostPosted: Tue Jan 31, 2006 3:30 pm Reply with quote

In the image properties, double check the path to the image files location and amend it if needed.
 
View user's profile Send private message Send e-mail
Duncan
PostPosted: Tue Jan 31, 2006 3:48 pm Reply with quote

Thanks for the quick response!

I checked the path to the image files and they are ../folder/image.jpg or similar. All are tied to the root in this manner and NOT listed as full paths. Is this the problem?

Like to know you thoughts on this.
 
Guardian2003
PostPosted: Tue Jan 31, 2006 3:54 pm Reply with quote

I dont think disclosing the full path or not is the casue of the problem, it might be something simple like the editor having a predefined path that it uses for its 'default' image location.
I have not had much time to play with this side of the editor.
I presume the image does actually exist at the location it is pointing too?
 
Duncan
PostPosted: Tue Jan 31, 2006 4:14 pm Reply with quote

The image sure does exist and displays fine on the site. As soon as I enter the full path to the image it displays fine in the editor!

eg. Only registered users can see links on this board! Get registered or login! - it works!!!!
eg. Only registered users can see links on this board! Get registered or login! - doesn't work
eg. ../imagefolder/image.jpg - doesn't work

Don't know if this something that can be worked around as I like my images linked to the site root?


-------------

Also wondering if in Image Properties>browse - if it is possible to add an easily accesible Fav image folder(s) to allow easy access to images that are already uploaded to a folder on the server. I tend to keep my images in an ../images folder and that makes it easy to link to from various articles over time.

I suppose I could dump all those pics into the designated folder in ../includes/etc..? Are these images safe from being changed or deleted by others, once uploaded to this folder? My folder and files are chmodded to 777 as suggested and it makes me nervous. :$

Cheers

Duncan
Glasgow, Scotland
 
kguske
Site Admin


Joined: Jun 04, 2004
Posts: 6383

PostPosted: Sat Oct 28, 2006 6:49 am Reply with quote

There is a setting in the includes/FCKeditor/fckconfig.js called FCKConfig.BaseHref. You can see this to one of two values with mixed results.

It can either be set to your root URL:
Code:
FCKConfig.BaseHref = 'http://www.yourdomain.com' ;

or it can be set to '../'. This allows images with relative paths (e.g. "/imagefolder/image.jpg") to be properly displayed when you are adding images - if the path is relative to the root path AND only in FireFox. IE 6 just doesn't work for some reason.

Also, there is a commented out section of code in includes/FCKeditor/editor/dialog/fck_image/fck_image.js:
Code:
   // TODO: Wait stable version and remove the following commented lines.

//   if ( sUrl.startsWith( FCK.BaseUrl ) )
//      sUrl = sUrl.remove( 0, FCK.BaseUrl.length ) ;

You can uncomment that, but again, it doesn't work with IE. This allows the image, again, defined with a path relative to the root, to be displayed when previewing the HTML. Since that wasn't removed in the final version of 2.0, I wonder if by "stable version" the author meant stable browser version since it seems to work fine in FF, but not IE.

I am testing this with IE 7 and I hope to test some other alternatives I've seen. I'm also hoping to start testing FCKeditor 2.3.2 soon to see what issues have been resolved since 2.0 and 2.3.1.

_________________
I google, therefore I exist...
Only registered users can see links on this board! Get registered or login!
 
View user's profile Send private message
kguske
PostPosted: Fri Dec 22, 2006 11:50 pm Reply with quote

Testing with 2.3.2, we can override the BaseHref parameter with ../ in fckeditor.js and it appears to allow consistent image display (at least with FF 1.5 and IE 6), as long as the image is preceeded with a /.

The testing is coming along nicely, and we hope to release an update soon.
 
Display posts from previous:       
Post new topic   Reply to topic    Ravens PHP Scripts And Web Hosting Forum Index -> WYSIWYG - Raven's RavenNuke(tm) v2.x Distro

View next topic
View previous topic
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum


Powered by phpBB © 2001-2007 phpBB Group
All times are GMT - 6 Hours
 
Forums ©