Ravens PHP Scripts: Forums
 

 

View next topic
View previous topic
This forum is locked: you cannot post, reply to, or edit topics.   This topic is locked: you cannot edit posts or make replies.    Ravens PHP Scripts And Web Hosting Forum Index -> Raven's RavenNuke(tm) v2.00.00 - v2.02.00 Distro
Author Message
riftmage
New Member
New Member


Joined: Jan 11, 2006
Posts: 1

PostPosted: Wed Jan 11, 2006 9:02 am Reply with quote

Hi,

I had downloaded the new RavenNuke76 v2.02.00 FULL distro pack and tried to do a full installation using the instructions in the QUICKINSTALL guild.

When I was doing step 1 in installSQL.php, I the following error was reported at the bottom of the page.

------------------------------------------------
ERROR! The exact error message that your MySQL server reported is You have an error in your SQL syntax near '; ' at line 1.
------------------------------------------------


I had tried to redownload the package again and upload it but still got teh same error. Anyone able to help on this?
 
View user's profile Send private message
montego
Site Admin


Joined: Aug 29, 2004
Posts: 9449
Location: Arizona

PostPosted: Wed Jan 11, 2006 9:18 pm Reply with quote

riftmage, I would try to FTP the installSQL.php script file again. It sounds to me like maybe it is corrupted? Try forcing your FTP client to use ASCII on the upload and see if that fixes it. I am thinking there may be ^M characters on each line of the file due to the FTP being set to binary.

_________________
Only registered users can see links on this board! Get registered or login!
Only registered users can see links on this board! Get registered or login! 
View user's profile Send private message Visit poster's website
Darrell3831
Worker
Worker


Joined: Feb 18, 2004
Posts: 244

PostPosted: Thu Jan 12, 2006 8:52 pm Reply with quote

I'm having the same problem...

Quote:
ERROR! The exact error message that your MySQL server reported is You have an error in your SQL syntax near '; ' at line 1.


Immediately after pressing Install core files that error appears at the bottom of the page.

RN 7.6/2.0, unix, mysql...

I have reuploaded, forcing ASCII with no change...

The top of the page reports that it can connect to the database.

Quote:
MySQL Database Connectivity Test Results

config.php file found!
Successfully connected to localhost as user test and assigned password!


Raven, could this be that non stardard characters in a db name?? Not being enclosed in back ticks??

Thanks,
Darrell

_________________
Only registered users can see links on this board! Get registered or login! 
View user's profile Send private message Visit poster's website
Raven
Site Admin/Owner


Joined: Aug 27, 2002
Posts: 17077

PostPosted: Thu Jan 12, 2006 11:00 pm Reply with quote

All tables are enclosed in back ticks. What version of MySQL are you using? It sounds like your version is not handling comments that start with -- .
 
View user's profile Send private message
Darrell3831
PostPosted: Fri Jan 13, 2006 6:33 am Reply with quote

Database: MySQL 3.23.58

-----

Server OS: Linux 2.4.20-13.9ensim.smp-3.5.0-14

HTTP Server: Apache/1.3.31 (Unix) (Red-Hat/Linux) mod_jk/1.2.1-beta-1 mod_perl/1.29 PHP/4.3.8 FrontPage/5.0.2.2635 mod_ssl/2.8.18 OpenSSL/0.9.7a mod_fastcgi/2.4.0

PHP Version: 4.3.8 (Zend: 1.3.0)

-----

So if this is the case, what search and replace strings would clear them all out??

Thanks,
Darrell
 
Raven
PostPosted: Fri Jan 13, 2006 8:42 am Reply with quote

Oh - My - Goodness, is all I can say about your host. I thought I had added all the code to get rid of the comments for all releases but I'd better go back over it again.

Try changing all -- (Note the space after the -- ) at the beginning of a line to ## (Again, there is a space after the ## ).
 
Darrell3831
PostPosted: Fri Jan 13, 2006 11:06 am Reply with quote

I changed all of (-- ) to (## ) and that still left a few of just (--) so I even changed them to old style comments too. (##)

But, that only changed the install error to this.

Quote:
ERROR! The exact error message that your MySQL server reported is Query was empty.
 
Raven
PostPosted: Fri Jan 13, 2006 11:14 am Reply with quote

Looks like you deleted something extra. The query wasn't recognized.
 
Darrell3831
PostPosted: Fri Jan 13, 2006 12:03 pm Reply with quote

Well...

I went back to the original .sql file (rn76_core_pl31.SQL) and tried to import it via phpMyAdmin.

This is the error I got doing that:

Quote:
Error

SQL-query :

CREATE TABLE `nuke_subscriptions` (

`id` int( 10 ) NOT NULL AUTO_INCREMENT ,
`userid` int( 10 ) default '0',
`subscription_expire` varchar( 50 ) NOT NULL default '',
PRIMARY KEY `id` ( `id` , `userid` )
) TYPE = MYISAM

MySQL said:


#1171 - All parts of a PRIMARY KEY must be NOT NULL; If you need NULL in a key, use UNIQUE instead



It's not the same error reported back through your installer script.. Totall different, but same file...

Darrell
 
Raven
PostPosted: Fri Jan 13, 2006 1:26 pm Reply with quote

What version of phpMyAdmin are you using? I think you are using really old versions of everything. Seriously, consider a new host. The versions of software that you are running are still prone to exploits that have been fixed in the later releases.
 
Darrell3831
PostPosted: Fri Jan 13, 2006 1:33 pm Reply with quote

It's 2.5.6.
 
Raven
PostPosted: Fri Jan 13, 2006 1:34 pm Reply with quote

You need, at the very minimum, to get your MySQL and phpMyAdmin up to date.
 
jdimaging
Hangin' Around


Joined: Oct 25, 2003
Posts: 27

PostPosted: Fri Jan 13, 2006 2:57 pm Reply with quote

I got the same problem on the install, so I tried just using the sql file and doing it manually but guess I can't do that. Has there been any fix as of yet as am not sure what -- or ## means. Your help would be appreciated.

Darlene
 
View user's profile Send private message Send e-mail
DC_IronMan
New Member
New Member


Joined: Nov 15, 2005
Posts: 14

PostPosted: Fri Jan 13, 2006 4:22 pm Reply with quote

Ok I am getting the same problem so I tried installing the sql file in phpmyadmin.

This is the messages I get when installing from phpmyadmin:

SQL query:

CREATE TABLE `nuke_subscriptions` (

`id` int( 10 ) NOT NULL AUTO_INCREMENT ,
`userid` int( 10 ) default '0',
`subscription_expire` varchar( 50 ) NOT NULL default '',
PRIMARY KEY `id` ( `id` , `userid` )
) TYPE = MYISAM

MySQL said:

#1171 - All parts of a PRIMARY KEY must be NOT NULL; If you need NULL in a key, use UNIQUE instead


My version of phpMyAdmin is 2.6.3-pl1

My version of MySQL is 3.23.58
 
View user's profile Send private message
Darrell3831
PostPosted: Fri Jan 13, 2006 4:27 pm Reply with quote

Ravens newer versions of software are exporting .sql files that our older versions of software can't import guys...
 
DC_IronMan
PostPosted: Fri Jan 13, 2006 5:02 pm Reply with quote

Ok I changed this:
Code:
--

-- Table structure for table `nuke_subscriptions`
--

DROP TABLE IF EXISTS `nuke_subscriptions`;
CREATE TABLE `nuke_subscriptions` ( `id` int(10) NOT NULL auto_increment, `userid` int(10) default '0', `subscription_expire` varchar(50) NOT NULL default '', PRIMARY KEY `id` (`id`,`userid`) ) TYPE=MyISAM;


--
-- Dumping data for table `nuke_subscriptions`
--


to:

Code:
--

-- Table structure for table `nuke_subscriptions`
--

DROP TABLE IF EXISTS `nuke_subscriptions`;
CREATE TABLE `nuke_subscriptions` ( `id` int(10) NOT NULL auto_increment, `userid` int(10) default '0', `subscription_expire` varchar(50) NOT NULL default '',  KEY `id` (`id`,`userid`) ) TYPE=MyISAM;


--
-- Dumping data for table `nuke_subscriptions`
--

and

change -- to #


Then install the sql file with phpmyadmin and it work.

Is this ok
 
Raven
PostPosted: Fri Jan 13, 2006 7:15 pm Reply with quote

A better fix would be to change `userid` int(10) default '0' to `userid` int(10) default '0' NOT NULL
 
Display posts from previous:       
This forum is locked: you cannot post, reply to, or edit topics.   This topic is locked: you cannot edit posts or make replies.    Ravens PHP Scripts And Web Hosting Forum Index -> Raven's RavenNuke(tm) v2.00.00 - v2.02.00 Distro

View next topic
View previous topic
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum


Powered by phpBB © 2001-2007 phpBB Group
All times are GMT - 6 Hours
 
Forums ©