Ravens PHP Scripts: Forums
 

 

View next topic
View previous topic
Post new topic   Reply to topic    Ravens PHP Scripts And Web Hosting Forum Index -> Blocks
Author Message
recep
Hangin' Around


Joined: Dec 11, 2005
Posts: 44

PostPosted: Mon Jan 02, 2006 12:26 pm Reply with quote

Hello pals, l have a request from you at all, l am tring to set a new web site in Only registered users can see links on this board! Get registered or login! but l have a problem, my browser ( Firefox ) doesnt show the security code Image and l dont know how to fix this problem, Can somebody Help me please..
yes l have made a resources on forums in last posts..
l am using php-nuke 7.6-3.1
 
View user's profile Send private message
montego
Site Admin


Joined: Aug 29, 2004
Posts: 9449
Location: Arizona

PostPosted: Mon Jan 02, 2006 1:02 pm Reply with quote

recep, this is not showing in IE either. This has been addressed numerous time here. Please read the following before posting:
Only registered users can see links on this board! Get registered or login!

I am sure your answer will be in the Nuke FAQs referenced in this READ ME FIRST post.

Thanks

_________________
Only registered users can see links on this board! Get registered or login!
Only registered users can see links on this board! Get registered or login! 
View user's profile Send private message Visit poster's website
recep
PostPosted: Mon Jan 02, 2006 1:46 pm Reply with quote

montego wrote:
recep, this is not showing in IE either. This has been addressed numerous time here. Please read the following before posting:
Only registered users can see links on this board! Get registered or login!

I am sure your answer will be in the Nuke FAQs referenced in this READ ME FIRST post.

Thanks

Quote:
First of all, make sure that you do NOT have the Your Account Module set for Registered Users Only, as it is then impossible to ever register!

Make sure you have the GD package installed. Save this script to a file and call it phpinfo.php
and then run it. That will show whether you have GD installed.

Assuming you have the GD package installed, the most often cause is a blank space/line either before or after the php tags in your config.php, one of your language files, theme file, or some other include file. This is usually the result of using Notepad or Wordpad. You need to use a better programmer's editor like Textpad.
[ Back to Top ]

· How do I adjust the server time for News articles?

In mainfile.php, find the function formatTimestamp(). Assuming it resembles this code

function formatTimestamp($time) {
global $datetime, $locale;
setlocale (LC_TIME, $locale);
ereg ("([0-9]{4})-([0-9]{1,2})-([0-9]{1,2}) ([0-9]{1,2})Sad[0-9]{1,2})Sad[0-9]{1,2})", $time, $datetime);
$datetime = strftime(""._DATESTRING."", mktime($datetime[4],$datetime[5],$datetime[6],$datetime[2],$datetime[3],$datetime[1]));
$datetime = ucfirst($datetime);
return($datetime);
}

Modify it to this. Note the -15? That is the number of hours to offset the timestamp.

function formatTimestamp($time) {
global $datetime, $locale;
setlocale (LC_TIME, $locale);
ereg ("([0-9]{4})-([0-9]{1,2})-([0-9]{1,2}) ([0-9]{1,2})Sad[0-9]{1,2})Sad[0-9]{1,2})", $time, $datetime);
$datetime = strftime(""._DATESTRING."", mktime(($datetime[4]-15),$datetime[5],$datetime[6],$datetime[2],$datetime[3],$datetime[1]));
$datetime = ucfirst($datetime);
return($datetime);
}

Friend, Yeah l have read as l think the post about it but l still cant understand, l think l am some idiot; Do u have any idiots guide Sad for my solution, ofcourse this is not an order, if you know and mind to help.
thanks for ur interest.
Do l must to change the your account codes or something else ?
 
montego
PostPosted: Mon Jan 02, 2006 4:35 pm Reply with quote

recep, just wanted to make sure you took the time to read up a little on the rules of these Forums and go through some of the common FAQs that have already been painstakingly put together by Raven and others. You had submitted too posts in a row which both looked like common issues and already addressed. Just wanted you to understand better why my two posts to "read" and "search".

Now, for your issue. Break it down one step at a time.


1) First of all, make sure that you do NOT have the Your Account Module set for Registered Users Only, as it is then impossible to ever register!


This one is easy. When you are in the Administration Contract Panel (ACP), click on "Modules" and make sure the module named "Your Account" is set for "All Visitors" and NOT "Registered Users Only".

Lets take this for our next one:


Assuming you have the GD package installed, the most often cause is a blank space/line either before or after the php tags in your config.php, one of your language files, theme file, or some other include file. This is usually the result of using Notepad or Wordpad. You need to use a better programmer's editor like Textpad.


I would do as Raven has suggested and use a tool such as Textpad (http://www.textpad.com), or UltraEdit, ... there are others, just cannot remember them right now. Make sure there is NO blank line before the starting <?php statement at the top and NO blank line after the ending ?> statement within your config.php file.

Unfortunately, the next one is a little harder -- for me -- as I have not installed GD before. My hosts have always had it installed.

Make sure you have the GD package installed. Save this script to a file and call it phpinfo.php
and then run it. That will show whether you have GD installed.


Create a file -- give it whatever name that is not already in your root web directory -- with only the following lines in it:

Code:


<?php
phpinfo();
?>


Upload it to the roo web directory for your site and then from the browser go to this link:

http://www.yourdomain.com/filename.php

Substitute the proper URL and file you created above. Look for a section headed up with "gd" and somewhere in the table below it it should say it is enabled.
 
recep
PostPosted: Tue Jan 03, 2006 1:08 pm Reply with quote

dear montego l did what u ordered, Editited by Moderator: removed link
as you can see gd is supported, so what now than, help me about it pls.
thanksssss..
 
montego
PostPosted: Tue Jan 03, 2006 1:51 pm Reply with quote

recep, please remove that file IMMEDIATELY from your web root! I had not requested that you post the link, just to check that it was enabled. That particular script gives potential hackers too much information.

I am at work right now and cannot help you further until later. I will PM Raven and see if he is able to assist in the meantime.
 
Raven
Site Admin/Owner


Joined: Aug 27, 2002
Posts: 17077

PostPosted: Tue Jan 03, 2006 2:21 pm Reply with quote

I tried your link in your first post and I see the security code in the right hand block.
 
View user's profile Send private message
recep
PostPosted: Tue Jan 03, 2006 3:27 pm Reply with quote

OKey pals, l have solved the problems, thanks for your interetsssssssss........
 
Raven
PostPosted: Tue Jan 03, 2006 5:45 pm Reply with quote

We request that when a problem is solved after we have offered up all known solutions that you post how you solved it. That way we can better help in the future. Thanks.
 
recep
PostPosted: Sat Jan 07, 2006 6:36 am Reply with quote

Raven wrote:
We request that when a problem is solved after we have offered up all known solutions that you post how you solved it. That way we can better help in the future. Thanks.

dear raven you are abloutely right, l have had to tell you the problem l have met.
first of all if you have had a problem in your complated site which doesnt sho any problem and than starts showing problems after you install something or add something into your site, firstly you have to look the last changes on your site, becouse there would be some comples scritps and java codes which cant work properly together.
thats how l solved my problem.
l have looked the last changes on my site, l have added a java code into index.php file and after l remove this script. code started being shown.
l am very pleased to get help from you (Montego+raven).
you are best in this job.
thankssssss
 
recep
PostPosted: Sat Jan 07, 2006 6:39 am Reply with quote

actually l forgot to thanks mentego about his important securing advices..
thanks montego friend.
 
montego
PostPosted: Sat Jan 07, 2006 8:45 am Reply with quote

No problem recept. That is what we are here for. Thanks for the reply.

RavensScripts
 
Display posts from previous:       
Post new topic   Reply to topic    Ravens PHP Scripts And Web Hosting Forum Index -> Blocks

View next topic
View previous topic
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum


Powered by phpBB © 2001-2007 phpBB Group
All times are GMT - 6 Hours
 
Forums ©