Ravens PHP Scripts: Forums
 

 

View next topic
View previous topic
This forum is locked: you cannot post, reply to, or edit topics.   This topic is locked: you cannot edit posts or make replies.    Ravens PHP Scripts And Web Hosting Forum Index -> Raven's RavenNuke(tm) v1.x Distro
Author Message
Susann
Moderator


Joined: Dec 19, 2004
Posts: 3191
Location: Germany:Moderator German NukeSentinel Support

PostPosted: Sun Dec 18, 2005 8:01 am Reply with quote

I´ve checked the backend.php but whenever I click on the backend.php I get a XML error.

The result from: Only registered users can see links on this board! Get registered or login!

This feed does not validate.

line 23, column 321: Undefined named entity: auml (9 occurrences).

This means I have a problem with the German ä,ü,ö. I ´don´t like to write ae instead of ä or ue for ü.Is there any other solution for this problem ?
 
View user's profile Send private message
hitwalker
Sells PC To Pay For Divorce


Joined:
Posts: 5661

PostPosted: Sun Dec 18, 2005 10:24 am Reply with quote

Hello susann,
i could find your problem a few times....and all mention the german characters,and the encoding problem.

Maybe this explains some..
Only registered users can see links on this board! Get registered or login! Only registered users can see links on this board! Get registered or login! Only registered users can see links on this board! Get registered or login!

But i also read that it could be a bug in the validator as well.

And a litle story howto deal with it or solve it..... Only registered users can see links on this board! Get registered or login!
 
View user's profile Send private message
Susann
PostPosted: Sun Dec 18, 2005 10:42 am Reply with quote

I was only wondering that I´ve never had this problem before with my backend.php in Nuke 6.5.
But very interested links. Thanks Hitwalker.
 
hitwalker
PostPosted: Sun Dec 18, 2005 11:17 am Reply with quote

well i asume you checked your backend before...so maybe something has changed from your side...
 
Susann
PostPosted: Mon Dec 19, 2005 8:50 am Reply with quote

I did´t check the backend.php after install. So I don´t know exactly since when this problem exist. But I´m using the original backend.php however have checked some other validators after I changed the ä and the ß and indeed I´ve got some other results. Was something like this RSS feed validates !" or "This Page Is Valid -//Netscape Communications//DTD RSS 0.91//EN!
XML
Used Charset:
US-ASCII
Source:
Fallback
Only registered users can see links on this board! Get registered or login! is now my favorite, because my feed is valid there !
Only registered users can see links on this board! Get registered or login! I´ve got:

"missing "charset" attribute for "text/xml" document.

The HTTP Content-Type header (text/xml) sent by your web server (Apache/1.3.27 (Linux/SuSE) did not contain a "charset" parameter, but the Content-Type was one of the XML text/* sub-types.

The relevant specification (RFC 3023) specifies a strong default of "us-ascii" for such documents so we will use this value regardless of any encoding you may have indicated elsewhere.

If you would like to use a different encoding, you should arrange to have your server send this new encoding information."

Ok, I `added the charset into the line:

header("Content-Type: text/xml;charset=iso-8859-1");


But couldn´t solve my ä,ü,ö,ß problem.
 
hitwalker
PostPosted: Mon Dec 19, 2005 8:58 am Reply with quote

ah but this should help also... Only registered users can see links on this board! Get registered or login!
 
Susann
PostPosted: Mon Dec 19, 2005 9:38 am Reply with quote

Thanks for the link.It´s a very helpful address. I´ve spent yesterday a lot of time with your links above and I have read about different RSS problems and enties at Only registered users can see links on this board! Get registered or login!

But you can read and don´t understand anything, you know that´s the problem. Well, I hope I can fix this after christmas.
 
FireATST
RavenNuke(tm) Development Team


Joined: Jun 12, 2004
Posts: 637
Location: Ohio

PostPosted: Mon Dec 19, 2005 10:52 am Reply with quote

hitwalker wrote:
well i asume you checked your backend before...



Now hitman, that line got my attention.....lol.... killing me
 
View user's profile Send private message Visit poster's website MSN Messenger ICQ Number
Susann
PostPosted: Mon Dec 19, 2005 6:41 pm Reply with quote

Found my solution with RSS 2.0 works perfect also with Sage RSS Reader for Firefox.
Only registered users can see links on this board! Get registered or login!

I only have to google tap the links. Very Happy
 
cacat
Hangin' Around


Joined: Nov 23, 2005
Posts: 43

PostPosted: Wed Dec 21, 2005 2:11 am Reply with quote

i have even a simpler solution, just download phpnuke 7.8 and replace you have wih the one from the new distribution.
works like acharm
 
View user's profile Send private message
Susann
PostPosted: Wed Dec 21, 2005 5:53 am Reply with quote

Well, it´s my GT testsite and it´s only a question of time to find out why the backend.php doesn´t work with ä,ü,ß. I´m not interested in higher Nuke versions.
 
cacat
PostPosted: Wed Dec 21, 2005 9:50 am Reply with quote

what i meant to said is download 7.8 and use the file backend.php from there and ONLY that file. nothing else. give it a try, it worked for my site (we use a lot of ø)
i am using ravens 7.6 with the backend.php from 7.8
 
Raven
Site Admin/Owner


Joined: Aug 27, 2002
Posts: 17086

PostPosted: Wed Dec 21, 2005 10:14 am Reply with quote

Susann, if you can verify that cacat's suggestion works for you, I will modify the next release to include the v7.8 backend.php file.
 
View user's profile Send private message
Susann
PostPosted: Wed Dec 21, 2005 4:50 pm Reply with quote

Really, I don´t believe it! How is this possible ? I´ve deinstalled my GT completly.Checked the original backend.php from the distro and the new 7.8 backend.php from a German site but always with the same errors.
Ok, now the surprise I have just downloaded the 7.8 from nuke.org and it works perfect.Cacat you are the hero of the day ! Thanks a lot.
Cheers
 
cacat
PostPosted: Wed Dec 21, 2005 5:18 pm Reply with quote

LOL, thank you

Wave
 
Raven
PostPosted: Wed Dec 21, 2005 9:12 pm Reply with quote

I just ran a compare and I see that htmlentities() and htmlspecialchars() have been swapped in the 3.1 patches. That's my guess as to the problem right there. But, there are other safety issues in 7.8 that you do need, so don't just throw the baby out with the bath water. Here is a Unix diff report.

16d15
< include("includes/ipban.php");
19,22c18,21
< $cat = intval($cat);
< if ($catid == "") {
< $catid = $db->sql_fetchrow($db->sql_query("SELECT catid FROM ".$prefix."_stories_cat WHERE title LIKE '%$cat%' LIMIT 1"));
< if ($cat != "") {
---
> if (isset($cat) && !empty($cat)) {
> $cat = htmlentities($cat);
> list($catid) = $db->sql_fetchrow($db->sql_query("SELECT catid FROM ".$prefix."_stories_cat WHERE title LIKE '%$cat%' LIMIT 1"));
> if (empty($catid)) {
37c36
< echo "<title>".htmlspecialchars($sitename)."</title>\n";
---
> echo "<title>".htmlentities($sitename)."</title>\n";
39c38
< echo "<description>".htmlspecialchars($backend_title)."</description>\n";
---
> echo "<description>".htmlentities($backend_title)."</description>\n";
42,43c41,42
< while ($row = $db->sql_fetchrow($result)) {
< $rsid = intval($row['sid']);
---
> while (list($rsid, $rtitle, $rtext) = $db->sql_fetchrow($result)) {
> $rsid = intval($rsid);
44,45d42
< $rtitle = $row['title'];
< $rtext = $row['hometext'];
47c44
< echo "<title>".htmlspecialchars($rtitle)."</title>\n";
---
> echo "<title>".htmlentities($rtitle)."</title>\n";
49c46
< echo "<description>".htmlspecialchars($rtext)."</description>\n";
---
> echo "<description>".htmlentities($rtext)."</description>\n";
 
Susann
PostPosted: Thu Dec 22, 2005 4:53 pm Reply with quote

This is a valid RSS feed ! My problem is fixed.Very Happy Thank you ! But why should I use the line: include("includes/ipban.php"); ?
 
Display posts from previous:       
This forum is locked: you cannot post, reply to, or edit topics.   This topic is locked: you cannot edit posts or make replies.    Ravens PHP Scripts And Web Hosting Forum Index -> Raven's RavenNuke(tm) v1.x Distro

View next topic
View previous topic
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum


Powered by phpBB © 2001-2007 phpBB Group
All times are GMT - 6 Hours
 
Forums ©