Ravens PHP Scripts: Forums
 

 

View next topic
View previous topic
This forum is locked: you cannot post, reply to, or edit topics.   This topic is locked: you cannot edit posts or make replies.    Ravens PHP Scripts And Web Hosting Forum Index -> Raven's RavenNuke(tm) v1.x Distro
Author Message
SPJeff69
Regular
Regular


Joined: Oct 25, 2004
Posts: 53

PostPosted: Thu Dec 15, 2005 1:31 pm Reply with quote

I just upgraded from 7.6 to raven 7.6 and I can't access my admin.php

The page comes up completely blank. I think it may have something to do with Sentinel, but I am not sure. This is bad because I disabled my site via Sentinel when I started to do the upgrade!

EDIT

Also if I try to access forum admin directly, I get this error.

Code:
Warning: main(config.php): failed to open stream: No such file or directory in /home/***/public_html/includes/sentinel.php on line 46


Fatal error: main(): Failed opening required 'config.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/***/public_html/includes/sentinel.php on line 46


Edit 2

To add to my problems, when I check the error log in cpanel, I see this error:
Code:
Error parsing /home/***/public_html/php.ini on line 3

 
View user's profile Send private message
hitwalker
Sells PC To Pay For Divorce


Joined:
Posts: 5661

PostPosted: Thu Dec 15, 2005 5:37 pm Reply with quote

Did you uploaded all files overwriting it all?
If so the included lines in your files are gone so you have to put it back...

and the php.ini file...you touched that?
(edit:..you can enable your site again with phpmyadmin...,look for table sentinel config and set site_switch to 0)
 
View user's profile Send private message
SPJeff69
PostPosted: Thu Dec 15, 2005 8:01 pm Reply with quote

Which files do I need to restore?

I did not touch php.ini
 
Guardian2003
Site Admin


Joined: Aug 28, 2003
Posts: 6793
Location: Ha Noi, Viet Nam

PostPosted: Thu Dec 15, 2005 11:04 pm Reply with quote

It looks to me like you just uploaded the RavenNuke 7.6 files on top of existing files.
Looking at your error message, it would seem the file config.php is calling for the file includes/sentinel.php
There should not be a call to that in the config.php file and in any event the file includes/sentinel.php does not exist within the package.
The correct file to be included is includes/nukesentinel.php
Check your mainfile.php around line 149 to make sure you have
Code:
if (!defined('ADMIN_FILE') && !file_exists('includes/nukesentinel.php')) {
 
View user's profile Send private message Send e-mail
SPJeff69
PostPosted: Fri Dec 16, 2005 5:23 am Reply with quote

That line does exist in my mainfile.php

I don't see "includes/sentinel.php" in config.php either. In fact, I see nothing about sentinel.
 
hitwalker
PostPosted: Fri Dec 16, 2005 6:06 am Reply with quote

Well there isnt any sentinel related line in config....so thats ok...
Maybe you can give an url we can look at..
 
SPJeff69
PostPosted: Fri Dec 16, 2005 9:48 am Reply with quote

amdusers.com
 
hitwalker
PostPosted: Fri Dec 16, 2005 9:50 am Reply with quote

well we cant see much if its closed..
 
SPJeff69
PostPosted: Fri Dec 16, 2005 9:54 am Reply with quote

There ya go.
 
hitwalker
PostPosted: Fri Dec 16, 2005 1:39 pm Reply with quote

well this way its hard to help cause its blank..
if this is an upgrade its likely you forgot something...
otherwise it shouldnt turn blank....
 
Raven
Site Admin/Owner


Joined: Aug 27, 2002
Posts: 17086

PostPosted: Fri Dec 16, 2005 1:43 pm Reply with quote

You did not install this correctly. Remove this line from mainfile.php include includes/sentinel.php - it no longer exists.
 
View user's profile Send private message
SPJeff69
PostPosted: Fri Dec 16, 2005 3:29 pm Reply with quote

Ok, now I get the error message "You can't access this file directly..."

When I get into admin.php there is no security number graphic either. The image does not load.

Should I just upload my backup?
 
Raven
PostPosted: Fri Dec 16, 2005 3:39 pm Reply with quote

Make sure that you have removed
admin/modules/sentinel.php
admin/links/links.sentinel.php
admin/case/case.sentinel.php

and that you are using the admin.php file supplied by me and that your config.php file contains
$admin_file='admin';
$gfx_chk = 7;
 
SPJeff69
PostPosted: Fri Dec 16, 2005 4:00 pm Reply with quote

OK, I still get the error for my index page. The security code does not come up in admin.php and I get this error message in my forum admin

Quote:

Your installation does not seem to be up to date. Updates are available for your version of phpBB, please visit Only registered users can see links on this board! Get registered or login! to obtain the latest version.
The latest available version is phpBB 2.0.18. You are running phpBB 2.0.16.
 
Raven
PostPosted: Fri Dec 16, 2005 7:30 pm Reply with quote

You have not upgraded your installation correctly and this is going to be like peeling an onion. That forum message is not an error just a notification. I would suggest that you start with aclean install of RavenNuke76 and upgrade from there as has been explained elsewhere in the forums.
 
Display posts from previous:       
This forum is locked: you cannot post, reply to, or edit topics.   This topic is locked: you cannot edit posts or make replies.    Ravens PHP Scripts And Web Hosting Forum Index -> Raven's RavenNuke(tm) v1.x Distro

View next topic
View previous topic
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum


Powered by phpBB © 2001-2007 phpBB Group
All times are GMT - 6 Hours
 
Forums ©