Ravens PHP Scripts: Forums
 

 

View next topic
View previous topic
Post new topic   Reply to topic    Ravens PHP Scripts And Web Hosting Forum Index -> Post Installation Help
Author Message
evo159
New Member
New Member


Joined: Nov 02, 2005
Posts: 7

PostPosted: Thu Nov 03, 2005 4:25 am Reply with quote

I figured this out on another module I was trying to get to work before but now I just dont know what it is.. Im sure its something small and stupid but i really need it figured out. Heres the code.. It just comes up with a blank white screen when I click on the link to it in the modules block. View my index.php file Only registered users can see links on this board! Get registered or login!

Id appreciate you help on this, Thx evo
 
View user's profile Send private message
Guardian2003
Site Admin


Joined: Aug 28, 2003
Posts: 6793
Location: Ha Noi, Viet Nam

PostPosted: Thu Nov 03, 2005 5:04 am Reply with quote

Does this module actually have a language file?
You could try placing a few echo statement in the first 10 lines or so to see where the file is failing.
 
View user's profile Send private message Send e-mail
montego
Site Admin


Joined: Aug 29, 2004
Posts: 9456
Location: Arizona

PostPosted: Thu Nov 03, 2005 5:07 am Reply with quote

You have an extra } bracket at the bottom of the file. White pages are almost always parse errors.

_________________
Only registered users can see links on this board! Get registered or login!
Only registered users can see links on this board! Get registered or login! 
View user's profile Send private message Visit poster's website
evo159
PostPosted: Thu Nov 03, 2005 5:09 am Reply with quote

no it doesnt have a lang file or anything.. Its just the index.php file.. If you look at the source by right clicking on it it only shows the html and body open and close tags but no content... It seems its not including header.php? or mainfile.php?
 
evo159
PostPosted: Thu Nov 03, 2005 5:10 am Reply with quote

montego wrote:
You have an extra } bracket at the bottom of the file. White pages are almost always parse errors.


Yeah i know... I put that there but it doesnt matter if its there or not.. still get white page.. I think its a parse error or something.. I used the disipal.net module creator to write out the php for me.. I just wrote out all the html
 
Guardian2003
PostPosted: Thu Nov 03, 2005 5:19 am Reply with quote

You would need to add some echo statements, like I said, to be able to see exactly where the file is failing.
The extra '}' would cause a parse error and calling for a language file that does not exist would also cause an error.

It might also be that as you have already called header.php which contains opening html and head tags that reiterating them in the files echo statements might be causing a conflicts.

Modify the first part of your file by changing it to this, so you can see where it is failing.
Code:
<?php

$myTest1 = "PHP loaded...     ";
$myTest2 = "Getting Mainfile...    ";
$myTest3 = "Getting Language file....      ";
$myTest3 = "Getting header file....      ";
$myTest4 = "Creating table ......        ";
echo $myTest1;

if (!eregi("modules.php", $PHP_SELF)) {
   die ("You can't access this file directly...");

}
echo $myTest2;

require_once("mainfile.php");
$module_name = basename(dirname(__FILE__));

echo $myTest2;
get_lang($module_name);
echo $myTest3;
include("header.php");
$index = 1;
echo $myTest4;
OpenTable();
 
evo159
PostPosted: Thu Nov 03, 2005 6:35 am Reply with quote

I redid the php file and hand wrote all of the php and its working fine now.. I guess there was a parse error in there somewhere.. Thanks for all the help it was a great attempt... I also need help getting my squirrelmail_login block to work... Not sure what i did wrong but it says "There is a problem right now with this block." I dont know what that means, but thats not working either.... Oh and by the way... If you could help me do that thing with the page background on the forums page that would help too.. I have been through all the css files and the overall_header and simple_header files... I dont have any idea what wold be causing that bg to be gray instead of black. You can see it Only registered users can see links on this board! Get registered or login!
 
Display posts from previous:       
Post new topic   Reply to topic    Ravens PHP Scripts And Web Hosting Forum Index -> Post Installation Help

View next topic
View previous topic
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum


Powered by phpBB © 2001-2007 phpBB Group
All times are GMT - 6 Hours
 
Forums ©