Ravens PHP Scripts: Forums
 

 

View next topic
View previous topic
Post new topic   Reply to topic    Ravens PHP Scripts And Web Hosting Forum Index -> General/Other Stuff
Author Message
candy
Worker
Worker


Joined: Dec 21, 2004
Posts: 225
Location: Kansas City metro

PostPosted: Wed Nov 02, 2005 4:57 pm Reply with quote

i can't for the life of me figure out why i have had this problem for the past few months.

Basically, when i am logged in as admin, then try to go to my home page, it times out and doesn't come up (cannot find server error). But, if i log out as admin, i can get to my home page (index.php) fine. The problem is, i want to be logged in as admin to see the home page since there are modules active on that page for only admins to see.

Also, i should mention that while i am logged in as admin i can view other pages of the site just not the index.php page. The only thing i can do is clear my cookies, but even when i do that it still doesn't come up sometimes. Plus, i don't want to clear cookies every five minutes on my computer.

Any help or ideas? Thanks.

PS my site is hosted via RWH but i also have another site hosted here on Raven Web Hosting that doesn't give me this problem when logged in as admin, so i think it is site specific.
 
View user's profile Send private message
montego
Site Admin


Joined: Aug 29, 2004
Posts: 9456
Location: Arizona

PostPosted: Wed Nov 02, 2005 5:45 pm Reply with quote

Candy,

I would first try deactivating each of the blocks that are set up for Administrator only. See if you still have the issue. If not, keep adding back one block at a time and find out which one is causing the issue.

Feel free to report back which one it is. Of course, if you solve it, definitely let us know.

I have found this to sometimes be related to the different patch levels and methods employed in the blocks for the top-most test of direct access. I have actually solved an endless loop problem with one block I had awhile back. I think it was when I implemented the 3.0 patch sometime back.

Anyways, let us know what you find out.

Regards,
montego

_________________
Only registered users can see links on this board! Get registered or login!
Only registered users can see links on this board! Get registered or login! 
View user's profile Send private message Visit poster's website
Raven
Site Admin/Owner


Joined: Aug 27, 2002
Posts: 17086

PostPosted: Wed Nov 02, 2005 11:54 pm Reply with quote

Candy,

I'm logged in as admin to your site and everything seems to be working for me. I do notice that it appears you do have something weird happening but I think it's theme related. I have tested this in both IE and Firefox. I logged in as admin and then clicked both the Home tab and the Home link in your main menu and it took me right to your home page.
 
View user's profile Send private message
candy
PostPosted: Wed Nov 02, 2005 11:57 pm Reply with quote

that is really weird because i am logged in as admin and cannot get to the home page. yes, i know about the theme problem. i posted a few days ago with the problem. it only happens in firefox.

anyway, i am not sure why i can't view the home page. have you tried closing the browser then trying to get in again still staying logged in? that's usually when it happens to me.
 
Raven
PostPosted: Wed Nov 02, 2005 11:58 pm Reply with quote

Have you deleted your cookies and cleared your cache?
 
candy
PostPosted: Thu Nov 03, 2005 12:00 am Reply with quote

yes, i have but it seems that's the only way to get to it and i don't want to have to keep clearing cookies, etc. because i hate having to re-login to certain sites. Plus the other site i have hosted here doesn't give me this problem when i don't clear cookies, etc. so not sure why the current site does.
 
Raven
PostPosted: Thu Nov 03, 2005 12:07 am Reply with quote

When you clear your cookies, you only have to clear them for that domain, not all the cookies. Are you using the same adminid/password for both sites? If so, try using a different admin name and see if you still have the problem. It could be that the cookies are getting mixed up.
 
candy
PostPosted: Thu Nov 03, 2005 12:08 am Reply with quote

no i am not using the same admin/pwd combination for both sites. how do i clear cookies from a particular site in IE?
 
Raven
PostPosted: Thu Nov 03, 2005 12:15 am Reply with quote

Tools -> Internet Options -> Settings -> View Files
 
Guardian2003
Site Admin


Joined: Aug 28, 2003
Posts: 6793
Location: Ha Noi, Viet Nam

PostPosted: Thu Nov 03, 2005 4:49 am Reply with quote

You might want to try changing the sitekey in config.php and the cookie name in forums-> configuration to be sure you are setting a fresh cookie - just in case.
 
View user's profile Send private message Send e-mail
candy
PostPosted: Thu Nov 03, 2005 4:03 pm Reply with quote

thank you for all your responses! i have finally figured it out. I took your advice, montego....it turns out i had a block that was an RSS feed (which was an admin only block) from another site that for some reason, was causing me to not be able to view the home page.

has anyone ever heard of anything like this happening before with RSS feed blocks? Question
 
Raven
PostPosted: Thu Nov 03, 2005 5:13 pm Reply with quote

Wonder why I was able to view it w/o any problem? That would lead me to believe there may be more to the story, but, if you're working now, then that's all that matters, for you!
 
montego
PostPosted: Thu Nov 03, 2005 5:24 pm Reply with quote

That is strange that two different admins were seeing different things. Doesn't make much sense unless the other site's RSS feeds just happened to be working when Raven logged in.

Well, hopefully that does not happen again.

Regards,
montego
 
Camber
New Member
New Member


Joined: Apr 02, 2006
Posts: 13

PostPosted: Sun Mar 18, 2007 11:11 am Reply with quote

I am so grateful for your website and for your forums. I just had this very same problem on my website that has been running without a problem for more than a year. Indeed disabling an RSS feed block did away with the problem. Thank you so much!
 
View user's profile Send private message
montego
PostPosted: Tue Mar 20, 2007 6:50 am Reply with quote

RavensScripts

tell all your friends. Laughing
 
Display posts from previous:       
Post new topic   Reply to topic    Ravens PHP Scripts And Web Hosting Forum Index -> General/Other Stuff

View next topic
View previous topic
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum


Powered by phpBB © 2001-2007 phpBB Group
All times are GMT - 6 Hours
 
Forums ©