Ravens PHP Scripts: Forums
 

 

View next topic
View previous topic
This forum is locked: you cannot post, reply to, or edit topics.   This topic is locked: you cannot edit posts or make replies.    Ravens PHP Scripts And Web Hosting Forum Index -> PHP-Nuke Patched Series By Chatserv
Author Message
Trubador
Regular
Regular


Joined: Dec 28, 2004
Posts: 94

PostPosted: Mon Sep 12, 2005 5:18 pm Reply with quote

Hi, I wonder if any could give me a little............. direction Smile

I have PhpNuke 7.4 installed with, what I believe from the readme, patched to 09/19/04 - Version 2.6.

Also Sentinel 2.1.3

and many Mods inc CNB Your Account 750_440

All is of coarse working fine, I think I seriously need to upgrade to 3.1 and 2.4.1 though.

Can anyone suggest a good way of upgrading both packages?

Do I de-install sentinel up-grade Chatserv then re-install the new sentinel package...............?

Any guidance most appreciated

TTFN

Trub
 
View user's profile Send private message
64bitguy
The Mouse Is Extension Of Arm


Joined: Mar 06, 2004
Posts: 1159
Location: Sanbornton, NH USA

PostPosted: Mon Sep 12, 2005 9:33 pm Reply with quote

As a heads-up, always do your "Patched" updates FIRST.

Then do the NukeSentinel 2.4.1 upgrade.

Don't forget to perform the CORE_FILE_EDITS in NukeSentinel.

_________________
Steph Benoit Only registered users can see links on this board! Get registered or login!
1CMS, 100% Section 508 and W3C XHTML/CSS Compliant (Truly) 
View user's profile Send private message Visit poster's website
Trubador
PostPosted: Tue Sep 13, 2005 7:00 am Reply with quote

Cheers for the info m8.

One last thing, would I need to un-install sentinel completely first inc db tables? or manually update to 3.1 then do a progressive update of sentinel to 2.4.1?

or just update to 3.1, uninstall 2.1.3 and install 2.4.1?

Cheers again

Trub
 
64bitguy
PostPosted: Tue Sep 13, 2005 9:24 am Reply with quote

This (to some) is a debatable issue.

I say that as someone that was of the Sentinel 2.1.3 church, only to have issues with the upgrade process.

In my particular Nuke Scneario, I had issues with upgrading directly from 2.1.3 to 2.4.1 which in the end became fairly frustrating. I ended up uninstalling (running the uninstallation file removes all of the tables from the database) and following the original 2.1.3 directions (in reverse) to find and remove all of the references in my files.

I then performed a fresh installation of the lastest version.

In your case, I would probably recommend the exact same scenario only because when you run the "Patched" Update, you are going to be wiping out some of your file edits used to run the legacy version of Sentinel.

Rather, Patched 3.1 files include core file with some of the edits already incorporated for working with NukeSentinel 2.4.1.

My personal recommendation would be as follows:

1) go to your forums administration screen and note your CURRENT forums version.
2) Visit NukeResources and obtain the BBtoNuke Updates. Remember these must be performed incrementally unlike nuke "Patched" Updates.
For instructions on this process, please see: Only registered users can see links on this board! Get registered or login!
continue on with the process that I outline in that forum post with the latest 2.0.16 and 2.0.17 updates:

BBtoNuke 2.0.15 -to- BBtoNuke 2.0.16 - Only registered users can see links on this board! Get registered or login!

BBtoNuke 2.0.16 -to- BBtoNuke 2.0.17 - Only registered users can see links on this board! Get registered or login!

Please note that while your forums will stop working effective the 2.0.15 update, that does not hurt anything, it is normal. You forums will start working again after the latest "Patched" update....

3) Upload the files and run the latest "Patched" revision for your version of nuke from NukeResources.com. This will automatically fix all files with the appropriate revisions including updating all corresponding forums files.
NOTE: If you lose right blocks in any module after running the latest "Patched" update, that is okay as it is a "Feature". To re-establish right blocks, simply open the index.php of any module in question and after the:
Code:
if (!stristr($_SERVER['SCRIPT_NAME'], "modules.php")) {

    die ("You can't access this file directly...");
}
require_once("mainfile.php");

Simply Add:
Code:
$index = 1;

This will restore right blocks to that module.

4) Install NukeSentinel 2.4.1 as a "fresh install"

5) Do NOT forget to perform all of the "CORE_FILE_EDITS" included with NukeSentinel. Read all of these that correspond to your version of Nuke carefully.

6) Done.

Hope this helps.
Steph
 
kguske
Site Admin


Joined: Jun 04, 2004
Posts: 6383

PostPosted: Tue Sep 13, 2005 9:46 am Reply with quote

This should be a sticky - very detailed and thorough (and definitely not surprising- thanks Steph!).

_________________
I google, therefore I exist...
Only registered users can see links on this board! Get registered or login!
 
View user's profile Send private message
Trubador
PostPosted: Tue Sep 13, 2005 5:46 pm Reply with quote

Steph your a star!!!

I had a feeling that was the way ahead but was hoping it was just an easier step.

My own fault for not continually updating Smack

Thanks for this walkthrough m8. I totally forgot about the forum updates as well.

Looks like I better find a spare weekend lol.

Thanks again m8 and yes I'd sticky this, I surely can not be the only lazy admin on the block Confused

TTFN

Trub
 
Trubador
PostPosted: Fri Sep 16, 2005 8:03 pm Reply with quote

Steph

If I wished to update to 3.1 by manually editing all of my files would I need to also do this progressively?. 2.6 - 2.7, 2.7 - 2.8 and so on, instead of uploading the 3.1 patched files?

Lots of work but I have also made many edits to many of these files that I would need to do again.

Cheers m8

Trub
 
64bitguy
PostPosted: Fri Sep 16, 2005 10:39 pm Reply with quote

"Patched" updates are all inclusive. Meaning, you just upload the lastest files and run the updater program.

If you have modded your core files with extensive hacks, this can be a problem in that applying the fixes is not that straight forward if you are going to mod the fixes by hand. It will take a lot of time to get from point a - to - point b if you need to edit everything by hand.

You should be very careful to get all of the new fixes from patched in there. In many cases, it's actually easier to simply upload the patched update and then go back and add-in your mods by hand. The reason being is that the instructions for the mods are always consistant and in applying them, you'll at the same time see the core changes that are part of patched.

This way you are ensuring that all of the fixes are actually applied. It obviously depends on how much you've modded your core code.

Steph
 
Trubador
PostPosted: Sat Sep 17, 2005 6:06 am Reply with quote

Extensively Modded m8.

I've compared the 3.1 Patched files with my current ones. EEEeek.

I've done a complete backup so I'll bite the bullet and patch-up.

It sounds pretty sad but I'm even starting to get the shakes with the thought of this..... Shocked lol

If you see a multitude of crying icons across the WWW you know who's been posted posting lol

Thanks again for the info m8.

Trub
 
Trubador
PostPosted: Sat Sep 17, 2005 9:51 am Reply with quote

Crying or Very sad Crying or Very sad Crying or Very sad Crying or Very sad Crying or Very sad Crying or Very sad Crying or Very sad Crying or Very sad Crying or Very sad Crying or Very sad Crying or Very sad

Hosed me webby Crying or Very sad Crying or Very sad Crying or Very sad Crying or Very sad Crying or Very sad Crying or Very sad Crying or Very sad

Crying or Very sad Crying or Very sad Crying or Very sad Crying or Very sad Crying or Very sad Crying or Very sad Crying or Very sad Crying or Very sad Crying or Very sad

Back to the start Crying or Very sad Crying or Very sad Crying or Very sad Crying or Very sad Crying or Very sad Crying or Very sad

Trub
 
Display posts from previous:       
This forum is locked: you cannot post, reply to, or edit topics.   This topic is locked: you cannot edit posts or make replies.    Ravens PHP Scripts And Web Hosting Forum Index -> PHP-Nuke Patched Series By Chatserv

View next topic
View previous topic
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum


Powered by phpBB © 2001-2007 phpBB Group
All times are GMT - 6 Hours
 
Forums ©