Ravens PHP Scripts: Forums
 

 

View next topic
View previous topic
Post new topic   Reply to topic    Ravens PHP Scripts And Web Hosting Forum Index -> NukeSentinel™
Author Message
whizardkid101
New Member
New Member


Joined: Jul 04, 2005
Posts: 14

PostPosted: Thu Jul 14, 2005 9:03 am Reply with quote

Hello, I have changed the sample.htaccess to .htaccess and changed what was in it to what the "cgi auth setup" told me to change it to. I then put in the correct paths for the .staccess and .htaccess in hte nuke admin panel, I then set an auth admin password for both of my admin accounts. Then when I went I refreshed the site it came back to "error 500." So temporarily I took out the .htaccess so the site would be up. Anybody have any suggestions on what to do to fix this "error 500" problem? All help would be greatly appreciated.

An added update: When I went to the admin auth list this is what came up

Build CGIAuth file: /html/.staccess
^^ is hyperlink to /html/admin.php?op=ABCGIBuild
**However when I click on the link it does nothing.
 
View user's profile Send private message
Raven
Site Admin/Owner


Joined: Aug 27, 2002
Posts: 17086

PostPosted: Thu Jul 14, 2005 9:25 am Reply with quote

An error 500 means either a syntax error or your host does not allow you to use certain driectives in your .htaccess. It's usually the latter. Try removing
Code:
Options All -Indexes

DirectoryIndex index.php index.htm index.html
 
View user's profile Send private message
whizardkid101
PostPosted: Thu Jul 14, 2005 11:59 am Reply with quote

where do I remove that line of code? I looked in the index.php and .htaccess but I could not find that.
 
Raven
PostPosted: Thu Jul 14, 2005 12:01 pm Reply with quote

It was in the sample.htaccess
 
whizardkid101
PostPosted: Thu Jul 14, 2005 6:28 pm Reply with quote

This is what my .htaccess file looks like now


# -------------------------------------------
# Start of NukeSentinel(tm) admin.php Auth
# -------------------------------------------
<Files .ftaccess>
deny from all
</Files>

<Files .staccess>
deny from all
</Files>

<Files admin.php>
<Limit GET POST PUT>
require valid-user
</Limit>
AuthName "Restricted"
AuthType Basic
AuthUserFile /.staccess
</Files>

# -------------------------------------------
# Start of NukeSentinel(tm) DENY FROM area
# -------------------------------------------

The .staccess file is blank as it was in the beginning, am I doing something wrong?
 
Raven
PostPosted: Thu Jul 14, 2005 8:19 pm Reply with quote

Absolutely. You can't use that .htaccess file with a blank .staccess. Rename those files back to sample.*. See Only registered users can see links on this board! Get registered or login! for the correct way to use those files.
 
whizardkid101
PostPosted: Sun Jul 17, 2005 7:52 pm Reply with quote

ok, I have done everything that you asked of, I have looked at another persons error, I am getting the "internal error" thing, this is what is in my .htaccess file

Code:
<Files .teleprompter

deny from all
</Files>
<Files admin.php>
<Limit GET POST PUT>
require valid-user
</Limit>
AuthName "Restricted"
AuthType Basic
AuthUserFile /homepages/11/d107438439/htdocs/dev/.teleprompter
</Files>


my salt code is P^
 
whizardkid101
PostPosted: Sun Jul 17, 2005 8:05 pm Reply with quote

I tried this

Code:
<Files .ftaccess>

  deny from all
</Files>

<Files .teleprompter>
  deny from all
</Files>

<Files admin.php>
   <Limit GET POST PUT>
      require valid-user
   </Limit>
   AuthName "Restricted"
   AuthType Basic
   AuthUserFile /homepages/11/d107438439/htdocs/dubiousbaby/.teleprompter
</Files>


I didn't get the internel error thing but instead as before when I try to enter with my username and password on the popup it just refreshes itself and erases my previous attempt to login to the admin panel.
 
Raven
PostPosted: Sun Jul 17, 2005 10:19 pm Reply with quote

Did you encode your password in the .staccess file?
 
whizardkid101
PostPosted: Mon Jul 18, 2005 9:11 am Reply with quote

So I am suppost to put my password into the secret file and the .htaccess file and upload them both to the server?
 
Display posts from previous:       
Post new topic   Reply to topic    Ravens PHP Scripts And Web Hosting Forum Index -> NukeSentinel™

View next topic
View previous topic
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum


Powered by phpBB © 2001-2007 phpBB Group
All times are GMT - 6 Hours
 
Forums ©