Ravens PHP Scripts: Forums
 

 

View next topic
View previous topic
This forum is locked: you cannot post, reply to, or edit topics.   This topic is locked: you cannot edit posts or make replies.    Ravens PHP Scripts And Web Hosting Forum Index -> NukeSentinel™ Bug Reports
Author Message
tag
Regular
Regular


Joined: Dec 18, 2003
Posts: 53
Location: Worldwide

PostPosted: Sun Jul 03, 2005 12:03 am Reply with quote

Keep getting:

You can't access this file directly...

On all sentinel blocks

What am I forgetting to do?

Nuke 7.5
Sentinel 2.3
 
View user's profile Send private message Visit poster's website
Manuel
Regular
Regular


Joined: May 28, 2005
Posts: 90

PostPosted: Sun Jul 03, 2005 10:24 am Reply with quote

you have chatserv' patches installed?

_________________
Only registered users can see links on this board! Get registered or login! 
View user's profile Send private message Send e-mail Visit poster's website MSN Messenger
tag
PostPosted: Sun Jul 03, 2005 11:42 am Reply with quote

sorry there is nothing in docs about patches.

Where do i find these "patches"?
 
Raven
Site Admin/Owner


Joined: Aug 27, 2002
Posts: 17086

PostPosted: Sun Jul 03, 2005 11:47 am Reply with quote

tag wrote:
sorry there is nothing in docs about patches.

Where do i find these "patches"?
From the README file
Quote:
Section 2: Requirements & Latest Features:
------------------------------------------
REQUIREMENTS:
- NukeSentinel(TM) requires PHP-Nuke 7.1 - 7.7 plus Patched 2.9+ to be installed. If
you are not using Patched 2.9+ you can still use it, but you will need to make
several modifications. If you are using v6.5, it should work but there may be additional
edits needed.
 
View user's profile Send private message
tag
PostPosted: Sun Jul 03, 2005 12:09 pm Reply with quote

Just did lots of work but all those edits were already in file 7.5 patched. so guess they was al right in first place....

still dont help tho cause i still getting same error


You can't access this file directly...

when i try to load the blocks

sentinel seems to be working tho
bumped one of my firends on proxy so had to take that part off

just cant load the sentinel blocks
the other blocks load and unload fine.


Last edited by tag on Sun Jul 03, 2005 2:26 pm; edited 1 time in total 
Raven
PostPosted: Sun Jul 03, 2005 1:22 pm Reply with quote

Use a REAL text editor like Textpad and not notepad Smile
 
tag
PostPosted: Sun Jul 03, 2005 6:09 pm Reply with quote

Just did lots of work but all those edits were already in file 7.5 patched. so guess they was al right in first place....

still dont help tho cause i still getting same error


You can't access this file directly...

when i try to load the blocks

sentinel seems to be working tho
bumped one of my firends on proxy so had to take that part off

just cant load the sentinel blocks
the other blocks load and unload fine.
 
Manuel
PostPosted: Sun Jul 03, 2005 10:05 pm Reply with quote

ok, i tried to check the code for the block of last version 2.3.1

FIND:

Code:


if(!defined('NUKE_FILE') && !defined('BLOCK_FILE'))


REPLACE WITH:

Code:


if(!defined('BLOCK_FILE'))



also check that in your mainfile.php you have:

Code:


define('BLOCK_FILE', true);


and

Code:


define('NUKE_FILE', true);


Wink
 
tag
PostPosted: Sun Jul 03, 2005 10:49 pm Reply with quote

First let me say thanks... I know you SHOULD have better things to do than track down problems... but you are like me I know and love to do. (sometimes)

Second the above fix worked. One addition to make so the Module Sentinel work is :

Quote:

define('MODULE_FILE', true);


taking your lead I found it easy.

Thank you for your time and patience with me
 
Manuel
PostPosted: Sun Jul 03, 2005 10:56 pm Reply with quote

Wink

if you are interested in some other mainfile fixes and stuff you can also take a look here:
Only registered users can see links on this board! Get registered or login!
 
Raven
PostPosted: Sun Jul 03, 2005 10:57 pm Reply with quote

No, you don't want that in the module! It could be forged. That code goes in your modules.php file. If you don't have it there already, then you do not have all the patches from 3.0b
 
Manuel
PostPosted: Sun Jul 03, 2005 10:59 pm Reply with quote

i think he made a mistake but has done what i wrote Smile lol
 
Raven
PostPosted: Sun Jul 03, 2005 11:05 pm Reply with quote

Those changes are all a part of Chat's 2.9 fixpacks and later. Tag, if that's been your problem then you need to bring your nuke version up to date with Chat's 3.0b fixes.
 
Manuel
PostPosted: Sun Jul 03, 2005 11:13 pm Reply with quote

tag wrote:
Just did lots of work but all those edits were already in file 7.5 patched. so guess they was al right in first place....

still dont help tho cause i still getting same error


this is all strange
you say to have nuke patched
but if you have non patched you may have some other problems than only the block not working... mmmmmm
 
tag
PostPosted: Sun Jul 03, 2005 11:19 pm Reply with quote

Ok put the define('MODULE_FILE', true); it worked there too.... its now in modules.php

I updated everything in the 2.3 version:

Patched 3.0 this can be shortened to:
if(!defined('BLOCK_FILE')) { die("You can't access this file directly..."); }
so i have the right files... just i didnt see about the define parts cause its hard to read in notepad Razz

get a real editor notepad then everyone can read it Razz
lol
ok it does open txt files in mircocrap word.... so i can at least read it (lame programs huh?)

actually I do have 7.5 patched I always wait for patched files from you guys before I uplaod to am-nuke.net --- however there is a problem this time. I never add a auto server like fantasico before... so those people using it are gonna be crying. It loaded itself automatically and I had to force orverwrite every file, so yeah I guess there are going be some problems.

For instance, preferences worked BEFORE i uplaoded the patched files, now it doesn't also MSN analysis worked before , now it doesnt... still working on those issues in other posts.....

Lots of other things didn't work but I fix all but those Sentinel and those two, now just have to two left. Since I was publishing the site all over thought sentinel should be in place first.
.
 
Display posts from previous:       
This forum is locked: you cannot post, reply to, or edit topics.   This topic is locked: you cannot edit posts or make replies.    Ravens PHP Scripts And Web Hosting Forum Index -> NukeSentinel™ Bug Reports

View next topic
View previous topic
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum


Powered by phpBB © 2001-2007 phpBB Group
All times are GMT - 6 Hours
 
Forums ©