Ravens PHP Scripts: Forums
 

 

View next topic
View previous topic
Post new topic   Reply to topic    Ravens PHP Scripts And Web Hosting Forum Index -> NukeSentinel™
Author Message
FireATST
RavenNuke(tm) Development Team


Joined: Jun 12, 2004
Posts: 637
Location: Ohio

PostPosted: Wed Mar 16, 2005 12:59 pm Reply with quote

Hello all, I have one question on doing this upgrade. I have 2 sites which have been recently upgraded to 7.5 php through the use of the program Fantastico that is offered by my host company. I am not sure that they are Chatserve patched, and if they are, what version they are. Is there a way for me to find this out. I have looked at my admin.php, mainfile.php, searched for Fantastico to see if they had a webpage which tells about what they use, etc, etc, etc. with no luck. I guess to be sure I should say, if these are not patched versions of php 7.5 files, what files would I have to edit so that I could use the latest version of Sentinel which I believe is the 710 2.2.0 pl1. Please correct me if I am wrong. I am looking to learn how to load sites without using the Fantastico program so I know for sure what is there, but that is another story...Smile Any help would be greatly appreciated, as is your work on these programs for the programming ignorant such as I....Smile

_________________
***** We continue to murder thousands of babies every day......just think if your mothers would have went this route, you would not be here today.***** 
View user's profile Send private message Visit poster's website MSN Messenger ICQ Number
Raven
Site Admin/Owner


Joined: Aug 27, 2002
Posts: 17077

PostPosted: Wed Mar 16, 2005 6:34 pm Reply with quote

Fantastico only supplies the generic version from phpnuke.org
 
View user's profile Send private message
FireATST
PostPosted: Wed Mar 16, 2005 7:37 pm Reply with quote

Thank you Raven. Is it still possible to use 2.2.0 with it by editing files, or won't it work with it at all? Or should I upgrade it to 2.1.3? If it is still possible to do 2.2.0, I will search for the files I need to change in the forums here. Thanks for the quick response back.
 
Raven
PostPosted: Wed Mar 16, 2005 7:47 pm Reply with quote

2.2.0 will work with the modifications mentioned here in the forums.
 
FireATST
PostPosted: Wed Mar 16, 2005 9:14 pm Reply with quote

ok, thanks Raven. Have a good evening....Smile
 
FireATST
PostPosted: Mon Mar 21, 2005 3:39 pm Reply with quote

If I take the chatserve patches that are on the main page of your site, 2.9 version for php 7.5, and overwrite the ones I have, then there shouldn't be any problems I am assuming. I don't know why I didn't understand this earlier Smack Then I can use the Sentinel version 2.2.0 without making the phpfile changes noted in the forums. Am I correct in my thinking?
 
Raven
PostPosted: Mon Mar 21, 2005 5:34 pm Reply with quote

That would be correct. However, for NukeSentinel to function effectively, you should comment out the following code from mainfile.php
Code:
//Union Tap

//Copyright Zhen-Xjell 2004 http://nukecops.com
//Beta 3 Code to prevent UNION SQL Injections
unset($matches);
unset($loc);
if (preg_match("/([OdWo5NIbpuU4V2iJT0n]{5}) /", rawurldecode($loc=$_SERVER["QUERY_STRING"]), $matches)) {
   die();
}

$queryString = strtolower($_SERVER['QUERY_STRING']);
if (stripos_clone($queryString,'%20union%20') OR stripos_clone($queryString,'/*') OR stripos_clone($queryString,'*/union/*') OR stripos_clone($queryString,'c2nyaxb0')) {
header("Location: index.php");
die();
}

and the following code from admin.php
Code:
$checkurl = $_SERVER['REQUEST_URI']; 

if((stripos_clone($_SERVER["QUERY_STRING"],'AddAuthor')) || (stripos_clone($_SERVER["QUERY_STRING"],'VXBkYXRlQXV0aG9y')) || (stripos_clone($_SERVER["QUERY_STRING"],'QWRkQXV0aG9y')) || (stripos_clone($_SERVER["QUERY_STRING"],'UpdateAuthor')) || (preg_match("/\?admin/", "$checkurl")) || (preg_match("/\&admin/", "$checkurl"))) {
die("Illegal Operation");
}
 
FireATST
PostPosted: Mon Mar 21, 2005 5:43 pm Reply with quote

thanks for being patient with me....I am learning slowly.... Wink thanks for the help
 
Display posts from previous:       
Post new topic   Reply to topic    Ravens PHP Scripts And Web Hosting Forum Index -> NukeSentinel™

View next topic
View previous topic
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum


Powered by phpBB © 2001-2007 phpBB Group
All times are GMT - 6 Hours
 
Forums ©