Ravens PHP Scripts: Forums
 

 

View next topic
View previous topic
Post new topic   Reply to topic    Ravens PHP Scripts And Web Hosting Forum Index -> NukeSentinel™
Author Message
rasin
New Member
New Member


Joined: Mar 08, 2005
Posts: 18

PostPosted: Wed Mar 09, 2005 10:36 am Reply with quote

hello people i installed sentinal and works fine with the exception i can no longer access my forum admin page from nuke site admin when i click link all i get is a white page nothing more nothing less than a white page no errors nothing can any 1 help me sort this 1 out please

RavensScripts
 
View user's profile Send private message
AsMan_DF_RT
New Member
New Member


Joined: Mar 09, 2005
Posts: 6

PostPosted: Wed Mar 09, 2005 11:07 am Reply with quote

Thought i was the only one. Everything works fine - all other admin options - Nuke Sentinel works perfectly.. Except I get a blank white page also when clicking "Forums" in admin.

.htaccess and .staccess are configured and working 100% also. Any help would be appreciated..

Thanks, As...

Only registered users can see links on this board! Get registered or login!
 
View user's profile Send private message
buf
New Member
New Member


Joined: Mar 10, 2005
Posts: 3

PostPosted: Thu Mar 10, 2005 4:16 am Reply with quote

Excuse for bringing up this topic again, but I'm having the same problem.
I read the other topic about applying the changes in techgfx's post, and I did. I also tried every other solution I found on the net about replacing the $forum_admin variable to defined('FORUM_ADMIN') (can't remember the whole code) and $inside_mod to defined('INSIDE_MOD'), and still can't access.
I'm now pretty much convinced that I made some mistake during the instalation process, and now I can't find the error.

I'd appreciate any help you con give me.
I'm using nuke platinum 7.6, and the sentinel 2.1.1 that came with it (I doubt upgrading to 2.2.0 will solve the problem). I uploaded all files as instructed, applied the patch, created sentinel's tables but didn't remove protector tables nor it's files (because I didn't think it would matter).

It seems that somewhere I'm not defining $forum_admin, but can't find where...
help... me...
 
View user's profile Send private message
maxcortair
New Member
New Member


Joined: Mar 07, 2005
Posts: 5

PostPosted: Thu Mar 10, 2005 7:05 am Reply with quote

This seems to be an ever growing problem, I'm running PHP-Nuke 7.6 w/patch 2.9, and sentinel 760_220. Have tried installing sentinel 2x in the past 2 days, and both times, am hit with this infamous white page bug, on EVERYTHING. I did everything by the books, read these forums 50 x, and still no solution.

I'm resolved to deleteing everything and doing a virgin instal w/o Sentinel this time. Maybe I'll take a look at some of the other protector programs out there or maybe I'll tempt fate, dunno yet.

Any solutions to this problem?
 
View user's profile Send private message
montego
Site Admin


Joined: Aug 29, 2004
Posts: 9457
Location: Arizona

PostPosted: Thu Mar 10, 2005 7:27 am Reply with quote

maxcortair and others,

If you do a virgin install and then follow the Sentinel install instructions correctly, it will work! There are many, many of us patched to the latest patches and using Sentinel just fine. Most of the issues are with either a piece of the installation not done correctly, or probably more frequently, another block or module (i.e., add-on) that is in conflict.

As an example, any mod that has added an include within mainfile.php or admin.php will be suspect and needs to be reviewed. I think this is where most of the issues with blank pages are caused by. I had the same issue and then found that NSN Groups that I had installed way back when was in conflict with the new 2.9 patch structure. Even Sentinel had the issue, hence the numerous posts on this site for how to correct. You may have to resort to a virgin install or dig a bit more to find the one customization or mod that is in conflict.

montego

_________________
Only registered users can see links on this board! Get registered or login!
Only registered users can see links on this board! Get registered or login! 
View user's profile Send private message Visit poster's website
buf
PostPosted: Thu Mar 10, 2005 8:40 am Reply with quote

My problem is that I'm using platinum, and it's already fully modded, so I don't really know where to look for errors...
One thing I'm sure of: I'm running Protector on one site and it hasn't given me problems. Just now, trying to use sentinel, do I have any trouble...
 
BobMarion
Former Admin in Good Standing


Joined: Oct 30, 2002
Posts: 1037
Location: RedNeck Land (known as Kentucky)

PostPosted: Thu Mar 10, 2005 1:56 pm Reply with quote

Open modules/Forums/admin/forums.php and compare to this(this is the 7.6 2.9 copy):
Code:
if ( !defined('ADMIN_FILE') )

{
   die("Illegal File Access");
}

global $prefix, $db;
$aid = substr("$aid", 0,25);
$row = $db->sql_fetchrow($db->sql_query("SELECT title, admins FROM ".$prefix."_modules WHERE title='Forums'"));
$row2 = $db->sql_fetchrow($db->sql_query("SELECT name, radminsuper FROM ".$prefix."_authors WHERE aid='$aid'"));
$admins = explode(",", $row['admins']);
$auth_user = 0;
for ($i=0; $i < sizeof($admins); $i++) {
    if ($row2['name'] == "$admins[$i]" AND $row['admins'] != "") {
        $auth_user = 1;   
    }
}

if ($row2['radminsuper'] == 1 || $auth_user == 1) {

   switch($op) {
   
      case "forums":
      Header("Location: modules/Forums/admin/index.php");
   }

         
} else {
    echo "Access Denied";
}


Inone copy of the forums.php it had a bad check routine that would cause the white page with or wwithout NukeSentinel installed.

_________________
Bob Marion
Codito Ergo Sum
Only registered users can see links on this board! Get registered or login! 
View user's profile Send private message Send e-mail Visit poster's website
buf
PostPosted: Thu Mar 10, 2005 3:31 pm Reply with quote

Well, similar, but not the same.
Code:


global $prefix, $db, $admin_file;
if (!stristr($_SERVER['SCRIPT_NAME'], "".$admin_file.".php")) {
    die ("Access Denied");
}

$aid = substr("$aid", 0,25);
$row = $db->sql_fetchrow($db->sql_query("SELECT title, admins FROM ".$prefix."_modules WHERE title='Forums'"));
$row2 = $db->sql_fetchrow($db->sql_query("SELECT name, radminsuper FROM ".$prefix."_authors WHERE aid='$aid'"));
$admins = explode(",", $row['admins']);
$auth_user = 0;
//@RJR-Pwmg@Rncvkpwo@-@Eqratkijv@(e)@VgejIHZ.eqo
for ($i=0; $i < sizeof($admins); $i++) {
    if ($row2['name'] == "$admins[$i]" AND $row['admins'] != "") {
        $auth_user = 1;   
    }
}

if ($row2['radminsuper'] == 1 || $auth_user == 1) {

   switch($op) {
   
      case "forums":
      Header("Location: modules/Forums/admin/index.php");
   }

         
} else {
    echo "Access Denied";
}

?>


Unfortunately, it's too late to try. I already started to re-upload platinum, and I'll probably stick with protector...
Anyway, it doesn't make any sense that I should have a different error than all the platinum community. TechGFX's fix solved the problem for everybody...
Thanks anyway. It'a always nice to have a reply from the site admin Very Happy
I'll put your button on my site just for the trouble I gave Wink
 
AsMan_DF_RT
PostPosted: Thu Mar 10, 2005 8:07 pm Reply with quote

I know where my problem was - seemed easier to just start w/ a virgin copy of 7.6 w/ all patches and sentinel. I got a copyof my db so no probs. I like the way NS works so im sticking w/ it. Thanks again - as.

me= RTFM
 
BobMarion
PostPosted: Thu Mar 10, 2005 10:19 pm Reply with quote

I can tell everyone one thing that is for certain, NukeSentinel runs perfectly fine with Patched 2.9, I personally tested it with 7.1 thru 7.6 and Patched 2.9.

I did run into white pages when a module or other addon didn't use the if (defined('ADMIN_FILE')), if (defined('FORUM_ADMIN')) {, if (defined('INSIDE_MOD')) {, or if(defined('NUKE_FILE')) {. This causes nuke to not know where to find the files it's to include and thus creates the white page. And since 2.9 hides ALL errors you never see anytype of message just the white page.

Like I've noted in other forum threads here if you are using a Patched 2.8 or below you will have to do the following.

If for any reason you are not using Patched 2.9 and want to use NukeSentinel 2.2.0 do the following.


Find(within includes/nukesentinel.php):
Code:
// Load required scripts

if (defined('FORUM_ADMIN')) {
  require_once("../../../config.php");
  require_once("../../../db/db.php");
  $lang_dir = "../../../";
} elseif (defined('INSIDE_MOD')) {
  require_once("../../config.php");
  require_once("../../db/db.php");
  $lang_dir = "../../";
} else {
  require_once("config.php");
  require_once("db/db.php");
  $lang_dir = "";
}


ChangeTo:
Code:
// Load required scripts

if ($forum_admin == 1) {
  require_once("../../../config.php");
  require_once("../../../db/db.php");
  $lang_dir = "../../../";
} elseif ($inside_mod == 1) {
  require_once("../../config.php");
  require_once("../../db/db.php");
  $lang_dir = "../../";
} else {
  require_once("config.php");
  require_once("db/db.php");
  $lang_dir = "";
}



Find(in mainfile.php):
Code:
if (defined('FORUM_ADMIN')) {

   include("../../../includes/nukesentinel.php");
} elseif (defined('INSIDE_MOD')) {
   include("../../includes/nukesentinel.php");
} else {
   include("includes/nukesentinel.php");
}


Change To:
Code:
if ($forum_admin == 1) {

   include_once("../../../includes/nukesentinel.php");
} elseif ($inside_mod == 1) {
   include_once("../../includes/nukesentinel.php");
} else {
   include_once("includes/nukesentinel.php");
}



NukeSentinel 2.2.0 takes advatage of Patched 2.9's more secure system for telling if it's being called from forum admin, from inside a module, or from the main system. However with the above you can revert to the Patched 2.8 level and below.
 
maxcortair
PostPosted: Thu Mar 10, 2005 11:46 pm Reply with quote

Well, I did a virgin reinstall of 7.6 w/patch 2.9 did not add NS 2.20 ( as I THOUGHT that was the problem). The only addons Im running atm is the latest JAG, ShoutBox, 4nChat, and scrolling forums, (all are the latest versions). The theme I am using is WFBlack.

Now, all is working well , no white pages, complete functionability until I try to go to my forum admin, thats where I get hit with the white page. I'm confused at this, because none of the addons are visable from the main admin section nor the forum view, (all are on the right side). So, how is an addon thats not visable from admin or forums, screwing up my forum admin page? Maybe its the theme? Any Ideas?


Its not the theme, tested them all and still the same results
 
montego
PostPosted: Fri Mar 11, 2005 12:28 am Reply with quote

BobMarion,

Seems to me we have so many duplicate topics related to blank pages and 2.9 and Sentinel, etc. Should a Sticky be made to help eleviate more duplicate topics?

I'd do it if I could...

Regards to all admins! You ROCK!
montego
 
maxcortair
PostPosted: Fri Mar 11, 2005 1:06 am Reply with quote

Ok, I got tired of messing around with my main site, so I did another installation for testing purposes. All was fine until I patched install2 with patch 2.9, then I got the forum admin white page, soooo Im still lost but at least i somewhat narrowed down the problem.

Now, heres another question. Im installing 7.6 from my server host, which includes it as an add on script, might this possibly be the problem?
 
rasin
PostPosted: Fri Mar 11, 2005 5:53 am Reply with quote

ok heres wat i got is there any thin i can change to get rid of white page


if ( !defined('ADMIN_FILE') )
{
die("Illegal File Access");
}
global $prefix, $db;
$aid = substr("$aid", 0,25);
$row = $db->sql_fetchrow($db->sql_query("SELECT radminforum, radminsuper FROM " . $prefix . "_authors WHERE aid='$aid'"));
if (($row['radminforum'] == 1) OR ($row['radminsuper'] == 1)) {

switch($op) {

case "forums":
Header("Location: modules/Forums/admin/index.php");
}


} else {
echo "Access Denied";
}
 
rasin
PostPosted: Fri Mar 11, 2005 6:46 am Reply with quote

ok people i sorted white screen problem out in forums admin i updated 2.9 patch then i edited a couple of files as listed here Only registered users can see links on this board! Get registered or login!

thanks for all your help guys regards and keep up the good work

RavensScripts
 
Display posts from previous:       
Post new topic   Reply to topic    Ravens PHP Scripts And Web Hosting Forum Index -> NukeSentinel™

View next topic
View previous topic
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum


Powered by phpBB © 2001-2007 phpBB Group
All times are GMT - 6 Hours
 
Forums ©