Ravens PHP Scripts: Forums
 

 

View next topic
View previous topic
Post new topic   Reply to topic    Ravens PHP Scripts And Web Hosting Forum Index -> NukeSentinel™
Author Message
tabascolibre
New Member
New Member


Joined: Jan 25, 2005
Posts: 11
Location: El infierno Verde

PostPosted: Mon Mar 07, 2005 7:09 pm Reply with quote

when I want to see the unanswered messges, I choose one, the message doesn`t appear and it says to me t hie: Possible Santy Worm Attack!, I would like to know how to repair that.
I´m using NukeSentinel™ 2.2.0, PHP Nuke 7.6 parch 2.9 and BBtoNuke 2.0.13

thanks

_________________
Yo vengo de la tierra abundante y del calor sofocante...
Only registered users can see links on this board! Get registered or login! 
View user's profile Send private message Visit poster's website
bergman
New Member
New Member


Joined: Mar 07, 2005
Posts: 10

PostPosted: Wed Mar 09, 2005 10:22 am Reply with quote

I have the same problem.
 
View user's profile Send private message
vmMayhem
New Member
New Member


Joined: Feb 01, 2005
Posts: 15

PostPosted: Sun Mar 20, 2005 9:59 pm Reply with quote

I'm getting the same thing. Is this a warning from sentinel 2.2.0?
 
View user's profile Send private message
Raven
Site Admin/Owner


Joined: Aug 27, 2002
Posts: 17086

PostPosted: Sun Mar 20, 2005 10:22 pm Reply with quote

Comment out that logic in sentinel.php and/or nukesentinel.php.
 
View user's profile Send private message
vmMayhem
PostPosted: Mon Mar 21, 2005 12:48 am Reply with quote

Thanks Raven.

I think this may have something to do with it? This is from includes/nukesentinel.php

Code:


// Stop Santy Worm
// If you have problems with forums remove ,highlight from the string below
if($ab_config['santy_protection'] == 1) {
  $bad_uri_content=array("rush","highlight","perl","chr(","pillar","visualcoder","sess_");
  while(list($stid,$uri_content)=each($bad_uri_content)) { if(stristr($_SERVER['REQUEST_URI'], $uri_content)) { die(_AB_SANTY); } }
}


Guess I can try removing "highlight".


Update: Removing "highlight" seems to have fixed my problem.
 
Raven
PostPosted: Mon Mar 21, 2005 9:41 am Reply with quote

Exactly what I was referring to Smile
 
jakkedup
New Member
New Member


Joined: Mar 27, 2005
Posts: 1

PostPosted: Sun Mar 27, 2005 10:13 pm Reply with quote

Out of the many that use our forums, why would only 2 people be affected by this? I'm not a coder, so can you tell me what "highlight" removal is doing? Does it decrease the protection? Sorry for the noobish ?'s.
 
View user's profile Send private message
loop
New Member
New Member


Joined: May 18, 2005
Posts: 2

PostPosted: Wed May 18, 2005 8:35 pm Reply with quote

my web site at Only registered users can see links on this board! Get registered or login! seems to have a problem with highlight.

when a user searches something (ie 'macro') and they click on the link, it returns a blank page. But when you delete 'highlight' in the url, the link works perfectly.

My question is: how do i delete the highlight wording when the user searches?

thank you.
 
View user's profile Send private message
loop
PostPosted: Wed May 18, 2005 8:58 pm Reply with quote

spb wrote:
Well I have fixed it, but is this the right thing to do

search.php

Changed
Code:
$topic_url = append_sid("viewtopic.$phpEx?" . POST_TOPIC_URL . '=' . $searchset[$i]['topic_id'] . "&highlight=$highlight_active");


to
Code:


$topic_url = append_sid("viewtopic.$phpEx?" . POST_TOPIC_URL . '=' . $searchset[$i]['topic_id']);


As I say it works, but will it cause me problems in future?
 
Raven
PostPosted: Wed May 18, 2005 9:11 pm Reply with quote

See this article Only registered users can see links on this board! Get registered or login!
 
socketus
New Member
New Member


Joined: Feb 05, 2005
Posts: 1

PostPosted: Fri Apr 07, 2006 1:15 pm Reply with quote

um, none of the options above work for me, i have the Possible Santy Worm Attack page when I click on 1 member's Find All Posts by in their forum profile ...

ok - i turned off Santy worm protection in sentinel admin, and am going t0 try the .htaccess script

but all i get now is a blank page for every member's posts search .. lol

Alright! I reversed the above changes and went with this post's reco about using the .htaccess script and turning off sentinel's santy worm protection -
Only registered users can see links on this board! Get registered or login!

all members' profiles' posts search now work, including the original afflicted one!

////
 
View user's profile Send private message
Display posts from previous:       
Post new topic   Reply to topic    Ravens PHP Scripts And Web Hosting Forum Index -> NukeSentinel™

View next topic
View previous topic
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum


Powered by phpBB © 2001-2007 phpBB Group
All times are GMT - 6 Hours
 
Forums ©