Ravens PHP Scripts: Forums
 

 

View next topic
View previous topic
Post new topic   Reply to topic    Ravens PHP Scripts And Web Hosting Forum Index -> Themes
Author Message
Virgin_Steel
Worker
Worker


Joined: Sep 30, 2004
Posts: 108
Location: Sf

PostPosted: Mon Feb 21, 2005 7:58 pm Reply with quote

Thats my first try to do theme...and so i got some problems:
The scrolling blocks just gone messed up, see this:
Image
But in Mozilla it's ok ????
and some other blocks are messed a little to like this:
Image
and this is the code of my blocks.htm

Code:
<html>

<head>
<title>blocks.gif</title>
<meta http-equiv="Content-Type" content="text/html;">

</head>
<body bgcolor="#ffffff">

<table border="0" cellpadding="0" cellspacing="0" width="160">
<!-- fwtable fwsrc="blocks.png" fwbase="blocks.gif" fwstyle="Generic" fwdocid = "703772699" fwnested="0" -->
  <tr>
   <td><img src="themes/DeepBlue/images/spacer.gif" width="12" height="1" border="0" alt=""></td>
   <td><img src="themes/DeepBlue/images/spacer.gif" width="12" height="1" border="0" alt=""></td>
   <td><img src="themes/DeepBlue/images/spacer.gif" width="13" height="1" border="0" alt=""></td>
   <td><img src="themes/DeepBlue/images/spacer.gif" width="1" height="1" border="0" alt=""></td>
  </tr>
  <tr>
   <td colspan="3" background="themes/DeepBlue/images/blocks_r1_c1.gif"><p align="center"><b>$title</b></p></td>
   <td><img src="themes/DeepBlue/images/spacer.gif" width="1" height="24" border="0" alt=""></td>
  </tr>
  <tr>
   <td background="themes/DeepBlue/images/blocks_r2_c1.gif">&nbsp;</td>
   <td valign="top" bgcolor="#FFFFFF">
    <p>$content</p></td>
   <td background="themes/DeepBlue/images/blocks_r2_c3.gif">&nbsp;</td>
   <td><img src="themes/DeepBlue/images/spacer.gif" width="1" height="5" border="0" alt=""></td>
  </tr>
  <tr>
   <td colspan="3"><img name="blocks_r3_c1" src="themes/DeepBlue/images/blocks_r3_c1.gif" width="160" height="24" border="0" alt=""></td>
   <td><img src="themes/DeepBlue/images/spacer.gif" width="1" height="5" border="0" alt=""></td>
  </tr>
</table>
</body>
</html>

I'll be so thankfull if someone could help me!
 
View user's profile Send private message Send e-mail Visit poster's website AIM Address Yahoo Messenger MSN Messenger ICQ Number
hitwalker
Sells PC To Pay For Divorce


Joined:
Posts: 5661

PostPosted: Mon Feb 21, 2005 8:15 pm Reply with quote

well first you need to strip the code a bit like this....

Code:


<table border="0" cellpadding="0" cellspacing="0" width="160"> <tr>
<td><img src="themes/DeepBlue/images/spacer.gif" width="12" height="1" border="0" alt=""></td>
<td><img src="themes/DeepBlue/images/spacer.gif" width="12" height="1" border="0" alt=""></td>
<td><img src="themes/DeepBlue/images/spacer.gif" width="13" height="1" border="0" alt=""></td>
<td><img src="themes/DeepBlue/images/spacer.gif" width="1" height="1" border="0" alt=""></td>
</tr> <tr>
<td colspan="3" background="themes/DeepBlue/images/blocks_r1_c1.gif"><p align="center"><b>$title</b></p></td>
<td><img src="themes/DeepBlue/images/spacer.gif" width="1" height="24" border="0" alt=""></td>
</tr><tr><td background="themes/DeepBlue/images/blocks_r2_c1.gif">&nbsp;</td>
<td valign="top" bgcolor="#FFFFFF"><p>$content</p></td>
<td background="themes/DeepBlue/images/blocks_r2_c3.gif">&nbsp;</td>
<td><img src="themes/DeepBlue/images/spacer.gif" width="1" height="5" border="0" alt=""></td>
</tr><tr><td colspan="3">
<img name="blocks_r3_c1" src="themes/DeepBlue/images/blocks_r3_c1.gif" width="160" height="24" border="0" alt=""></td>
<td><img src="themes/DeepBlue/images/spacer.gif" width="1" height="5" border="0" alt=""></td></tr></table>


I think you have to edit it online,and prefered on a testsite.
Cause looking at your site that the rest is okay....as you said isnt realy true....
As far as you problem can be solved....i think the width isnt correct of the design itself.
I copied your index with the block part and it showed that the images used as background arent properly set...
But i recommend this stuff on a test site.....
 
View user's profile Send private message
Virgin_Steel
PostPosted: Mon Feb 21, 2005 8:57 pm Reply with quote

hitwalker, thank you so much, I solved the problem.There left only one strange thing!The empty space in the underpart of my blocks.Under mozilla it don't shows these space, but in IE it's there...so it makes my site longer..blah!i cant understand it.
Image
 
Holbrookau
Hangin' Around


Joined: Jun 25, 2004
Posts: 32

PostPosted: Mon Feb 21, 2005 10:22 pm Reply with quote

That would be the bug in IE that adds a space after the ending form tag.
Add this to the FORM line in your themes/ThemeName/style/style.css file:
Code:
display:inline
so that it looks something like:
Code:
FORM       {FONT-FAMILY: Verdana,Helvetica; FONT-SIZE: 11px; display: inline}
 
View user's profile Send private message
Virgin_Steel
PostPosted: Tue Feb 22, 2005 4:11 am Reply with quote

It didn't change anything...so i can swallow it...one line more..
but there is another bug in my forums ,i knew that something with the DeepBlue is not ok,cause in the fresh installation forums are messed up...now when i create my theme everything works instead of forums look at this:
Image that is the same in virgin instalation of DeepBlue...i don't have any idea how to put forum in site frame...also my forum go so wide.
Any Help!
Sorry for the images...you can check it here Only registered users can see links on this board! Get registered or login!

And after all Raven you could delete the topic..but i thing it will be useful for thos who use DeepBlue!
 
sixonetonoffun
Spouse Contemplates Divorce


Joined: Jan 02, 2003
Posts: 2496

PostPosted: Tue Feb 22, 2005 7:53 am Reply with quote

There are a few themes that will work with right blocks on but not many.

The header in DeepBlue doesn't resize either and that makes the issue more prominent scrollbars are bad enough.

_________________
[b][size=5]openSUSE 11.4-x86 | Linux 2.6.37.1-1.2desktop i686 | KDE: 4.6.41>=4.7 | XFCE 4.8 | AMD Athlon(tm) XP 3000+ | MSI K7N2 Delta-L | 3GB Black Diamond DDR
| GeForce 6200@433Mhz 512MB | Xorg 1.9.3 | NVIDIA 270.30[/size:2b8 
View user's profile Send private message
Virgin_Steel
PostPosted: Tue Feb 22, 2005 9:23 am Reply with quote

sixonetonoffun, i don't want to be shown right blocks...there whera i wrote "there is no right" i mean the right table of my theme!I just cant understand which file is responsible for this unframing of the forums in DeepBlue theme.if i knew... so any help?Putin` forums in themeheader ?
 
Virgin_Steel
PostPosted: Tue Feb 22, 2005 9:34 am Reply with quote

hahahaha i cannot believe i jwas ust jokin` with my files when i see overall footar had closing tags </tr> and </table> so i put in the beginnin <table> and <tr> now everything works Smile))

but still dont know where to put absolute width so that the forums will cannot go wider...
 
Display posts from previous:       
Post new topic   Reply to topic    Ravens PHP Scripts And Web Hosting Forum Index -> Themes

View next topic
View previous topic
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum


Powered by phpBB © 2001-2007 phpBB Group
All times are GMT - 6 Hours
 
Forums ©