Ravens PHP Scripts: Forums
 

 

View next topic
View previous topic
Post new topic   Reply to topic    Ravens PHP Scripts And Web Hosting Forum Index -> NukeSentinel™
Author Message
dfuhawk
New Member
New Member


Joined: Feb 10, 2005
Posts: 2

PostPosted: Thu Feb 10, 2005 4:16 pm Reply with quote

ok heres the low down i installed nukesentinel 2.1.1 to php-nuke 7.5 i cmoded the .htaccess file and .staccess file to 666 i aded this script to the .htaccess

Quote:

Options All -Indexes
DirectoryIndex index.php index.htm index.html

# -------------------------------------------
# Start of NukeSentinel(tm) admin.php Auth
# -------------------------------------------
<Files .staccess>
deny from all
</Files>

<Files admin.php>
<Limit GET POST PUT>
require valid-user
</Limit>
AuthName "Restricted"
AuthType Basic
AuthUserFile /home/teamdfu/public_html/.staccess
</Files>

# -------------------------------------------
# Start of NukeSentinel(tm) DENY FROM area
# -------------------------------------------


i edited the mainfile.php, header.php, and the javascrpit.php to what was specifyed on the instructions then i ran the nsnst.php file and installed the sql wel after i did that i tryed to access the admin on my site and it prompted me for a pass like it was sopose to do but my uname and pass dont work now befor u refer me to look at this faq

Quote:

I set Admin HTTP Auth to on, and now I cannot get logged in as Admin. Is there a way to diable this feature and reconfigure with a valid user/pass?

Answer
This would normally use your Superuser (or GOD admin) user name and password. If this does not work, you can edit the database using PHPMyAdmin. Find the table nuke_nsnst_config, then find the field HTTP Auth and set this value to 0 (zero). Log in to your site as admin, go to the Sentinel contol panel. Click on Admin HTTP Auth. This will show the protected admins. Click on your admin name and in this window, you can set a new password for the Admin HTTP Auth.



i that above and this is the results i went to nuke_nsnst_config and there was no field called HTTP Auth the only to feilds are config_name and Config_value i tryed a tottal reinstall of the whole thing and just a sql reinstall what do i doo to fix this
 
View user's profile Send private message
BobMarion
Former Admin in Good Standing


Joined: Oct 30, 2002
Posts: 1037
Location: RedNeck Land (known as Kentucky)

PostPosted: Thu Feb 10, 2005 5:06 pm Reply with quote

First check to make sure your .staccess has atleast one username:password line in it. The password will be encrypted Smile

Second, if there's no entries in that file remove the code from the .htaccess file and goto the Admin Auth List and make sure each admin has a password set. These passwords are not the same as the passwords used in hte nuke_authors table. Next click the Build CGIAuth file: /PATH/TO/YOUR/.staccess link.

Next reinsert the code into the .htaccess file and try loggin in again and see if that cures your problems.

_________________
Bob Marion
Codito Ergo Sum
Only registered users can see links on this board! Get registered or login! 
View user's profile Send private message Send e-mail Visit poster's website
dfuhawk
PostPosted: Thu Feb 10, 2005 5:51 pm Reply with quote

Thank you very much it worked by the way great script i love it
 
Display posts from previous:       
Post new topic   Reply to topic    Ravens PHP Scripts And Web Hosting Forum Index -> NukeSentinel™

View next topic
View previous topic
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum


Powered by phpBB © 2001-2007 phpBB Group
All times are GMT - 6 Hours
 
Forums ©