Ravens PHP Scripts: Forums
 

 

View next topic
View previous topic
Post new topic   Reply to topic    Ravens PHP Scripts And Web Hosting Forum Index -> How To's
Author Message
jondvb
Regular
Regular


Joined: Oct 25, 2003
Posts: 67

PostPosted: Sat Oct 25, 2003 3:11 pm Reply with quote

Hello,

Before I get into the problem, I just have to say I am VERY impressed with the mods and add-ons at this site. A quick look at my site will tell you that I have gotten a lot of great ideas from here.

Raven, you have been a HUGE help so far on the nukecops.com site, but I still have this big problem.

Here is the breakdown...

I was running a phpbb forum version 2.0.6. It has 130 registered users and over 3000 posts. I decided to go with a phpbb/nuke combo, and downloaded the subblackorg package with phpnuke7.0.

I installed the site, then used a tweak to transfer all of my users and settings from my old forum to this new site.

All of my users from the forum can log onto the site fine! It works great; however, new user can not register. What happened was, when you register, the information got stuck in the nuke_users_temp table.

I downloaded the autoactivatemod, and that didn't change anything. I then aplied the resend_email_module tweak and it changed my site visitor look on the main page! I love it! But, now when you register, it says:

jondvb: Your account has been activated. Please login from this link using your assigned Nickname and Password.

Yet, when you click the link, it brings you to the login page, and the account is not recognized. The account was never populated in the nuke_users table.

I am baffled, and tried everything. This is the final step to get the board up and running, and it is driving me nuts!

I will be more than happy to give someone GOD rights to see if they can find something out of whack. It means that much to me to get this fixed.

I've spent too much time trying to figure this out!

If anyone has any ideas, I would greatly appreciate anything they can do to assist.

Regards,

Jonathan
 
View user's profile Send private message
Raven
Site Admin/Owner


Joined: Aug 27, 2002
Posts: 17086

PostPosted: Sat Oct 25, 2003 3:33 pm Reply with quote

PM me the following

site url, adminid, adminpw
ftp url, id, password
phpMyAdmin url, id, password

I will look into it as sson as I can
 
View user's profile Send private message
Raven
PostPosted: Sat Oct 25, 2003 4:16 pm Reply with quote

It looks like your Your_Account/index.php file is miscoded. Replace it with the virgin Your_Account/index.php file and then post back to let me know to test it again. And, if this doesn't work, I will need FTP access.
 
jondvb
PostPosted: Sat Oct 25, 2003 4:25 pm Reply with quote

I put back the original index.php file.
 
Raven
PostPosted: Sat Oct 25, 2003 4:49 pm Reply with quote

Your email is not working, are you aware of that? I try to resend the email and it errors out on the email send. To do any more debugging, I will need the FTP access. Thanks.
 
jondvb
PostPosted: Sat Oct 25, 2003 4:53 pm Reply with quote

dag. I am not familiar with proftp. are you?

I need to know how to get it to work in linux.
 
Raven
PostPosted: Sat Oct 25, 2003 4:56 pm Reply with quote

Unfortunately, no. I use VSFTP and I set it up so long ago, but I do remember that it is pretty simple. Linux ships with wuftp and it should already be installed. Maybe we can make this simpler. How do you move files to your server w/o ftp?
 
jondvb
PostPosted: Sat Oct 25, 2003 6:16 pm Reply with quote

I've got a network setup at home.

Raven, I actually would like to have the email sent to people. That way they are forced to use unique passwords. The reason I wanted to mod it was because it didn't work.

So, let's move to fixing the email portion. Can you tell me what may need to be modified? I can tell you all of the server info if you need it.
 
jondvb
PostPosted: Sat Oct 25, 2003 7:20 pm Reply with quote

I'm going to configure vsftpd. I will let you know when it's done. =)
 
Raven
PostPosted: Sat Oct 25, 2003 7:30 pm Reply with quote

Sorry, I've been working on some other stuff and in and out. Let me know when ftp is set up.

For email, on Linux, I just use the default installation of Sendmail and my ISP. Do you have Sendmail installed and working?
 
jondvb
PostPosted: Sat Oct 25, 2003 7:32 pm Reply with quote

I don't use sendmail. With the forum (also on the linux box), I used smtp.

Once I can kick my wife off her computer, I can switch to my server to configure vsftp. =)
 
jondvb
PostPosted: Sat Oct 25, 2003 7:34 pm Reply with quote

Hey bud, can you tell me how to add you to see my html folder via ftp? If I knew that, I could probably ssh into my server to do it.

Just looking to speed this up!
 
Raven
PostPosted: Sat Oct 25, 2003 7:37 pm Reply with quote

smtp is just the protocol (Simple Mail Transfer Protocol). You still have to use a Mail server and you must be using Sendmail unless you installed another Mail server. Run a 'top' command at your shell prompt to see if sendmail is listed.
 
Raven
PostPosted: Sat Oct 25, 2003 7:42 pm Reply with quote

Unless you install some kind of a ssh jail program, you can't do that. You can set me up as a shell user and PM me the username and password and I can ssh in.

I think we're going to have to pick this up again tomorrow. I have to get some rest.
 
jondvb
PostPosted: Sat Oct 25, 2003 7:43 pm Reply with quote

Sorry, I'm a moron.

I'm running communigate pro mail server.
 
jondvb
PostPosted: Sat Oct 25, 2003 7:45 pm Reply with quote

Raven wrote:
Unless you install some kind of a ssh jail program, you can't do that. You can set me up as a shell user and PM me the username and password and I can ssh in.

I think we're going to have to pick this up again tomorrow. I have to get some rest.


I'll work on vsftp some more. If you can send me some sample configs for vsftp sothat you can get access to the html folder, that would be awesome.
 
Raven
PostPosted: Sat Oct 25, 2003 7:48 pm Reply with quote

jondvb wrote:
I'm running communigate pro mail server.
Have you told PHP (in ini file) that you are using that and configured it in the ini Smile?
 
jondvb
PostPosted: Sat Oct 25, 2003 8:12 pm Reply with quote

Only registered users can see links on this board! Get registered or login!

sendmail_from Only registered users can see links on this board! Get registered or login! Only registered users can see links on this board! Get registered or login!
sendmail_path /usr/sbin/sendmail -t -i /usr/sbin/sendmail -t -i

I guess that's a no. Now maybe I should figure out how to add communigate!
 
Raven
PostPosted: Sat Oct 25, 2003 8:14 pm Reply with quote

Laughing Yes, that would be a resounding UH-HUH Laughing
 
jondvb
PostPosted: Sat Oct 25, 2003 8:22 pm Reply with quote

Hey Bud, go to sleep!!! Evil or Very Mad

We can do this tomorrow. No rush, my friend.

I'll do some searching to see what I have to put in there.
 
Raven
PostPosted: Sat Oct 25, 2003 8:25 pm Reply with quote

Well, I'll knock off the computer anyway. Just remembered that we set the clocks back tonight so I get a n hour extra anyway. Talk with you later! At any rate, we're slowly but surely getting you on track Wink
 
jondvb
PostPosted: Sat Oct 25, 2003 8:41 pm Reply with quote

Yeah, an extra hour! lol.

I think so. I found the commands I need to modify. I just need to test it.

Speak to you tomorrow! I'm going to watch the Yankees lose!!!!!
 
jondvb
PostPosted: Sun Oct 26, 2003 2:33 pm Reply with quote

Raven,

They get the email now!

However, when they click the link in the email, and get to the site, they put in their name and password, and it doesnt accpet it.

If you refresh, it says it doesnt recognize that you are registered.

If you register again, you can do so with the same name/password.
 
Raven
PostPosted: Sun Oct 26, 2003 3:01 pm Reply with quote

Great news on the email! Now to try to figure out the registration issue. I'll be back on in a while. hang in there - we're close Wink
 
jondvb
PostPosted: Sun Oct 26, 2003 3:02 pm Reply with quote

No problem. Send me a pm when you have a minute.
 
Display posts from previous:       
Post new topic   Reply to topic    Ravens PHP Scripts And Web Hosting Forum Index -> How To's

View next topic
View previous topic
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum


Powered by phpBB © 2001-2007 phpBB Group
All times are GMT - 6 Hours
 
Forums ©