Ravens PHP Scripts: Forums
 

 

View next topic
View previous topic
Post new topic   Reply to topic    Ravens PHP Scripts And Web Hosting Forum Index -> General/Other Stuff
Author Message
Dacubz
Worker
Worker


Joined: Apr 27, 2004
Posts: 156
Location: Homer Glen, Illinois

PostPosted: Sat Nov 27, 2004 10:25 am Reply with quote

I'm using Sommiere, and I'd like some of my links to open within my site the same way that my forums do instead of in a new browser window. How can I do this?
 
View user's profile Send private message Visit poster's website
TheosEleos
Life Cycles Becoming CPU Cycles


Joined: Sep 18, 2003
Posts: 960
Location: Missouri

PostPosted: Sat Nov 27, 2004 12:29 pm Reply with quote

Don't put the entire url into the 'link url' box. If you site is Only registered users can see links on this board! Get registered or login! and you want it to open test.html then put just test.html and not Only registered users can see links on this board! Get registered or login!

I hope that helps.

_________________
Only registered users can see links on this board! Get registered or login! 
View user's profile Send private message Visit poster's website AIM Address ICQ Number
Dacubz
PostPosted: Sat Nov 27, 2004 12:50 pm Reply with quote

It still doess the same thing. What I'm looking to do is have the link open and keep the left modules intact. Simething like nukewrap would do, but I cant figure out how to get that to work properly. Thanks in advance!
 
TheosEleos
PostPosted: Sat Nov 27, 2004 2:02 pm Reply with quote

What address is it you want people to be directed to?
 
Dacubz
PostPosted: Sat Nov 27, 2004 2:49 pm Reply with quote

I'm just looking for one of my local pages to open in the main area of my site, keeping the left column in place showing the navigation, etc... something similar to frames.
 
TheosEleos
PostPosted: Sat Nov 27, 2004 4:57 pm Reply with quote

what module is it?
 
Dacubz
PostPosted: Sat Nov 27, 2004 5:01 pm Reply with quote

It's the main module that the forums show in when clicking on them. The one that covers the majority of the page, index.php?
 
TheosEleos
PostPosted: Sat Nov 27, 2004 7:00 pm Reply with quote

What is your web address?

What is the url you are trying to get to work?
 
Dacubz
PostPosted: Sat Nov 27, 2004 7:55 pm Reply with quote

mazx.org. trying to get the members listings to show in the main part of the page when clicked.
 
TheosEleos
PostPosted: Sat Nov 27, 2004 8:18 pm Reply with quote

You need to make it as an actual module for the side blocks to show up.

It isn't that hard really. Use the following code in a file and name it index.php.

Code:
<?php

        if (!eregi("modules.php", $PHP_SELF)) die ("You can't access this file directly...");

      $index=1;
        $module_name = basename(dirname(__FILE__));
        require_once("mainfile.php");
        $pagetitle = "- pHenyl's House Roster";

        include("header.php");
        OpenTable();

        include("modules/$module_name/*****.html");

        CloseTable();
        include("footer.php");
?>


Once you have the index.php file create a folder in 'modules' called 'Mazx_members' and put the index.php file in there. Also put the html file you used to make that members page in there. Then edit the index.php file and change '*****.html' to be whatever the name of your html page is called. Once you do this go into your nuke admin/modules and activate your module.

Post here if you have any questions.
 
Dacubz
PostPosted: Sat Nov 27, 2004 9:59 pm Reply with quote

Can't get the module to show up for activation. Using version 7.5
 
TheosEleos
PostPosted: Sun Nov 28, 2004 7:52 am Reply with quote

Have you added new modules before and had any problems?

Do a search on the forums for modules not showing up and see if any of those fixes work for you.
 
Dacubz
PostPosted: Sun Nov 28, 2004 3:28 pm Reply with quote

Haven't searched yet. I don't believe I've ever had this problem before, but I'm not sure if it was pre-upgrade or not.
 
TheosEleos
PostPosted: Sun Nov 28, 2004 4:53 pm Reply with quote

Well, this usually happens when you install something that changes the 'modules' table in the database and so when you go to your modules admin it can't add the new module to the database.

You can hit me up on Yahoo or MSN if you would like. My IM information is under my sig. Very Happy
 
Display posts from previous:       
Post new topic   Reply to topic    Ravens PHP Scripts And Web Hosting Forum Index -> General/Other Stuff

View next topic
View previous topic
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum


Powered by phpBB © 2001-2007 phpBB Group
All times are GMT - 6 Hours
 
Forums ©