Ravens PHP Scripts: Forums
 

 

View next topic
View previous topic
Post new topic   Reply to topic    Ravens PHP Scripts And Web Hosting Forum Index -> NukeSentinel™
Author Message
Kilim
Hangin' Around


Joined: Nov 02, 2004
Posts: 26

PostPosted: Tue Nov 02, 2004 11:17 am Reply with quote

WHat I have:
Nuke 7.3 w/ Patch 2.5
Phbb2 v 2.08
Sentinel 2.10

I am unsure what went wrong but I am now having some issues w/ Sentinel on my site.
When I 1st installed it, I didn't see any issues at all and was amazed and happy.

I turned on most functions except the .htaccess as I am unsure of how it is done and how to make it work.


Problem:
I later on used my home PC and I and some other users noticed that the website is either slow loading, loaded weirdly or won't load at all.

I personally got the http 404 error when I try to load my nuke site.
EVerything seeems to work fina again after I comment out the editable file for mainfile.php.


Any idea what could be causing the problem?
I really love this program and would love to use it in my site.


Last edited by Kilim on Tue Nov 02, 2004 5:19 pm; edited 1 time in total 
View user's profile Send private message
sixonetonoffun
Spouse Contemplates Divorce


Joined: Jan 02, 2003
Posts: 2496

PostPosted: Tue Nov 02, 2004 11:41 am Reply with quote

Have you tried removing the duplicate filtering in mainfile.php
1) //Union Tap code
2) #--------------- Base64 sanitize by Waraxe code
3) foreach ($_GET as $secvalue) code
4) foreach ($_POST as $secvalue)

If you remove those be sure your NukeSentinel is running and all of the default blockers are turned on. This should improve the speed greatly. But 404 that is odd have your tried running tracert from the commandline to see if there is a server issue either your hosts or isp's or someplace in between?
Start->Run type cmd enter then in the cammand window type:
tracert Only registered users can see links on this board! Get registered or login!
This will show the response times between you and your website.

_________________
[b][size=5]openSUSE 11.4-x86 | Linux 2.6.37.1-1.2desktop i686 | KDE: 4.6.41>=4.7 | XFCE 4.8 | AMD Athlon(tm) XP 3000+ | MSI K7N2 Delta-L | 3GB Black Diamond DDR
| GeForce 6200@433Mhz 512MB | Xorg 1.9.3 | NVIDIA 270.30[/size:2b8 
View user's profile Send private message
Kilim
PostPosted: Tue Nov 02, 2004 1:27 pm Reply with quote

I have other nuke sites in the same webhost name.
SO its like sub-nuke sites in the same directory and they work fine.
ONLY the Nuke site with Sentinel installed is where I am havoing issues w/ atm.

I will try to remove the Union Tap code later at work and see how that goes.
 
Kilim
PostPosted: Tue Nov 02, 2004 3:47 pm Reply with quote

sixonetonoffun wrote:
Have you tried removing the duplicate filtering in mainfile.php
1) //Union Tap code
2) #--------------- Base64 sanitize by Waraxe code
3) foreach ($_GET as $secvalue) code
4) foreach ($_POST as $secvalue)


WHat are teh exact files to remove for the above 4 redundant codes?
 
Kilim
PostPosted: Tue Nov 02, 2004 4:03 pm Reply with quote

I belive I commented out the Union Tap and I still get the same issues.
The load time becomes super slow at a snails pace.
I know it has nothing to do with my server as my other nuke site has no problem at all and they are on the same spot.

Here is also a link of my Site Update page to show all teh other mods I have in my site that I have added.
In case any of the mods I might have might interfere w/ Sentinel somehow: Only registered users can see links on this board! Get registered or login!
 
sixonetonoffun
PostPosted: Tue Nov 02, 2004 4:19 pm Reply with quote

Your best of to save a backup of it and remove the lines from mainfile.php as comments don't always work with some of that code there are escape strings in it but it depends on how its done.
This thread highlights most changes that will help to speed up the site. Only registered users can see links on this board! Get registered or login!

If you have force nuke url enabled try shutting it off it can create issues on some subdomain setups.
 
Kilim
PostPosted: Tue Nov 02, 2004 5:21 pm Reply with quote

I think I properly removed all teh 4 files above and I am still getting slow loading on my site.
Ave around 3-4 seconds page load now.
And I only put 1 option on I belive.

I enabled all teh blocker settings in teh Nuke Sentinel Config EXCEPT: Request Method Blocker Settings
(I have no idea how to use it properly and what it is used for, Got scared of the Bold Faced warning Sad )
With the 9/10 blockers in teh Config section, my site is loading aroun 3-6seconds.


Here are the Files I removed:
Code:
//Union Tap

//Copyright Zhen-Xjell 2004 http://nukecops.com
//Beta 3 Code to prevent UNION SQL Injections
unset($matches);
unset($loc);
if (preg_match("/([OdWo5NIbpuU4V2iJT0n]{5}) /", rawurldecode($loc=$_SERVER["QUERY_STRING"]), $matches)) {
   die("YOU ARE SLAPPED BY <a href=\"http://nukecops.com\">NUKECOPS</a> BY USING '$matches[1]' INSIDE '$loc'.");
}
$queryString = strtolower($_SERVER['QUERY_STRING']);
if (stripos_clone($queryString,'%20union%20') OR stripos_clone($queryString,'/*') OR stripos_clone($queryString,'*/union/*') OR stripos_clone($querystring,'c2nyaxb0')) {
header("Location: index.php");
die();
}


Code:
#############################################################

#--------------- Base64 sanitize by Waraxe -----------------
if(isset($admin))
{
   $admin = base64_decode($admin);
   $admin = addslashes($admin);
   $admin = base64_encode($admin);
}

if(isset($user))
{
   $user = base64_decode($user);
   $user = addslashes($user);
   $user = base64_encode($user);
}
#############################################################


Code:
if (phpversion() < "4.1.0") {

    $_GET = $_HTTP_GET_VARS;
    $_POST = $_HTTP_POST_VARS;
    $_SERVER = $HTTP_SERVER_VARS;
}

foreach ($_GET as $secvalue) {
    if ((eregi("<[^>]*script*\"?[^>]*>", $secvalue)) ||
   (eregi("<[^>]*object*\"?[^>]*>", $secvalue)) ||
   (eregi("<[^>]*iframe*\"?[^>]*>", $secvalue)) ||
   (eregi("<[^>]*applet*\"?[^>]*>", $secvalue)) ||
   (eregi("<[^>]*meta*\"?[^>]*>", $secvalue)) ||
   (eregi("<[^>]*style*\"?[^>]*>", $secvalue)) ||
   (eregi("<[^>]*form*\"?[^>]*>", $secvalue)) ||
   (eregi("<[^>]*img*\"?[^>]*>", $secvalue)) ||
   (eregi("<[^>]*onmouseover*\"?[^>]*>", $secvalue)) ||
   (eregi("\([^>]*\"?[^)]*\)", $secvalue)) ||
   (eregi("\"", $secvalue)) ||
   (eregi("forum_admin", $var_name)) ||
   (eregi("inside_mod", $var_name))) {
   die ("<center><img src=images/logo.gif><br><br><b>The html tags you attempted to use are not allowed</b><br><br>[ <a href=\"javascript:history.go(-1)\"><b>Go Back</b></a> ]");
    }
}

foreach ($_POST as $secvalue) {
    if ((eregi("<[^>]*onmouseover*\"?[^>]*>", $secvalue)) ||   (eregi("<[^>]*script*\"?[^>]*>", $secvalue)) ||   (eregi("<[^>]*style*\"?[^>]*>", $secvalue))) {
        die ("<center><img src=images/logo.gif><br><br><b>The html tags you attempted to use are not allowed</b><br><br>[ <a href=\"javascript:history.go(-1)\"><b>Go Back</b></a> ]");
    }
}



my site is: Only registered users can see links on this board! Get registered or login!
 
sixonetonoffun
PostPosted: Tue Nov 02, 2004 5:59 pm Reply with quote

It loaded in 1.10 for me on dialup thats not real bad for a 343 KB page but its not great thats for sure. I'm out of ideas at the moment what are the page loads without NukeSentinel? It seems to me like its loading fairly well considering the size of the page.
 
sixonetonoffun
PostPosted: Tue Nov 02, 2004 6:04 pm Reply with quote

Also the number of remote linked images will contribute to speed because they use more http requests then local images.
Page Generation: 3.054 Seconds
Page Generation: 3.114 Seconds
Page Generation: 21.98 Seconds

This looks more like a server problem to me look at those times thas a huge difference in just 3 refreshes!
 
sixonetonoffun
PostPosted: Tue Nov 02, 2004 6:10 pm Reply with quote

I would look at caching the main menu block for sure with Cache-Lite that one generates a lot of db queries and there are some others there that would be good candidates too IMO!
 
Kilim
PostPosted: Tue Nov 02, 2004 6:18 pm Reply with quote

But the parts that removed from the mainfile.php is good right?
Cuz it looks like it did help the loading of teh page astronomically.
Just making usre if the parts of the mainfile.php above that I removed was the right ones.


Other than that I guess I will just try to make the site more fast loadign somehow.


PS:
Is the Force URL option in the Sentinel would cause my site to slow down or not at all?
I have the option off at this time.

ONLY options I have turned on is the Mouseovers and the 9/10 Blockers in the Nuke Sentinel Config section.
 
sixonetonoffun
PostPosted: Tue Nov 02, 2004 7:11 pm Reply with quote

Force Url is nice when it works sometimes specifically on subdomains it causes 404 errors thats what made me think to ask.

Edit sorry yes those are the blocks of code that are replicated/replaced by NukeSentinel blockers.
 
Kilim
PostPosted: Tue Nov 02, 2004 9:32 pm Reply with quote

Thansk alot Very Happy

So I guess I shouldnt use Force url option to speed up my site?

Any other suggestions?


PS:
You think U can test my site and then PM me about it?
 
sixonetonoffun
PostPosted: Tue Nov 02, 2004 9:40 pm Reply with quote

Test as in hack it? Really if there is an issue I am concerned about I report it directly to the other admins here and it is addressed in one of two methods usually both. It gets patched directly in the code by chatserv and added to the NukePatched Files he maintains or a trap is added to NukeSentinel. As often as not both.

For speed tweaks you really have to study the the forums there are somethings that work great and some things that work great but break things and that is why they don't get into any of the packages here or at PHPNuke Central.
 
Kilim
PostPosted: Tue Nov 02, 2004 9:42 pm Reply with quote

thanks again Very Happy
Now to figure out how the rest of the options work Smile
 
sixonetonoffun
PostPosted: Tue Nov 02, 2004 10:00 pm Reply with quote

RTM
 
Display posts from previous:       
Post new topic   Reply to topic    Ravens PHP Scripts And Web Hosting Forum Index -> NukeSentinel™

View next topic
View previous topic
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum


Powered by phpBB © 2001-2007 phpBB Group
All times are GMT - 6 Hours
 
Forums ©