Ravens PHP Scripts: Forums
 

 

View next topic
View previous topic
Post new topic   Reply to topic    Ravens PHP Scripts And Web Hosting Forum Index -> NukeSentinel™
Author Message
Carryconcealed
Hangin' Around


Joined: Jan 31, 2004
Posts: 35

PostPosted: Thu Oct 14, 2004 6:58 am Reply with quote

I ran this install to upgrade Sentinal but now my site gets this error:

Fatal error: Cannot redeclare get_remote_port() (previously declared in /home/carryco/public_html/includes/sentinel.php:284) in /home/carryco/public_html/includes/sentinel.php on line 283


How do I fix this.
 
View user's profile Send private message Send e-mail
GeekyGuy
Client


Joined: Jun 03, 2004
Posts: 302
Location: Huber Heights Ohio

PostPosted: Thu Oct 14, 2004 8:44 am Reply with quote

Carryconcealed,
Make sure the beginning of your mainfile.php looks like this:
Code:
<?php 

if ($forum_admin == 1) {
       include("../../../includes/sentinel.php");
   } elseif ($inside_mod == 1) {
       include("../../includes/sentinel.php");
   } else {
       include("includes/sentinel.php");
   }

/************************************************************************/

You want to make sure you have removed this line:
Code:
include("includes/sentinel.php");

_________________
"The Daytona 500 is ours! We won it, we won it, we won it!", Dale Earnhardt, February 15th, 1998, Daytona 500 
View user's profile Send private message Send e-mail Visit poster's website Yahoo Messenger MSN Messenger ICQ Number
Carryconcealed
PostPosted: Mon Oct 18, 2004 8:41 am Reply with quote

OK,

I wasn't able to fix my site and my hosting restored my backup.

What is weird is that the day before trying to upgrade to 2.0.2 I upgraded PHP-Nuke from 7.3 to 7.4.

When they did the restore, I was back to 7.3 but Sentinal was 2.0.2. Also, if I try to use the Fantastico script installer my host has to upgrade, it crashes my site and won't do the upgrade.

And now, when I log in as an admin, my only option is to log out. I cannot access any of the other modules like banners, content, etc...

I found a way to access the Sentinal config options but can't really do much.

Any help?

Both my personal god admin and the generic administration admin are this way.
 
Jinxinc
New Member
New Member


Joined: Nov 27, 2004
Posts: 1

PostPosted: Sat Nov 27, 2004 7:19 pm Reply with quote

I'm havin the same problem but I'm installing sentinel 2.1.1 with a fresh install. I've installed nuke and sentinel on many sites before, always using chatservs patches and this is the first time I've gotten this error. I tried lookin for the include(includes/sentinel.php) line of code you say to remove but can't seem to find it. What file is it in and about what line???
 
View user's profile Send private message
Display posts from previous:       
Post new topic   Reply to topic    Ravens PHP Scripts And Web Hosting Forum Index -> NukeSentinel™

View next topic
View previous topic
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum


Powered by phpBB © 2001-2007 phpBB Group
All times are GMT - 6 Hours
 
Forums ©