Ravens PHP Scripts: Forums
 

 

View next topic
View previous topic
Post new topic   Reply to topic    Ravens PHP Scripts And Web Hosting Forum Index -> Themes
Author Message
phaylen
New Member
New Member


Joined: Sep 26, 2004
Posts: 3

PostPosted: Sun Sep 26, 2004 10:19 pm Reply with quote

Hi there!

I am using the theme deepblue and trying to replace the default PHPNUKE logo with my customized flash one of the exact same size (I thought this would make it easier) Smile Anyhow if someone can help I'd seriously appreciate it.

Where in this:

Code:
function themeheader() {

    global $banners;
    echo "<body bgcolor=\"#0E3259\" text=\"#000000\" link=\"0000ff\">"
   ."<br>";
    if ($banners) {
   include("banners.php");
   echo "<br>";
    }

    echo "<table border=\"0\" cellpadding=\"0\" cellspacing=\"0\" width=\"840\" align=\"center\">\n"
   ."<tr><td width=\"100%\">\n"
   ."<table border=\"0\" cellpadding=\"0\" cellspacing=\"0\" width=\"840\">\n"
   ."<tr><td width=\"100%\">\n"
   ."<table border=\"0\" cellpadding=\"0\" cellspacing=\"0\" width=\"840\">\n"
   ."<tr><td width=\"100%\" height=\"88\" bgcolor=\"#FFFFFF\">\n"
   ."<table border=0 width=100% cellpadding=0 cellspacing=0><tr><td align=\"left\"><a href=\"index.php\"><img border=\"0\" src=\"themes/DeepBlue/images/logo.gif\" alt=\"Welcome to $sitename!\" hspace=\"20\"></a></td><td align=\"right\"><img border=\"0\" src=\"themes/DeepBlue/images/logo-graphic.gif\"></td></tr></table></td></tr>\n"
   ."<tr><td width=\"100%\" bgcolor=\"#000000\" height=\"19\" valign=\"bottom\">\n"
   ."<a href=\"index.php\"><img border=\"0\" src=\"themes/DeepBlue/images/home.gif\" width=\"140\" height=\"18\"></a>"
   ."<a href=\"account.html\"><img border=\"0\" src=\"themes/DeepBlue/images/account.gif\" width=\"140\" height=\"18\"></a>"
   ."<a href=\"downloads.html\"><img border=\"0\" src=\"themes/DeepBlue/images/downloads.gif\" width=\"140\" height=\"18\"></a>"
   ."<a href=\"submit.html\"><img border=\"0\" src=\"themes/DeepBlue/images/submit.gif\" width=\"140\" height=\"18\"></a>"
   ."<a href=\"topics.html\"><img border=\"0\" src=\"themes/DeepBlue/images/topics.gif\" width=\"140\" height=\"18\"></a>"
   ."<a href=\"top.html\"><img border=\"0\" src=\"themes/DeepBlue/images/top10.gif\" width=\"140\" height=\"18\"></a>"
   ."</td></tr><tr><td width=\"100%\" height=\"10\" bgcolor=\"#d3e2ea\">\n"
   ."</td></tr></table>\n"
   ."</td></tr><tr><td width=\"100%\"><table width='100%' cellspacing='0' cellpadding='0' border='0'><tr><td bgcolor='#d3e2ea'>\n"
;



Do i add this:

Code:
<object classid="clsid:D27CDB6E-AE6D-11cf-96B8-444553540000" codebase="http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=5,0,0,0" width="223" Height ="80">

<param name=movie value="Movie1.swf"><param name=quality value=high><PARAM NAME=menu VALUE=false><embed src="Movie1.swf" quality=high pluginspage="http://www.macromedia.com/shockwave/download/index.cgi?P1_Prod_Version=ShockwaveFlash" type="application/x-shockwave-flash" width="223" Height ="80"></embed></object>


remember the flash file is supposed to replace the src=\"themes/DeepBlue/images/logo.gif but i can't get it to work.

Thanks in advance!

Phaylen
Code:
 
View user's profile Send private message
Raven
Site Admin/Owner


Joined: Aug 27, 2002
Posts: 17077

PostPosted: Sun Sep 26, 2004 10:32 pm Reply with quote

Try this. This assumes the flash movie is in your root directory. Otherwise, adjust the src attribute.
Code:
function themeheader() { 

    global $banners;
    echo "<body bgcolor=\"#0E3259\" text=\"#000000\" link=\"0000ff\">"
   ."<br>";
    if ($banners) {
   include("banners.php");
   echo "<br>";
    }

    echo "<table border=\"0\" cellpadding=\"0\" cellspacing=\"0\" width=\"840\" align=\"center\">\n"
   ."<tr><td width=\"100%\">\n"
   ."<table border=\"0\" cellpadding=\"0\" cellspacing=\"0\" width=\"840\">\n"
   ."<tr><td width=\"100%\">\n"
   ."<table border=\"0\" cellpadding=\"0\" cellspacing=\"0\" width=\"840\">\n"
   ."<tr><td width=\"100%\" height=\"88\" bgcolor=\"#FFFFFF\">\n"
   ."<table border=0 width=100% cellpadding=0 cellspacing=0><tr><td align=\"left\"><object classid=\"clsid:D27CDB6E-AE6D-11cf-96B8-444553540000\" codebase=\"http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=5,0,0,0\" width=\"223\" Height =\"80\">
<param name=movie value=\"Movie1.swf\"><param name=quality value=high><PARAM NAME=menu VALUE=false><embed src=\"Movie1.swf\" quality=high pluginspage=\"http://www.macromedia.com/shockwave/download/index.cgi?P1_Prod_Version=ShockwaveFlash\" type=\"application/x-shockwave-flash\" width=\"223\" Height =\"80\"></embed></object></td><td align=\"right\">&nbsp;</td></tr></table></td></tr>\n"
   ."<tr><td width=\"100%\" bgcolor=\"#000000\" height=\"19\" valign=\"bottom\">\n"
   ."<a href=\"index.php\"><img border=\"0\" src=\"themes/DeepBlue/images/home.gif\" width=\"140\" height=\"18\"></a>"
   ."<a href=\"account.html\"><img border=\"0\" src=\"themes/DeepBlue/images/account.gif\" width=\"140\" height=\"18\"></a>"
   ."<a href=\"downloads.html\"><img border=\"0\" src=\"themes/DeepBlue/images/downloads.gif\" width=\"140\" height=\"18\"></a>"
   ."<a href=\"submit.html\"><img border=\"0\" src=\"themes/DeepBlue/images/submit.gif\" width=\"140\" height=\"18\"></a>"
   ."<a href=\"topics.html\"><img border=\"0\" src=\"themes/DeepBlue/images/topics.gif\" width=\"140\" height=\"18\"></a>"
   ."<a href=\"top.html\"><img border=\"0\" src=\"themes/DeepBlue/images/top10.gif\" width=\"140\" height=\"18\"></a>"
   ."</td></tr><tr><td width=\"100%\" height=\"10\" bgcolor=\"#d3e2ea\">\n"
   ."</td></tr></table>\n"
   ."</td></tr><tr><td width=\"100%\"><table width='100%' cellspacing='0' cellpadding='0' border='0'><tr><td bgcolor='#d3e2ea'>\n"


Edited to escape the double quotes.


Last edited by Raven on Sun Sep 26, 2004 11:39 pm; edited 1 time in total 
View user's profile Send private message
phaylen
PostPosted: Sun Sep 26, 2004 11:31 pm Reply with quote

Thanks, I copied and pasted that into the code exactly where the other was, and i got this error;

Parse error: parse error, unexpected T_STRING, expecting ',' or ';' in /home/filmpr6/public_html/main/themes/DeepBlue/theme.php on line 69

now in line 69 is this code;

."<table border=0 width=100% cellpadding=0 cellspacing=0><tr><td align=\"left\"><object classid="clsid:D27CDB6E-AE6D-11cf-96B8-444553540000" codebase="http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=5,0,0,0" width="223" Height ="80">

Now, it's exactly as it's posted above and I can't figure out where I'm missing a , or ;

Sad You're great for helping me Raven. Thank you
 
Raven
PostPosted: Sun Sep 26, 2004 11:40 pm Reply with quote

The " marks needed to be escaped. I have edited my post. Try copying it again.
 
phaylen
PostPosted: Mon Sep 27, 2004 1:01 am Reply with quote

Raven you are really the best thank you so much for your help!!! It worked!

RavensScripts
 
Display posts from previous:       
Post new topic   Reply to topic    Ravens PHP Scripts And Web Hosting Forum Index -> Themes

View next topic
View previous topic
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum


Powered by phpBB © 2001-2007 phpBB Group
All times are GMT - 6 Hours
 
Forums ©