Ravens PHP Scripts: Forums
 

 

View next topic
View previous topic
Post new topic   Reply to topic    Ravens PHP Scripts And Web Hosting Forum Index -> How To's
Author Message
ruffleader
New Member
New Member


Joined: Oct 01, 2003
Posts: 10

PostPosted: Sat Oct 04, 2003 3:04 pm Reply with quote

i own a sig site now and i am inserting a file uploader to the site.

i do not wish for the files to be saved to the database though from the owner i have been told to make the link change and upload to the directory he used to use.

here is the current coding:

# the upload store directory (chmod 777)
$dir = "store";

how do i alter this to have it to save this on the webpage ??
 
View user's profile Send private message
ruffleader
PostPosted: Sat Oct 04, 2003 4:00 pm Reply with quote

or could anyone point me in the direction of a uploader that will allow me to upload to a site directory base function instead of my site database ???
 
Raven
Site Admin/Owner


Joined: Aug 27, 2002
Posts: 17086

PostPosted: Sat Oct 04, 2003 4:11 pm Reply with quote

I haven't actually tried this yet, although I have it downloaded. See if this is what you're after Only registered users can see links on this board! Get registered or login!
 
View user's profile Send private message
ruffleader
PostPosted: Sat Oct 04, 2003 4:40 pm Reply with quote

cheers, from what i have been through onit it looks like just what i need and looks really good, thanks again
 
porcupinepc
Involved
Involved


Joined: Sep 20, 2003
Posts: 261
Location: Schumacher, Ontario CANADA

PostPosted: Sat Oct 04, 2003 4:57 pm Reply with quote

I just downloaded the same file and am getting the following error. Obviously i have some files in the wrong place. I have modules in modules etc. Appreciate any help. Here's the error im getting:

Warning: opendir(): SAFE MODE Restriction in effect. The script whose uid is 10209 is not allowed to access /usr/local/psa/home/vhosts/porcupinepc.com/httpdocs/forums/modules/My_Uploads owned by uid 0 in /usr/local/psa/home/vhosts/porcupinepc.com/httpdocs/forums/modules/My_Uploads/index.php on line 218

Warning: opendir(modules/My_Uploads/user_folders/joerobertson): failed to open dir: No such file or directory in /usr/local/psa/home/vhosts/porcupinepc.com/httpdocs/forums/modules/My_Uploads/index.php on line 218

Warning: readdir(): supplied argument is not a valid Directory resource in /usr/local/psa/home/vhosts/porcupinepc.com/httpdocs/forums/modules/My_Uploads/index.php on line 220

Account Summary:

Warning: opendir(): SAFE MODE Restriction in effect. The script whose uid is 10209 is not allowed to access /usr/local/psa/home/vhosts/porcupinepc.com/httpdocs/forums/modules/My_Uploads owned by uid 0 in /usr/local/psa/home/vhosts/porcupinepc.com/httpdocs/forums/modules/My_Uploads/index.php on line 98

Warning: opendir(modules/My_Uploads/user_folders/joerobertson): failed to open dir: No such file or directory in /usr/local/psa/home/vhosts/porcupinepc.com/httpdocs/forums/modules/My_Uploads/index.php on line 98

Warning: readdir(): supplied argument is not a valid Directory resource in /usr/local/psa/home/vhosts/porcupinepc.com/httpdocs/forums/modules/My_Uploads/index.php on line 101


Regards

Joe
 
View user's profile Send private message Send e-mail Visit poster's website ICQ Number
ruffleader
PostPosted: Sat Oct 04, 2003 5:01 pm Reply with quote

mine might be the same aint sure though here is what i got out:

File Name File Size Delete Rename

Warning: opendir(): open_basedir restriction in effect. File(/modules/My_Uploads/user_folders/ruffleader) is not within the allowed path(s): (/home/innovat:/usr/lib/php:/usr/local/lib/php:/tmp) in /home/innovat/public_html/thesigsite/modules/My_Uploads/index.php on line 218

Warning: opendir(/modules/My_Uploads/user_folders/ruffleader): failed to open dir: Operation not permitted in /home/innovat/public_html/thesigsite/modules/My_Uploads/index.php on line 218

Warning: readdir(): supplied argument is not a valid Directory resource in /home/innovat/public_html/thesigsite/modules/My_Uploads/index.php on line 220
You have no uploaded files!






Account Summary:

Warning: opendir(): open_basedir restriction in effect. File(/modules/My_Uploads/user_folders/ruffleader) is not within the allowed path(s): (/home/innovat:/usr/lib/php:/usr/local/lib/php:/tmp) in /home/innovat/public_html/thesigsite/modules/My_Uploads/index.php on line 98

Warning: opendir(/modules/My_Uploads/user_folders/ruffleader): failed to open dir: Operation not permitted in /home/innovat/public_html/thesigsite/modules/My_Uploads/index.php on line 98

Warning: readdir(): supplied argument is not a valid Directory resource in /home/innovat/public_html/thesigsite/modules/My_Uploads/index.php on line 101
 
ruffleader
PostPosted: Sat Oct 04, 2003 5:04 pm Reply with quote

it gives me some of the options liek the size of files, my folder url though it replicates it over and over
 
fury
Worker
Worker


Joined: Sep 09, 2003
Posts: 165

PostPosted: Sat Oct 04, 2003 5:04 pm Reply with quote

looks to me like a folder permission problem check your chmod settings to make sure it is the same as what the installation requires
 
View user's profile Send private message
ruffleader
PostPosted: Sat Oct 04, 2003 5:13 pm Reply with quote

the coding from what i have read doesnt mention anything about the chmod settings, there aint a readme or install file with the program either
 
Raven
PostPosted: Sat Oct 04, 2003 5:16 pm Reply with quote

Start by making them all 775 then go to 777 would be my guess.
 
ruffleader
PostPosted: Sat Oct 04, 2003 5:19 pm Reply with quote

nope, nothing happens i had already tried that, i am trying to get in contact with the maker and find out if he knows the problem as this seems a very good thing to use with allowing the user a certain amount of space along with his own folder with work
 
porcupinepc
PostPosted: Sat Oct 04, 2003 5:31 pm Reply with quote

It would have been nice to have a readme file attached. It would be nice to get this going. I am also looking for a decent program to enable my users to upload images to their messages in the forums. I have a "Trading Post" that i operate.

Joe
Only registered users can see links on this board! Get registered or login!
 
fury
PostPosted: Sat Oct 04, 2003 5:32 pm Reply with quote

I installed it on the test site and i am going to see if i can get it to work and i will post here any findings
thanks
Fury
 
Raven
PostPosted: Sat Oct 04, 2003 5:32 pm Reply with quote

porcupinepc wrote:
It would have been nice to have a readme file attached. It would be nice to get this going. I am also looking for a decent program to enable my users to upload images to their messages in the forums. I have a "Trading Post" that i operate.

Joe
Only registered users can see links on this board! Get registered or login!
This exists. I think it's at Only registered users can see links on this board! Get registered or login! but I can't remember for sure.
 
fury
PostPosted: Sat Oct 04, 2003 5:38 pm Reply with quote

ok i found out what has happened on the first error
Code:
Warning: opendir(): open_basedir restriction in effect. File(/modules/My_Uploads/user_folders/ruffleader) is not within the allowed path(s): (/home/innovat:/usr/lib/php:/usr/local/lib/php:/tmp) in /home/innovat/public_html/thesigsite/modules/My_Uploads/index.php on line 218 

It is not allowing to create a directory with the usersname i created one by hand and it worked and the error went away.
working on the second and third errors now.
Thanks
Fury
 
fury
PostPosted: Sat Oct 04, 2003 5:41 pm Reply with quote

ok that has fixed it all from what i see you must have read and write access all the way thru to the modules directory

Modules 775
My_Uploads 775
user_folders 777
Your named folder 777

this is what i could only come up with hopefully someone else knows more and posts.
thanks
Fury
 
ruffleader
PostPosted: Sat Oct 04, 2003 5:42 pm Reply with quote

right so just add a folder for each user and that should solve the first problem yeah and also thanks for the help fury very grateful
 
Raven
PostPosted: Sat Oct 04, 2003 5:45 pm Reply with quote

Raven wrote:
Start by making them all 775 then go to 777 would be my guess.
Just for clarification, that is what I was suggesting here. Ruff, you said you tried it and it didn't work?
 
porcupinepc
PostPosted: Sat Oct 04, 2003 6:31 pm Reply with quote

Yes, i created a directory and it seems ok now.

Also, regarding the "File Attachment Mod 2". I downloaded it from Portedmods. The only thing is there is alot of code to edit. Im a little nervous editing as im scared to screw up the board. Its a slow process.We'll see.

Joe
 
Raven
PostPosted: Sat Oct 04, 2003 6:39 pm Reply with quote

That's how they do most of their modifications. You edit code.
 
ruffleader
PostPosted: Sun Oct 05, 2003 6:07 am Reply with quote

where abouts on the ported mods site is this File Attachment Mod 2
 
ruffleader
PostPosted: Sun Oct 05, 2003 6:47 am Reply with quote

well i have got mine now fully working, thanks for your help.

i found that after i added the folders and change the chmod on the folders things seemed to load partly better.

after this in the main admin section the upload folder section said /modules/my_uploads/user_uploads/

so i took out the ' / ' before modules and everything seemed to work after that.
 
Display posts from previous:       
Post new topic   Reply to topic    Ravens PHP Scripts And Web Hosting Forum Index -> How To's

View next topic
View previous topic
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum


Powered by phpBB © 2001-2007 phpBB Group
All times are GMT - 6 Hours
 
Forums ©