Ravens PHP Scripts: Forums
 

 

View next topic
View previous topic
This forum is locked: you cannot post, reply to, or edit topics.   This topic is locked: you cannot edit posts or make replies.    Ravens PHP Scripts And Web Hosting Forum Index -> NukeSentinel™ Bug Reports
Author Message
Pilgrim
New Member
New Member


Joined: Aug 18, 2004
Posts: 6

PostPosted: Wed Aug 18, 2004 8:26 am Reply with quote

I am using a speed enhanced version of phpnuke 6.9 (DJMaze and steven111's speed hacks found on the nukecops website). Running MySQL 3.23.58 and php 4.2.2 and a couple months ago I installed sentinel 1.20 and had the same problem that this person had in this post Only registered users can see links on this board! Get registered or login! .

When I would run the nsnst.php It would fail to create one field and then when I would go into configuration of the program it would not save the union blocker settings. It would reset itself back to off. I added the code that raven suggested the other poster add. But that did not work . So I went in and created the field manually in myphpAdmin and it worked. The settings would now save.

Now just yesterday I installed sentinel 2.01 on a different nuke website using the same version as above and it failed to create the same two tables that failed in this post Only registered users can see links on this board! Get registered or login! . When I would try to save union blocker it would reset to off. The same thing for referer blocking. When I would use phpmyadmin to check the database the fields had been created but they would not function.

I tried setting the values manually in phpMyAdmin, but while the settings would save in the database, they would not appear in the configuration panel of sentinel even after refreshing the page.

I tried dropping the tables and recreating them. That did not work. I tried dropping the tables and recreating them manually with the sql file that is provided in the download. That did not work. They still reset themselves to off.

So I finally gave up and installed version 1.20 and just created the union blocker field manually like I did for my other website.

Again, that worked.

My question is, by using the method that I did above, will my website be protected against union commands?

And is there a way to install the newest version of sentinel despite my situation above?

Also I think I remember reading somwhere that MYSQL 3 was not vulnerable to the union command. Is this correct?

Thanks in advance.

Pilgrim
 
View user's profile Send private message
sixonetonoffun
Spouse Contemplates Divorce


Joined: Jan 02, 2003
Posts: 2496

PostPosted: Wed Aug 18, 2004 9:19 am Reply with quote

Pilgrim how about using a clean mainfile.php? I've installed some of those speed tweaks without any trouble so I'm guessing the ones you have installed are on the bleeding edge or change functionality.

_________________
[b][size=5]openSUSE 11.4-x86 | Linux 2.6.37.1-1.2desktop i686 | KDE: 4.6.41>=4.7 | XFCE 4.8 | AMD Athlon(tm) XP 3000+ | MSI K7N2 Delta-L | 3GB Black Diamond DDR
| GeForce 6200@433Mhz 512MB | Xorg 1.9.3 | NVIDIA 270.30[/size:2b8 
View user's profile Send private message
Display posts from previous:       
This forum is locked: you cannot post, reply to, or edit topics.   This topic is locked: you cannot edit posts or make replies.    Ravens PHP Scripts And Web Hosting Forum Index -> NukeSentinel™ Bug Reports

View next topic
View previous topic
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum


Powered by phpBB © 2001-2007 phpBB Group
All times are GMT - 6 Hours
 
Forums ©