Ravens PHP Scripts: Forums
 

 

View next topic
View previous topic
Post new topic   Reply to topic    Ravens PHP Scripts And Web Hosting Forum Index -> FCKeditor/WYSIWYG Issues
Author Message
papamike
Theme Guru


Joined: Jan 11, 2006
Posts: 154
Location: Southern Influence

PostPosted: Wed Jan 13, 2016 8:22 pm Reply with quote

I upgraded to ckeditor (WYSIWYG) and tonight I edited a "Message" on my website home page ... and for some reason once I saved it and went back to edit it again the content didn't show in the editor/source. I went to the database and the content shows up there. I'll keep checking and try to find and resolve the problem, if I do I'll post here again.

If you use "Content Plus" for your Blog I have noticed that I can only upload images using the header editor (the top one). I then have to grab it and move it down to the page text or footer text. It's a workable or should I say work around problem just a bit inconvenient
 
View user's profile Send private message
neralex
The Mouse Is Extension Of Arm


Joined: Aug 22, 2007
Posts: 1296
Location: Germany

PostPosted: Fri Jan 15, 2016 12:38 pm Reply with quote

Ok tested with a fresh install of RN251 and a upgrade to ckeditor. It works fine!

Have you tried to clear the browser cache after the upgrade?

If yes and you are getting the same issue and you are using a custom theme, then switch back to a theme of the RN251 package to close out coding errors with your used custom theme. If the issue still exist and you had modified core files of RN then you can start a try & error through all your changes.
 
View user's profile Send private message
papamike
PostPosted: Sat Jan 16, 2016 1:53 pm Reply with quote

Been there done all of that before I posted. I should have probably worded my submission differently.

I am a seasoned user of RavenNuke and have designed themes, since 2006. I make changes to RN quite frequently but nothing to affect any portion of RN or the WYSIWYG editor. I edited a Message that is on my home page, looked at it and saw something in the changes (a typo) that I didn't like so I went back and corrected the typo. I then saw something else I didn't like and when I went back in - all of the input was gone. I checked the db and the content shows up fine. I copied it pasted it in my text editor thinking that maybe I didn't close a quote or something else but everything was fine.

I use Content Plus for my blog and it works fine. The upgrade to WYSIWYG ... ckeditor ... was some time ago and clearing the browser cache will not help with this problem.

The only thing that I haven't tried is copying the text from the db and pasting it into the editor. Tried and didn't work.

Thanks for your input.

Update: I pasted the content to the message (by the way I'm not referring to Private Messages) in question directly into the db through phpMyAdmin but did not solve the problem. I have two other messages on my front page and they are fine. I have checked my code 3 times and cannot find what is causing this problem. I re-uploaded all of the files which have anything to do with the editor and that didn't help.

It has to be something in the code because I removed half of the code, created a new message and pasted the code into the new message and it's fine. I'm going to remove some more and see what happens. I'll keep adding updates in the event I find how to resolve this issue. Maybe it will help someone else in the future.

Fix I Hope .. Using phpMyAdmin I went to the source of the problem message and removed the code, rewrote it, pasted it - not in the source - but in the WYSIWYG itself and now everything works fine. It had to be something in the way that code was handled from the source input that kept the editor from retrieving the data from nuke_messages. But the code was just simple html ..... I most always hand code my entries in the source and have never had a problem.

Oh well ... live and learn!
 
Display posts from previous:       
Post new topic   Reply to topic    Ravens PHP Scripts And Web Hosting Forum Index -> FCKeditor/WYSIWYG Issues

View next topic
View previous topic
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum


Powered by phpBB © 2001-2007 phpBB Group
All times are GMT - 6 Hours
 
Forums ©