Ravens PHP Scripts: Forums
 

 

View next topic
View previous topic
Post new topic   Reply to topic    Ravens PHP Scripts And Web Hosting Forum Index -> RavenNuke(tm) v2.5x
Author Message
Anders
Worker
Worker


Joined: Jun 16, 2004
Posts: 158
Location: Sweden

PostPosted: Thu Sep 11, 2014 11:32 am Reply with quote

hi i have problem with ň ń ÷ any that can help me?
but its show just wierd in forum
looks like this
Yttre G´┐Żllareb´┐Żke Forum Index


Last edited by Anders on Fri Nov 21, 2014 10:00 am; edited 1 time in total 
View user's profile Send private message
neralex
Site Admin


Joined: Aug 22, 2007
Posts: 1482

PostPosted: Thu Sep 11, 2014 2:36 pm Reply with quote

Sounds like a collation mismatch in your database. That's happend if you have a database created maybe with a UTF-8 collation and in there entries with a another collation. Search the entry in your database and check if the specialchars are also not readable.

_________________
Only registered users can see links on this board! Get registered or login!

Last edited by neralex on Fri Sep 12, 2014 10:38 am; edited 1 time in total 
View user's profile Send private message
Anders
PostPosted: Fri Sep 12, 2014 5:21 am Reply with quote

Hi
It's seems to be ok in database and its a clean install no changes
the main page handle ┼ ─ Í perfect its just the darn forum
can fault be on the hostserver?
 
neralex
PostPosted: Fri Sep 12, 2014 6:13 am Reply with quote

Where you are getting this issue? In forum titles or topic titles or topic text?
 
Anders
PostPosted: Fri Sep 12, 2014 7:01 am Reply with quote

all the places you told titles, topic titles ,topic tex
 
neralex
PostPosted: Fri Sep 12, 2014 10:32 am Reply with quote

I tested on my local installations and can't reproduce this issue - all fine! Which colation have your database and which collation have the database-table with the entries?
 
Anders
PostPosted: Fri Sep 12, 2014 10:45 am Reply with quote

database is utf8mb4_general_ci and database table is latin1_swedish_ci and i have test shift around to diffrent but no luck
 
neralex
PostPosted: Fri Sep 12, 2014 11:15 am Reply with quote

Anders wrote:
database is utf8mb4_general_ci and database table is latin1_swedish_ci


That is the cause! You should have the same collation.

Create a new database with latin1_swedish_ci and then start the db-install of RN again.
 
Anders
PostPosted: Fri Sep 12, 2014 11:24 am Reply with quote

ok thx i give that a try
 
Anders
PostPosted: Fri Sep 12, 2014 12:28 pm Reply with quote

Nope its same i have latin1_swedish_ci on every place still no go
 
neralex
PostPosted: Fri Sep 12, 2014 1:07 pm Reply with quote

Create a new database and try to use: utf8_general_ci

After that run the db-installer. It works for me in more than 15 installations.

Please don't change an existend db!!

Add this database+pw in your config.php
 
Anders
PostPosted: Sat Sep 13, 2014 6:13 am Reply with quote

Now it works did talk to host and he did do something what i dont know but will ask him...and i have utf8mb4_general_ci as i not can change that and tables at utf8_general_ci dam...thx for all help
 
Anders
PostPosted: Sat Sep 13, 2014 6:19 am Reply with quote

too fast grrr topic title dont show

preview dont work even
 
hicuxunicorniobestbuildpc
The Mouse Is Extension Of Arm


Joined: Aug 13, 2009
Posts: 1005
Location: Netherland

PostPosted: Sat Sep 13, 2014 8:03 am Reply with quote

Hi Anders

What FTP software are you using? Do not forget to clean your cache from the browser. Try to run your installation with FF(firefox). What is your default language on the website? can you please show us the link from your website?
 
View user's profile Send private message Visit poster's website
Anders
PostPosted: Sat Sep 13, 2014 9:44 am Reply with quote

i use smartftp and it have work b4 so that should not be the problem ihope...and i will give FF a test just weird if that should help...
default lang is english
 
hicuxunicorniobestbuildpc
PostPosted: Sat Sep 13, 2014 10:58 am Reply with quote

My experience with SmartFTP was not good. Lots of permission problems in the past. I don't know if they improve it.

Check it out.
Only registered users can see links on this board! Get registered or login!

Where is the link for your website. I would like to check it.

Can you do yourself a favor. Try this FTP and upload all RavenNuke files again. If you don't like the program. I can advice you FlashFXP which is my favorite. I never had any single problem with it.
Only registered users can see links on this board! Get registered or login!

If you do these steps we suggest you it would be more easy to find out where your issues are coming from.

When you enter to your your MySQL Databases on your phpMyadmin you need to see this collation neralex mentioned before. Please follow steps so you can find your problem asap.



collation2.png
 Description:
collation2
 Filesize:  64.79 KB
 Viewed:  20853 Time(s)

collation2.png



collation.png
 Description:
collation
 Filesize:  21.01 KB
 Viewed:  20854 Time(s)

collation.png


 
Anders
PostPosted: Sat Sep 13, 2014 11:24 am Reply with quote

i have done all what neralex have told me and i have exactly data base as your images now....

I think I am an experimental rabbit to the new webhost
they have called in expert help later
 
neralex
PostPosted: Sun Sep 14, 2014 11:33 am Reply with quote

@hicux, please don't turn him in a wrong direction. He is on the right way. This issue is based on the used database collation or better on the a collation mismatch and can't be a part of FTP permissions. If should have the files wrong permissions so he wouldn't see the website >(!)< because then the files aren't executable or readable. Its a pain to read your false-instruction postings again and again that helps anybody.
 
Anders
PostPosted: Sun Sep 14, 2014 4:33 pm Reply with quote

Yupp little confusing....but i did get from my host Confused raven isn't going to work on our servers Try this Only registered users can see links on this board! Get registered or login!
and they did say some more that i wont take up here....
i hope raven realse ravencms sooooooon
or raven maybe can give them webhost setup lol b4 ň ń ÷ work here
 
Anders
PostPosted: Sun Sep 14, 2014 6:05 pm Reply with quote

They have moved me to a new server now lol...so i must wait and see to dns point work....Sad
 
neralex
PostPosted: Sun Sep 14, 2014 9:04 pm Reply with quote

WTF, if the current RN will not work on their servers and they are recommend old stuff like evo, then RavenCMS will also not work. Its a simple database issue and have nothing to do with the CMS. Anyway.
 
misterstereus
Hangin' Around


Joined: Aug 03, 2012
Posts: 47
Location: Rome Italy

PostPosted: Tue Sep 16, 2014 12:04 am Reply with quote

Hello Anders can I see online your problem? I think you have my Skype account "MisterStereus"

_________________
MisterStereus from Rome Italy!!  
View user's profile Send private message Send e-mail Visit poster's website
Anders
PostPosted: Tue Sep 16, 2014 7:11 am Reply with quote

Hi misterstereus!
I do not have skype anymore ... And even webhost could not fix it, it seems that only xtreme nuke works on their server lol but you can say what the problem is and I will try to upload ravens distro again and install
 
Anders
PostPosted: Tue Sep 16, 2014 7:17 am Reply with quote

Personally, I think it's something with the forum ┼ ─ Í works in ravens distro but the Forum looks F-UP and i have test atleast 5 diffrent Character Sets and Collations setups
 
neralex
PostPosted: Tue Sep 16, 2014 10:26 am Reply with quote

You can see it here in this thread. It works! This installation is a RN251 and i have it tested on my WAMP with a fresh install and don't get this issue.

What is happen if you are using the specialchars in article titles of the News module?
 
Display posts from previous:       
Post new topic   Reply to topic    Ravens PHP Scripts And Web Hosting Forum Index -> RavenNuke(tm) v2.5x

View next topic
View previous topic
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum


Powered by phpBB © 2001-2007 phpBB Group
All times are GMT - 6 Hours
 
Forums ©