Ravens PHP Scripts: Forums
 

 

View next topic
View previous topic
Post new topic   Reply to topic    Ravens PHP Scripts And Web Hosting Forum Index -> RavenNuke(tm) v2.5x
Author Message
dad7732
RavenNuke(tm) Development Team


Joined: Mar 18, 2007
Posts: 1242

PostPosted: Tue Dec 31, 2013 6:55 am Reply with quote

Just upgraded a client to RN 2.5 and she wants a really good center block forum list of posts. Some of the older ones are just not quite what she wants, such as "Forum Collapsing" and so on. Any suggestions welcomed, thanks. Not the right place for this post, please move if necessary.
 
View user's profile Send private message
spasticdonkey
RavenNuke(tm) Development Team


Joined: Dec 02, 2006
Posts: 1693
Location: Texas, USA

PostPosted: Tue Dec 31, 2013 9:23 am Reply with quote

It's unlikely you will find another block that handles all of the view permissions properly. If you look at that block you'll notice how much code is dedicated just to that. What are you looking for in a Forums block?

There is the "Forum News" block which takes a different approach Only registered users can see links on this board! Get registered or login!
or using the Advanced bbcode mod Only registered users can see links on this board! Get registered or login!
 
View user's profile Send private message Visit poster's website
dad7732
PostPosted: Tue Dec 31, 2013 10:12 am Reply with quote

Looking for something like I have there now but a bit less "busy" and a little more plain but configurable for colors and such, etc. Switched to the slash theme for now until the client approves or not and will go from there. Dunno if I'm registered on Tricked Out but will do so in order to download. Thanks - will look after work today.
 
nuken
RavenNuke(tm) Development Team


Joined: Mar 11, 2007
Posts: 2024
Location: North Carolina

PostPosted: Tue Dec 31, 2013 10:23 am Reply with quote

There are a bunch of config options in the collapsing forums block that can limit what is shown.

_________________
Only registered users can see links on this board! Get registered or login! 
View user's profile Send private message Send e-mail Visit poster's website
dad7732
PostPosted: Tue Dec 31, 2013 5:21 pm Reply with quote

nuken wrote:
There are a bunch of config options in the collapsing forums block that can limit what is shown.

That's what we're using now, just looking for some alternatives and yes, there are config options, thanks.
 
dad7732
PostPosted: Wed Jan 01, 2014 10:47 am Reply with quote

Posting back here because forums isn't working now after loading the Forum_News module from the link above. The lists are there but clicking a post brings up just a blank page. Also, clicking a "poster" also brings up a blank page ... Need a solution, thanks.
Only registered users can see links on this board! Get registered or login!
 
nuken
PostPosted: Wed Jan 01, 2014 11:15 am Reply with quote

When you turn on error reporting, what does it say? The module does not change anything in your forums module.
 
dad7732
PostPosted: Wed Jan 01, 2014 11:35 am Reply with quote

Code:


*** YES, THIS IS A BLANK FILE - MAKE SURE PERMISSIONS ARE SET CORRECTLY SO IT CAN BE WRITTEN TO ***
January 1, 2014, 11:30 am File: /home/jay/www/pondlady.com/db/mysqli.php - Line: 201
Code: 1064 - Message: You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'AND ug.user_pending = 0 AND a.group_id = ug.group_id' at line 1
SQL was: SELECT a.forum_id, auth_view, auth_read, a.auth_mod FROM `nuke_bbauth_access` a, `nuke_bbuser_group` ug WHERE ug.user_id = AND ug.user_pending = 0 AND a.group_id = ug.group_id
 remote addr: 192.217.105.150
January 1, 2014, 11:30 am File: /home/jay/www/pondlady.com/db/mysqli.php - Line: 201
Code: 1064 - Message: You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'AND ug.user_pending = 0 AND a.group_id = ug.group_id' at line 1
SQL was: SELECT a.forum_id, auth_view, auth_read, a.auth_mod FROM `nuke_bbauth_access` a, `nuke_bbuser_group` ug WHERE ug.user_id = AND ug.user_pending = 0 AND a.group_id = ug.group_id
 remote addr: 192.217.105.150
January 1, 2014, 11:30 am File: /home/jay/www/pondlady.com/db/mysqli.php - Line: 201
Code: 1064 - Message: You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'AND ug.user_pending = 0 AND a.group_id = ug.group_id' at line 1
SQL was: SELECT a.forum_id, auth_view, auth_read, a.auth_mod FROM `nuke_bbauth_access` a, `nuke_bbuser_group` ug WHERE ug.user_id = AND ug.user_pending = 0 AND a.group_id = ug.group_id
 remote addr: 192.217.105.150
January 1, 2014, 11:30 am File: /home/jay/www/pondlady.com/db/mysqli.php - Line: 201
Code: 1064 - Message: You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'AND ug.user_pending = 0 AND a.group_id = ug.group_id' at line 1
SQL was: SELECT a.forum_id, auth_view, auth_read, a.auth_mod FROM `nuke_bbauth_access` a, `nuke_bbuser_group` ug WHERE ug.user_id = AND ug.user_pending = 0 AND a.group_id = ug.group_id
 remote addr: 192.217.105.150
January 1, 2014, 11:30 am File: /home/jay/www/pondlady.com/db/mysqli.php - Line: 201
Code: 1064 - Message: You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'AND ug.user_pending = 0 AND a.group_id = ug.group_id' at line 1
SQL was: SELECT a.forum_id, auth_view, auth_read, a.auth_mod FROM `nuke_bbauth_access` a, `nuke_bbuser_group` ug WHERE ug.user_id = AND ug.user_pending = 0 AND a.group_id = ug.group_id
 remote addr: 184.188.98.54
January 1, 2014, 11:30 am File: /home/jay/www/pondlady.com/db/mysqli.php - Line: 201
Code: 1064 - Message: You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'AND ug.user_pending = 0 AND a.group_id = ug.group_id' at line 1
SQL was: SELECT a.forum_id, auth_view, auth_read, a.auth_mod FROM `nuke_bbauth_access` a, `nuke_bbuser_group` ug WHERE ug.user_id = AND ug.user_pending = 0 AND a.group_id = ug.group_id
 remote addr: 184.188.98.54
January 1, 2014, 11:30 am File: /home/jay/www/pondlady.com/db/mysqli.php - Line: 201
Code: 1064 - Message: You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'AND ug.user_pending = 0 AND a.group_id = ug.group_id' at line 1
SQL was: SELECT a.forum_id, auth_view, auth_read, a.auth_mod FROM `nuke_bbauth_access` a, `nuke_bbuser_group` ug WHERE ug.user_id = AND ug.user_pending = 0 AND a.group_id = ug.group_id
 remote addr: 184.188.98.54
January 1, 2014, 11:30 am File: /home/jay/www/pondlady.com/db/mysqli.php - Line: 201
Code: 1064 - Message: You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'AND ug.user_pending = 0 AND a.group_id = ug.group_id' at line 1
SQL was: SELECT a.forum_id, auth_view, auth_read, a.auth_mod FROM `nuke_bbauth_access` a, `nuke_bbuser_group` ug WHERE ug.user_id = AND ug.user_pending = 0 AND a.group_id = ug.group_id
 remote addr: 184.188.98.54
January 1, 2014, 11:30 am File: /home/jay/www/pondlady.com/db/mysqli.php - Line: 201
Code: 1064 - Message: You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'AND ug.user_pending = 0 AND a.group_id = ug.group_id' at line 1
SQL was: SELECT a.forum_id, auth_view, auth_read, a.auth_mod FROM `nuke_bbauth_access` a, `nuke_bbuser_group` ug WHERE ug.user_id = AND ug.user_pending = 0 AND a.group_id = ug.group_id
 remote addr: 184.188.98.54
January 1, 2014, 11:30 am File: /home/jay/www/pondlady.com/db/mysqli.php - Line: 201
Code: 1064 - Message: You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'AND ug.user_pending = 0 AND a.group_id = ug.group_id' at line 1
SQL was: SELECT a.forum_id, auth_view, auth_read, a.auth_mod FROM `nuke_bbauth_access` a, `nuke_bbuser_group` ug WHERE ug.user_id = AND ug.user_pending = 0 AND a.group_id = ug.group_id
 remote addr: 192.217.105.150
January 1, 2014, 11:30 am File: /home/jay/www/pondlady.com/db/mysqli.php - Line: 201
Code: 1064 - Message: You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'AND ug.user_pending = 0 AND a.group_id = ug.group_id' at line 1
SQL was: SELECT a.forum_id, auth_view, auth_read, a.auth_mod FROM `nuke_bbauth_access` a, `nuke_bbuser_group` ug WHERE ug.user_id = AND ug.user_pending = 0 AND a.group_id = ug.group_id
 remote addr: 192.217.105.150
January 1, 2014, 11:30 am File: /home/jay/www/pondlady.com/db/mysqli.php - Line: 201
Code: 1064 - Message: You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'AND ug.user_pending = 0 AND a.group_id = ug.group_id' at line 1
SQL was: SELECT a.forum_id, auth_view, auth_read, a.auth_mod FROM `nuke_bbauth_access` a, `nuke_bbuser_group` ug WHERE ug.user_id = AND ug.user_pending = 0 AND a.group_id = ug.group_id
 remote addr: 192.217.105.150
January 1, 2014, 11:30 am File: /home/jay/www/pondlady.com/db/mysqli.php - Line: 201
Code: 1064 - Message: You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'AND ug.user_pending = 0 AND a.group_id = ug.group_id' at line 1
SQL was: SELECT a.forum_id, auth_view, auth_read, a.auth_mod FROM `nuke_bbauth_access` a, `nuke_bbuser_group` ug WHERE ug.user_id = AND ug.user_pending = 0 AND a.group_id = ug.group_id
 remote addr: 192.217.105.150
January 1, 2014, 11:31 am File: /home/jay/www/pondlady.com/db/mysqli.php - Line: 201
Code: 1064 - Message: You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'AND ug.user_pending = 0 AND a.group_id = ug.group_id' at line 1
SQL was: SELECT a.forum_id, auth_view, auth_read, a.auth_mod FROM `nuke_bbauth_access` a, `nuke_bbuser_group` ug WHERE ug.user_id = AND ug.user_pending = 0 AND a.group_id = ug.group_id
 remote addr: 66.249.73.233
January 1, 2014, 11:32 am File: /home/jay/www/pondlady.com/db/mysqli.php - Line: 201
Code: 1064 - Message: You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'AND ug.user_pending = 0 AND a.group_id = ug.group_id' at line 1
SQL was: SELECT a.forum_id, auth_view, auth_read, a.auth_mod FROM `nuke_bbauth_access` a, `nuke_bbuser_group` ug WHERE ug.user_id = AND ug.user_pending = 0 AND a.group_id = ug.group_id
 remote addr: 66.249.73.233
January 1, 2014, 11:33 am File: /home/jay/www/pondlady.com/db/mysqli.php - Line: 201
Code: 1064 - Message: You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'AND ug.user_pending = 0 AND a.group_id = ug.group_id' at line 1
SQL was: SELECT a.forum_id, auth_view, auth_read, a.auth_mod FROM `nuke_bbauth_access` a, `nuke_bbuser_group` ug WHERE ug.user_id = AND ug.user_pending = 0 AND a.group_id = ug.group_id
 remote addr: 66.249.73.233
January 1, 2014, 11:33 am File: /home/jay/www/pondlady.com/db/mysqli.php - Line: 201
Code: 1064 - Message: You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'AND ug.user_pending = 0 AND a.group_id = ug.group_id' at line 1
SQL was: SELECT a.forum_id, auth_view, auth_read, a.auth_mod FROM `nuke_bbauth_access` a, `nuke_bbuser_group` ug WHERE ug.user_id = AND ug.user_pending = 0 AND a.group_id = ug.group_id
 remote addr: 192.217.105.150
January 1, 2014, 11:33 am File: /home/jay/www/pondlady.com/db/mysqli.php - Line: 201
Code: 1064 - Message: You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'AND ug.user_pending = 0 AND a.group_id = ug.group_id' at line 1
SQL was: SELECT a.forum_id, auth_view, auth_read, a.auth_mod FROM `nuke_bbauth_access` a, `nuke_bbuser_group` ug WHERE ug.user_id = AND ug.user_pending = 0 AND a.group_id = ug.group_id
 remote addr: 192.217.105.150

 
nuken
PostPosted: Wed Jan 01, 2014 11:37 am Reply with quote

You didn't make any modifications in your forums module did you? The only edits should be made in the Forums_News module only.
 
dad7732
PostPosted: Wed Jan 01, 2014 11:53 am Reply with quote

Looked but didn't make any mods at all.
 
nuken
PostPosted: Wed Jan 01, 2014 11:54 am Reply with quote

If you haven't modified your forums module, try to re upload a fresh install of your forums module and see if that doesn't fix it.
 
dad7732
PostPosted: Wed Jan 01, 2014 11:58 am Reply with quote

Should both the forum and the forum_news modules be active at the same time. I tried all different settings to no avail. Will reload /Forums/ when I get home from work and see what happens. I also noticed that Forum_News loaded something in /includes/ if that makes any difference. Thanks
 
nuken
PostPosted: Wed Jan 01, 2014 12:07 pm Reply with quote

The Forum_News module is totally separate from the Forums module. It uses the forums database to pull the selected forums posts, but does not add, modify or in any way change any part of your site. If you delete the Forum_News module, your site is exactly as it was before the module was installed. They should both be activated but that has no impact on either module.
 
nuken
PostPosted: Wed Jan 01, 2014 12:17 pm Reply with quote

Did you download the correct Forum News module?
There is one for a site with the Advanced BBcode mod added to the forums and one for sites that have not added the mod to the forums. If you installed the one with the ABBC mod and did not install the ABBC mod in your forums, it will not work.
 
dad7732
PostPosted: Wed Jan 01, 2014 12:31 pm Reply with quote

I only installed the first file, not the ABBC. I'll install that one before I move to re-install module Forums.
 
nuken
PostPosted: Wed Jan 01, 2014 12:43 pm Reply with quote

That is the problem. The Forum News module for the ABBC mod has a modified file called head-abbcbox.php that adds the javascript and css needed for the text highlighter mod to work. If the ABBC mod is not installed, than it is trying to open files that do not exist and that is why your forums is not loading. Once you install the ABBC mod, make sure you replace the head-abbcbox.php that comes with the ABBC mod with the one included with the Forums News module.
 
dad7732
PostPosted: Wed Jan 01, 2014 2:24 pm Reply with quote

Yah, above it says "or" use the ABBC one. Maybe there is a text file I didn't read. I'll be home in an hour and will load the other one, thanks.
 
dad7732
PostPosted: Wed Jan 01, 2014 3:30 pm Reply with quote

There is only one head-abbcbox.php file and it in /includes/addons that is ONLY included in the ABBC distro - not found in the other distro Forum-News .. what now?
 
nuken
PostPosted: Wed Jan 01, 2014 3:55 pm Reply with quote

If you do not have the ABBC mod installed on your site and you have that file in your addons folder, you installed the wrong version of the Forum News module and you need to either remove the head-abbcbox.php and the Forum_News module or install the ABBC mod to your site.
 
dad7732
PostPosted: Wed Jan 01, 2014 4:03 pm Reply with quote

Ok, remove /includes/addons/head-abbcbox.php and /modules/Forum_News and then install the Forum_News from the second link above, right?
 
dad7732
PostPosted: Wed Jan 01, 2014 4:11 pm Reply with quote

I removed /includes/addons and /modules/Forum-News and the site no longer loads, just a blank page - something else is wrong, no clue. I removed /modules/Forums/ and re-uploaded and still doesn't work. I'm thinking of re-installing RN 2.51 or maybe I'm just not following this mod for some reason.
 
nuken
PostPosted: Wed Jan 01, 2014 4:11 pm Reply with quote

The second link above is for the ABBC mod. The first link is for the Forum News module which does not include the ABBC mod. Lets try to simplify this whole process, ok?

Delete the Forums News module and the /includes/addons/head-abbcbox.php. That should get your forums back up. Once you do that, we will figure out what you want to do next.
 
nuken
PostPosted: Wed Jan 01, 2014 4:17 pm Reply with quote

Do not remove the entire addons folder, just the head-abbcbox.php file.
 
nuken
PostPosted: Wed Jan 01, 2014 4:22 pm Reply with quote

The web site Only registered users can see links on this board! Get registered or login! still has the head-abbcbox.php file in the addons directory because your page source is still showing it trying to load mods/bbcode_box/bbcode_addons.css which does not exist. Please remove the includes/addons/head-abbcbox.php file and lets see if it loads the forums.
 
dad7732
PostPosted: Wed Jan 01, 2014 6:27 pm Reply with quote

Customer wants to completely start over from scratch. Not my doing, she has been want to do that for some time now. (grumble)
 
Display posts from previous:       
Post new topic   Reply to topic    Ravens PHP Scripts And Web Hosting Forum Index -> RavenNuke(tm) v2.5x

View next topic
View previous topic
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum


Powered by phpBB © 2001-2007 phpBB Group
All times are GMT - 6 Hours
 
Forums ©