Ravens PHP Scripts: Forums
 

 

View next topic
View previous topic
Post new topic   Reply to topic    Ravens PHP Scripts And Web Hosting Forum Index -> RavenNuke(tm) v2.5x
Author Message
jumus
Hangin' Around



Joined: Jul 15, 2008
Posts: 30

PostPosted: Sat Jan 12, 2013 3:32 am Reply with quote

Code:
<fieldset>

<legend><b>$title</b><br>$hotimage</legend>
<table cellSpacing="0" cellPadding="0" width="100%" border="0">
  <tr>
    <td vAlign="top">
    <a href="modules.php?name=Search&query=&topic=$topic"><img src="$tipath$topicimage" border="0" Alt="$topictext" align="right" hspace="10" vspace="10"></a> $content</td>
  </tr>
  <tr>
    <td vAlign="top" align="right"><br>
    <img alt src="themes/.../images/goldpointer.gif" align="middle" width="11" height="10">
    $morelink</td>
  </tr>
</table>
</fieldset>


What did I do wrong? It is working without the fieldset
 
View user's profile Send private message
Guardian2003
Site Admin



Joined: Aug 28, 2003
Posts: 6795
Location: Ha Noi, Viet Nam

PostPosted: Sat Jan 12, 2013 10:40 am Reply with quote

Fieldset is for forms and there is no form element in your sample code.
For tables, you should use 'caption'.
Code:


<table style="border-spacing:0px; padding:0px; width:100%;">
<caption>$title</caption>
  <tr>
    <td style="vertical-align:top;">
    <a href="modules.php?name=Search&query=&topic=$topic"><img style="text-align:right;" src="$tipath$topicimage" alt="$topictext"></a> $content</td>
  </tr>
  <tr>
    ......
 
View user's profile Send private message Send e-mail
hicuxunicorniobestbuildpc
The Mouse Is Extension Of Arm



Joined: Aug 13, 2009
Posts: 1014
Location: Netherland

PostPosted: Sun Jan 13, 2013 6:17 pm Reply with quote

Hi Guardian

Shouldn't be this line

Code:
<a href="modules.php?name=Search&query=&topic=$topic"><img style="text-align:right;" src="$tipath$topicimage" alt="$topictext"></a> $content</td> 


XHTML

Code:
<a href="modules.php?name=Search&amp;query=&amp;topic=$topic"><img style="text-align:right;" src="$tipath$topicimage" alt="$topictext" /></a> $content</td> 
 
View user's profile Send private message Visit poster's website
spasticdonkey
RavenNuke(tm) Development Team



Joined: Dec 02, 2006
Posts: 1693
Location: Texas, USA

PostPosted: Sun Jan 13, 2013 8:14 pm Reply with quote

You are right unicornio. It also looks like the code is using double quotes within a double quoted string; without escaping them.. but hard to say 100% with the code provided. Couple of examples below, notice the escaped double quotes in the second example.

echo '<img src="' . $tipath . $topicimage . '" alt="' . $topictext . '" />';
echo "<img src=\"$tipath$topicimage\" alt=\"$topictext\" />";


also see: [ Only registered users can see links on this board! Get registered or login! ]
 
View user's profile Send private message Visit poster's website
Guardian2003







PostPosted: Mon Jan 14, 2013 2:15 pm Reply with quote

@ Unicornico - my bad! Yes, that should have been an escaped ampersand, thanks for the catch.
If you using HTML, or xHTML you always need to use escaped ampersands. HTML5 is less fussy.
 
Display posts from previous:       
Post new topic   Reply to topic    Ravens PHP Scripts And Web Hosting Forum Index -> RavenNuke(tm) v2.5x

View next topic
View previous topic
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum


Powered by phpBB © 2001-2007 phpBB Group
All times are GMT - 6 Hours
 
Forums ©