Ravens PHP Scripts: Forums
 

 

View next topic
View previous topic
Post new topic   Reply to topic    Ravens PHP Scripts And Web Hosting Forum Index -> FCKeditor/WYSIWYG Issues
Author Message
dad7732
RavenNuke(tm) Development Team


Joined: Mar 18, 2007
Posts: 1242

PostPosted: Sat Oct 27, 2012 9:50 am Reply with quote

FCKEditor does not work with FF 17 and RN 2.4 but does work with RN 2.5. Have a client that does not want to upgrade past 2.4 for whatever reasons. Any idea how to work this out? Client also does not want to downgrade to FF 16 where FCK does work. Got a real dilemma here, any suggestions?

Should add that with FF 17 and RN 2.4 that when clicking on "Edit", the FCK toolbar does not appear and in the edit window is only the source code.

Maybe installing the latest FCK may work in RN 2.4 ?
 
View user's profile Send private message
neralex
The Mouse Is Extension Of Arm


Joined: Aug 22, 2007
Posts: 1329
Location: Germany

PostPosted: Sat Oct 27, 2012 12:34 pm Reply with quote

FF 17 is not a final release maybe it have some issues... the current FF release is 16.0.2!
 
View user's profile Send private message
Palbin
Site Admin


Joined: Mar 30, 2006
Posts: 2583
Location: Pittsburgh, Pennsylvania

PostPosted: Sat Oct 27, 2012 12:45 pm Reply with quote

I am in agreement with neralex, that that is still a beta.

_________________
"Debugging is twice as hard as writing the code in the first place. Therefore, if you write the code as cleverly as possible, you are, by definition, not smart enough to debug it." — Brian W. Kernighan. 
View user's profile Send private message
dad7732
PostPosted: Sat Oct 27, 2012 2:48 pm Reply with quote

Yes I know, I am on the FF progamming team. The change with FF is apparent all the way thru 19.0a1. I ran every beta after 16 and the same thing happens with FCK. Even ran with addons disabled. I don't think the problem is with Firefox because FCK works with RN 2.5, just not with 2.4.x.x

FF 17 (beta) is as close to final as can be, only a few touchups left but nothing major. Only thing that was added was the social integration api. I'll repost with 17 final and see what happens.
 
spasticdonkey
RavenNuke(tm) Development Team


Joined: Dec 02, 2006
Posts: 1693
Location: Texas, USA

PostPosted: Wed Oct 31, 2012 6:58 pm Reply with quote

Make sure the theme being used does not have a div with an id of content. At least one theme had that issue in v2.4. Possibly SimplyBlue, but cannot remember for sure...
Only registered users can see links on this board! Get registered or login!
 
View user's profile Send private message Visit poster's website
dad7732
PostPosted: Wed Oct 31, 2012 7:39 pm Reply with quote

Using the default theme. Also Seamonkey beta doesn't work either but the release does. I thought maybe the UA was being sniffed not allowing the beta but I used a UA switcher and that didn't do the trick. Will wait for the final and try again.
 
spasticdonkey
PostPosted: Wed Oct 31, 2012 8:35 pm Reply with quote

RavenIce with rn2.4.XX has that issue
<div id="content">

It was changed to
<div id="main_content">
in rn2.5

you would also need to change #content to #main_content within the style.css file.
 
dad7732
PostPosted: Wed Oct 31, 2012 9:34 pm Reply with quote

RN 2.4 -- Changing #content to #main_content in Ravenice causes the left and right blocks to vanish.
 
spasticdonkey
PostPosted: Thu Nov 01, 2012 6:13 am Reply with quote

did you also make the change to theme.php? If so, did you make sure to clear firefox's overly-aggressive cache? If you made the edit to the theme did the fckeditor start working? BTW, this is the line in theme.php you'll be looking for

echo '</div>
</div></div>
<div id="content">';


I am unable to check the change logs prior to 2.41 so there could be another change, if the above suggestions don't work I would use a file comparison tool to check the 2.4 vs 2.5 RavenIce. I don't recall any changes to how the WYSIWYG editor is implemented from 2.4 to 2.5 so it's likely a theme problem. You could verify by trying some other themes.
 
dad7732
PostPosted: Tue Nov 20, 2012 7:52 pm Reply with quote

Running with theme fisubice, fckeditor does the same thing - shows source only, no toolbars, etc.

Updated to FF 17 release today, same anomaly as in the 17 beta.

So what do I edit in theme.php and the style.css file in fisubice.
 
neralex
PostPosted: Wed Nov 21, 2012 3:36 am Reply with quote

After a test with RN4001 and php5 i can say, the problem is based in the file: includes/fckeditor/fckeditor_php5.php

It seems the issue is inside the function FCKeditor_IsCompatibleBrowser() with the checks of the user agent.

Code:
function FCKeditor_IsCompatibleBrowser()

{
   if ( isset( $_SERVER ) ) {
      $sAgent = $_SERVER['HTTP_USER_AGENT'] ;
   }
   else {
      global $HTTP_SERVER_VARS ;
      if ( isset( $HTTP_SERVER_VARS ) ) {
         $sAgent = $HTTP_SERVER_VARS['HTTP_USER_AGENT'] ;
      }
      else {
         global $HTTP_USER_AGENT ;
         $sAgent = $HTTP_USER_AGENT ;
      }
   }

   if ( strpos($sAgent, 'MSIE') !== false && strpos($sAgent, 'mac') === false && strpos($sAgent, 'Opera') === false )
   {
      $iVersion = (float)substr($sAgent, strpos($sAgent, 'MSIE') + 5, 3) ;
      return ($iVersion >= 5.5) ;
   }
   else if ( strpos($sAgent, 'Gecko/') !== false )
   {
      $iVersion = (int)substr($sAgent, strpos($sAgent, 'Gecko/') + 6, 8) ;
      return ($iVersion >= 20030210) ;
   }
   else if ( strpos($sAgent, 'Opera/') !== false )
   {
      $fVersion = (float)substr($sAgent, strpos($sAgent, 'Opera/') + 6, 4) ;
      return ($fVersion >= 9.5) ;
   }
   else if ( preg_match( "|AppleWebKit/(\d+)|i", $sAgent, $matches ) )
   {
      $iVersion = $matches[1] ;
      return ( $matches[1] >= 522 ) ;
   }
   else
      return false ;
}


So i have checked the public function IsCompatible():

Code:
   public function IsCompatible()

   {
      return FCKeditor_IsCompatibleBrowser() ;
   }


I have tried to disable the check in this function and the editor was loaded in FF17.

Code:
   public function IsCompatible()

   {
      //return FCKeditor_IsCompatibleBrowser() ;
      return true;
   }


Its not a final fix and maybe somebody have an idea to change user agent check inside the function FCKeditor_IsCompatibleBrowser().

Wink
 
fkelly
Former Moderator in Good Standing


Joined: Aug 30, 2005
Posts: 3312
Location: near Albany NY

PostPosted: Wed Nov 21, 2012 9:18 am Reply with quote

Wish I had read this first. My wysiwyg editor wasn't working this morning either, on a RN2.5 release. After mucking around sticking in echoes I worked my way into the function FCKeditor_IsCompatibleBrowser() function too.

$iVersion = (int)substr($sAgent, strpos($sAgent, 'Gecko/') + 6, Cool ;
// return ($iVersion >= 20030210) ;
return ($iVersion);
}

I'm not sure about PHP return syntax, I think it might not be returning true if the version is below 20030210? At any rate commenting out that return and just returning anything with Gecko in it seems to be a temporary fix. The real fix is to load up ckeditor, which will come with RN3.0 but I don't have time for that right now.

As you noted this is in the file: /includes/fckeditor/fckeditor_php5.php. This is just a bandage type fix and I'd be open to other solutions. Send me a few hours of free time for instance so I could muck with loading up ckeditor.
 
View user's profile Send private message Visit poster's website
dad7732
PostPosted: Wed Nov 21, 2012 9:44 am Reply with quote

The FCKeditor in 2.5 works here with FF 17 and up. FCKeditor in RN 2.4 does not work with FF 17 and up. I just loaded up FF 20.0a1 that was released this morning and no-go, same problems in RN 2.4.

Now, can someone tell me that replacing the FCKeditor in RN 2.4 with the one in RN 2.5 will work?
 
neralex
PostPosted: Wed Nov 21, 2012 9:49 am Reply with quote

Yes, for all RN25 users is the best solution to switch on the ckeditor...
 
dad7732
PostPosted: Wed Nov 21, 2012 9:53 am Reply with quote

I'm speaking of RN 2.4 users. Will the RN 2.5 version of FCKeditor work with RN 2.4?
 
dad7732
PostPosted: Wed Nov 21, 2012 10:03 am Reply with quote

Frank -- Revising that line as per your reply makes FCKeditor work all the way up to FF 20.0.a1 .. So, it turned out to be the browser-sniff function in the editor and not FF. Thanks
 
hicuxunicorniobestbuildpc
Life Cycles Becoming CPU Cycles


Joined: Aug 13, 2009
Posts: 967
Location: Netherland

PostPosted: Thu Nov 22, 2012 2:19 am Reply with quote

FF 17 has been released yesterday.
 
View user's profile Send private message Visit poster's website
dad7732
PostPosted: Thu Nov 22, 2012 7:18 am Reply with quote

Actually released on Tuesday the 20th, but "yesterday" is close enough. Smile

BTW: All Mozilla releases are on a Tuesday.
 
matthew234
New Member
New Member


Joined: Nov 22, 2012
Posts: 2

PostPosted: Thu Nov 22, 2012 7:31 am Reply with quote

Just registered to post this, but registration appalling, kept getting false redirect, till it randomly worked, must have duff coders here!!

The issue is Firefox have changed the user agent string, specifically the Gecko version number, dropping it right down to 17!! that causes the compatibility check to fail as its looking for Gecko > 20030210

My fix:

In fckeditor/fckeditor_php5.php

replace:

Code:
else if ( strpos($sAgent, 'Gecko/') !== false )

   {
      $iVersion = (int)substr($sAgent, strpos($sAgent, 'Gecko/') + 6, 8) ;
      return ($iVersion >= 20030210) ;
   }


with:

Code:
   else if ( strpos($sAgent, 'Gecko/') !== false )

   {
      $iVersion = (int)substr($sAgent, strpos($sAgent, 'Gecko/') + 6, 8) ;
      if ($iVersion < 20030210)
      {
         if ( strpos($sAgent, 'Firefox/') !== false )
            return ((int)substr($sAgent, strpos($sAgent, 'Firefox/') + 8, 2) >= 17);
         else
            return false;
      }
      return true;   
   }
 
View user's profile Send private message
dad7732
PostPosted: Thu Nov 22, 2012 9:58 am Reply with quote

The new useragent string:

Mozilla/5.0 (Windows NT 5.1; rv:17.0) Gecko/17.0 Firefox/17.0

Some banking sites didn't work as well as some other sites. For instance, if Capitalone.com doesn't work (example only), then in the about:config, add:

general.useragent.override.capitalone.com Gecko/[^ ]*#Gecko/20100101

Do the same for any sites that have problems with UA String problems.
 
matthew234
PostPosted: Thu Nov 22, 2012 11:43 am Reply with quote

dad7732 wrote:
in the about:config, add:

general.useragent.override.capitalone.com Gecko/[^ ]*#Gecko/20100101


Nice fix for your own browser but not suitable for your clients, requiring them to change browser config setting is dangerous.

Does anyone know what's Mozilla's reasoning with the version # drop?
 
dad7732
PostPosted: Thu Nov 22, 2012 7:43 pm Reply with quote

First of all I have to provide what my PAYING client demands regardless of my pressing issues, etc. Not dangerous if I oversee the change, etc.

Reasoning .. Read for yourself:
Only registered users can see links on this board! Get registered or login!
 
fkelly
PostPosted: Thu Nov 22, 2012 8:04 pm Reply with quote

Put this in perspective. Fckeditor is out-dated and there is a replacement available. What we are talking about here is a a temporary patch to keep things running for a limited time until you have time to update to Ckeditor. Hopefully they are not doing user agent sniffing the same way that fckeditor is.

Also, in perspective, the whole purpose of a wysiwyg editor doing such "sniffing" is to try to assure that it doesn't present a wysiwyg textarea to an old browser that won't support it. From what I see, users with those browsers are not going to have a satisfactory experience anyway. On a practical basis, falling back to a standard textarea is going to be troublesome with the complex html text that goes into many of our pages.
 
Display posts from previous:       
Post new topic   Reply to topic    Ravens PHP Scripts And Web Hosting Forum Index -> FCKeditor/WYSIWYG Issues

View next topic
View previous topic
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum


Powered by phpBB © 2001-2007 phpBB Group
All times are GMT - 6 Hours
 
Forums ©