Ravens PHP Scripts: Forums
 

 

View next topic
View previous topic
Post new topic   Reply to topic    Ravens PHP Scripts And Web Hosting Forum Index -> FCKeditor/WYSIWYG Issues
Author Message
dad7732
RavenNuke(tm) Development Team


Joined: Mar 18, 2007
Posts: 1242

PostPosted: Fri Mar 26, 2010 10:37 am Reply with quote

RN 2.3.01
FCKEditor up to date
/javascript and /jquery up to date

FCKEditor copied from RN 2.4
/javascript and /jquery copied from RN 2.4

Editor works just fine, no problem there.

Image linked with Lightbox works (displays ok) but instead of being displayed where the original image displays, the LB image displays at the very bottom left corner side of the screen well below the theme display. Theme doesn't matter, tried in several including fisubice and ravenice, still the problem.

Other domains running RN 2.4, no problem, just this one domain still on 2.3.01

Cheers
 
View user's profile Send private message
nuken
RavenNuke(tm) Development Team


Joined: Mar 11, 2007
Posts: 2024
Location: North Carolina

PostPosted: Fri Mar 26, 2010 10:41 am Reply with quote

Sounds like a css issue.

_________________
Only registered users can see links on this board! Get registered or login! 
View user's profile Send private message Send e-mail Visit poster's website
dad7732
PostPosted: Fri Mar 26, 2010 11:34 am Reply with quote

nuken wrote:
Sounds like a css issue.


Possible I suppose but changing themes doesn't matter and the FCKEditor is supposedly up to date. Where else to look, another CSS file somewhere?

Cheers

Edit: The best thing of course is to update the site to RN 2.4 but the site is soooo very much customized, it'll take some time.
 
dad7732
PostPosted: Mon Mar 29, 2010 7:42 pm Reply with quote

New problem. Installed/updated this same site to 2.40.01 and the LightBox preference is not in the Editor under "Link" like it was in 2.30.01 .. disappeared. /javascript and /jquery are still there as before .. dunno what we did to get it to show in the previous versions, will try searching here again as I think there was some mod to install or edit a file or two.

Cheers
 
nuken
PostPosted: Mon Mar 29, 2010 7:48 pm Reply with quote

It was an addon. RavenNuke has never had it in the distro.
 
dad7732
PostPosted: Mon Mar 29, 2010 8:23 pm Reply with quote

Ok, I got the addon back and installed but back to the same problem when clicking on a thumb, the larger image displays well below the theme border. Try it yourself:
Only registered users can see links on this board! Get registered or login!

Click on the first "beer" image and see what happens. Theme doesn't matter, it does the same in all other themes including Ravenice and Fisubice.

Cheers

Update: Changed back to my original theme and loaded another style.css mod and works now like a charm. Groovy
 
dad7732
PostPosted: Mon Mar 29, 2010 10:04 pm Reply with quote

Ok, success. Went back to my original custom theme, loaded another css mod to style.css and works now like a charm. ROTFL
 
dad7732
PostPosted: Wed Mar 31, 2010 7:11 am Reply with quote

Ok, I found what the real problem was that caused this from the very beginning, wasn't the CSS file but rather:

File: Lightbox_Addon.zip
Errant Instructions: Edit Javascript.php

Quote:
-----------Find------------------

if (defined('MODULE_FILE') AND file_exists('modules/'.$name.'/copyright.php')) {
echo '<script type="text/javascript">'."\n";
echo '<!--'."\n";
echo 'function openwindow(){'."\n";
echo ' window.open (\'modules/'.$name.'/copyright.php\',\'Copyright\',\'toolbar=no,location=no,directories=no,status=no,scrollbars=yes,resizable=no,copyhistory=no,width=400,height=200\');'."\n";
echo "}\n";
echo '//-->'."\n";
echo '</script>'."\n\n";
}
---------After That add------------------------
echo "<script type=\"text/javascript\" src=\"/includes/javascript/prototype.js\"></script>";
echo "<script type=\"text/javascript\" src=\"/includes/javascript/scriptaculous.js?load=effects,builder\">></script>";
echo "<script type=\"text/javascript\" src=\"/includes/javascript/lightbox.js\"></script>";


--------Done--------------


Now, I am not a programmer by any stretch but IIRC you cannot include the "echo" statements outside of braces { }.

So, this is what I did:

Quote:
-----------Find------------------

if (defined('MODULE_FILE') AND file_exists('modules/'.$name.'/copyright.php')) {
echo '<script type="text/javascript">'."\n";
echo '<!--'."\n";
echo 'function openwindow(){'."\n";
echo ' window.open (\'modules/'.$name.'/copyright.php\',\'Copyright\',\'toolbar=no,location=no,directories=no,status=no,scrollbars=yes,resizable=no,copyhistory=no,width=400,height=200\');'."\n";
echo "}\n";
echo '//-->'."\n";
echo '</script>'."\n\n";

---------After That add------------------------
echo "<script type=\"text/javascript\" src=\"/includes/javascript/prototype.js\"></script>";
echo "<script type=\"text/javascript\" src=\"/includes/javascript/scriptaculous.js?load=effects,builder\">></script>";
echo "<script type=\"text/javascript\" src=\"/includes/javascript/lightbox.js\"></script>";
}

--------Done--------------



Note where the closing brace } is now. My lightbox works as intended now, no problems at all.

Cheers

PS: Thought I should add that this is a really GREAT add-on, works well, easy to install and so on .. Smile

Thanks
 
nuken
PostPosted: Wed Mar 31, 2010 9:16 am Reply with quote

There are known conflicts with running the prototype/scriptaculous along side jquery. I have several alternatives on my site that use jquery so no conflicts arise. One uses the colorbox addon that is already in RavenNuke. Another that uses slimbox which is a direct jquery replacement for lightbox.

Also, with the use of addCSSToHead and addJSToHead in RavenNuke 2.4, it would be better the make a file in includes/addons called head-yourfilename.php to call css and js into the head of RavenNuke with something like this in it:

Code:


<?php
if (stristr(htmlentities($_SERVER['PHP_SELF']), 'head-yourfilename.php')) {
   Header('Location: ../../index.php');
   die();
}
addCSSToHead('locationofcssfilehere', 'file');
addJSToHead('locationofjsfilehere','file');
?>
 
dad7732
PostPosted: Wed Mar 31, 2010 4:20 pm Reply with quote

The site works just fine with RN 2.40.01 with LightBox_Addon and correcting the javascript.php edit. Should there be anything else added in besides that? What "conflicts" should I be on the lookout for?

Cheers
 
nuken
PostPosted: Wed Mar 31, 2010 6:45 pm Reply with quote

Both jQuery and prototype define “$” as an alias. So when both libraries are included, the browser doesn't know which to use. That is why I made the slimbox mod because it is a jquery clone of lightbox. Now that colorbox is included in RavenNuke, it kind of makes them all redundant. I had users that experienced issues with logins and on some clan modules that would not work. If it works for you, cool.
 
spasticdonkey
RavenNuke(tm) Development Team


Joined: Dec 02, 2006
Posts: 1693
Location: Texas, USA

PostPosted: Wed Mar 31, 2010 7:14 pm Reply with quote

I ran into issues with the Member Map module (very cool module, which uses jquery) using prototype/scriptaculous...
Image

good chance you will run into problems with other jquery scripts as well.
 
View user's profile Send private message Visit poster's website
Display posts from previous:       
Post new topic   Reply to topic    Ravens PHP Scripts And Web Hosting Forum Index -> FCKeditor/WYSIWYG Issues

View next topic
View previous topic
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum


Powered by phpBB © 2001-2007 phpBB Group
All times are GMT - 6 Hours
 
Forums ©