Ravens PHP Scripts: Forums
 

 

View next topic
View previous topic
Post new topic   Reply to topic    Ravens PHP Scripts And Web Hosting Forum Index -> Captcha Security
Author Message
kenno
Worker
Worker


Joined: Jul 26, 2009
Posts: 117
Location: Scunthorpe, UK

PostPosted: Sun Dec 20, 2009 5:25 am Reply with quote

Hi Guys

Just wandering if any of you had come across this issue before.
Basically what happens is when you log onto my ravennuke sites using your mobile phone, everytime you type the captcha code in, it always comes back saying it is the incorrect code.

Now it does actually log you in the site even after saying this, it is just annoying and was hoping it might be an easy fix

Any help appreciated

thanks Kenno
 
View user's profile Send private message
montego
Site Admin


Joined: Aug 29, 2004
Posts: 9456
Location: Arizona

PostPosted: Mon Dec 21, 2009 6:19 am Reply with quote

Interesting. Sounds like an artifact of the phone's browser. I don't know if it helps at all, but the captcha uses PHP sessions for validation, but it is odd that it throws the error and still logs them in... trying to wrap my head around that one!

_________________
Only registered users can see links on this board! Get registered or login!
Only registered users can see links on this board! Get registered or login! 
View user's profile Send private message Visit poster's website
fkelly
Former Moderator in Good Standing


Joined: Aug 30, 2005
Posts: 3312
Location: near Albany NY

PostPosted: Mon Dec 21, 2009 11:27 am Reply with quote

You can also turn off Captcha. If you are not getting spammed by bots it is just an annoyance. If you start getting spammed you can turn it back on. It's in rnconfig.
 
View user's profile Send private message Visit poster's website
kenno
PostPosted: Mon Dec 21, 2009 3:11 pm Reply with quote

Yes Montego

This is a strange one, it says the code is incorrect but all the time will say hello to your username and you are then signed in to the site as normal.

I don`t fancy turning the Captcha off just for this little issue, especially as it is not actually restricting any body from viewing the sites.

Is it possible that this is something to do with the UK phone networks or is that not possible. Can you guys gain access to yor sites in ok from your USA phones

Thanks Mark
 
montego
PostPosted: Tue Dec 22, 2009 6:29 am Reply with quote

I just got a new phone last night actually that now has the ability to surf the web. I just tried logging into my site and the captcha worked just fine. Mine is a Droid, which looks by the User Agent to be Safari mobile based. So, might be a browser/OS nuance maybe?
 
spiders
Regular
Regular


Joined: Jun 05, 2006
Posts: 90
Location: Aachen / Germany

PostPosted: Tue Dec 22, 2009 12:09 pm Reply with quote

HI,
I have tested it with my new HTC HD2 phone. I just tried logging here and the captcha worked just fine.

Spiders

_________________
Only registered users can see links on this board! Get registered or login! >> the global Web Content Management Services Only registered users can see links on this board! Get registered or login! >> My Raven24 Testside 
View user's profile Send private message Visit poster's website
bobbyg
Worker
Worker


Joined: Dec 05, 2007
Posts: 212
Location: Tampa, Florida

PostPosted: Tue Dec 22, 2009 1:18 pm Reply with quote

Could it be a die; statement is // out thereby allowing it to connect?
 
View user's profile Send private message Visit poster's website
spasticdonkey
RavenNuke(tm) Development Team


Joined: Dec 02, 2006
Posts: 1693
Location: Texas, USA

PostPosted: Tue Dec 22, 2009 6:49 pm Reply with quote

do you have multiple Captcha's on the page? I.E. a login block on the left and the "your account" login? If so, you could try disabling the block and see if that helps.

btw, I have a couple of mobile users that have said my RN site works quite well... (iPhone)
 
View user's profile Send private message Visit poster's website
montego
PostPosted: Wed Dec 23, 2009 7:11 am Reply with quote

spasticdonkey wrote:
do you have multiple Captcha's on the page? I.E. a login block on the left and the "your account" login?


Regarding this point (good one spasticdonkey), if you are running RavenNuke(tm) version 2.40.00, this issue was resolved.
 
kenno
PostPosted: Tue Dec 29, 2009 5:15 am Reply with quote

Hi

Sorry took so long to reply, I have 2 ravennuke sites one using 2.4 and the other 2.3, it does this on both sites.
It is not just my phone this does it on but on quite a few different makes, although I need to try and test it on different mobile networks to see if that makes any difference.

I have just for the first time tried logging onto here using my mobile and something slightly different happened.

When I submitted my login details and inputted the captcha on here, I got a message back on my phone saying "Unable to redirect", so tried this a few times with the same response. It was not till I clicked the "home" link that I could actually see it had logged me in.

So I do not know what the differences are between the 2 different captchas but both have the same issue although the one on here will not actually tell you the code incorrect but it does log you in.

I need to try this on more networks
 
Display posts from previous:       
Post new topic   Reply to topic    Ravens PHP Scripts And Web Hosting Forum Index -> Captcha Security

View next topic
View previous topic
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum


Powered by phpBB © 2001-2007 phpBB Group
All times are GMT - 6 Hours
 
Forums ©