Ravens PHP Scripts: Forums
 

 

View next topic
View previous topic
Post new topic   Reply to topic    Ravens PHP Scripts And Web Hosting Forum Index -> Blocks
Author Message
express
Client


Joined: Jan 03, 2007
Posts: 94

PostPosted: Wed Dec 09, 2009 2:07 pm Reply with quote

This is just an FYI. I am using Ravennuke 2.4 and this version of the treasury block will not work correctly.

I had to use the Nuke Treaury V1._1_2 Evo block instead. "dreadedcorpse" over at clanthemes was the one who figured out the problem for me. I just wanted to pass this tidbit along.
 
View user's profile Send private message
Susann
Moderator


Joined: Dec 19, 2004
Posts: 3191
Location: Germany:Moderator German NukeSentinel Support

PostPosted: Wed Dec 09, 2009 3:10 pm Reply with quote

What do you mean with "will not work correctly" ? What was the problem ?There are some code changes required if you use it wit RavenNuke. I have not found a problem after I did the changes using vers. 1.1.1. The validation errors are more or less simple to solve.
 
View user's profile Send private message
express
PostPosted: Wed Dec 09, 2009 8:26 pm Reply with quote

Hi Susann,
The problem with a regular install of the version 1.1.1 was that the "treasury" page would not read the data from mySQL. All you could get when you went to the admin page and clicked on the treasury module was a plain white html page. I wrote about this in the clanthemes forum and dreadcorpse had heard of similar problem so suggested that I try and install the "evo version" since he had ported it to work on Ravennuke 2.4. So I did just that and the problem was resolved.

What the problem between ravennuke 2.4 and the nuke treasury v1.1.1 I have no idea. That is where you gurus step in:)
 
Doulos
Life Cycles Becoming CPU Cycles


Joined: Jun 06, 2005
Posts: 626

PostPosted: Wed Dec 09, 2009 9:24 pm Reply with quote

Maybe someone could upload an updated copy of v1.1 to RN downloads. Many of these post would go away since NT1.1 would then work with RN2.4.

Just a suggestion.
 
View user's profile Send private message
bobbyg
Worker
Worker


Joined: Dec 05, 2007
Posts: 212
Location: Tampa, Florida

PostPosted: Thu Dec 10, 2009 7:00 am Reply with quote

I had made all the $db changes Susanne had posted awhile back and changes to make it W3C compliance. Raven downloaded my copy, as Ravennuke was going to assume responsibility for that module. I have not compared it to the "evo version".

I am running Ravennuke 2.4 and it went in with no problems. See: Only registered users can see links on this board! Get registered or login!
 
View user's profile Send private message Visit poster's website
express
PostPosted: Thu Dec 10, 2009 10:39 am Reply with quote

I think if you and he( "dreaded")could to talk,
the 2 of you would have an answer in 30 seconds. He at least could tell you what he did in the "evo" version.
 
Guardian2003
Site Admin


Joined: Aug 28, 2003
Posts: 6792
Location: Ha Noi, Viet Nam

PostPosted: Thu Dec 10, 2009 11:47 am Reply with quote

You will probably find that Treasury versions up to and including 1.1 use a different table to 1.1.1 but I'm not 100% sure as it was a long time ago.
If you are using RavenNuke (tm) 2.4 the problem should highlight itself if you have error reporting and dblogging turned on.
If you are mixing and matching different versions of blocks/modules then it definitely isn't going to play nice if the tables are different.

@Doulos - v1.1.1 was intended to correct specific bugs from the v1.1 release so in effect v1.1.1 is the updated version of v1.1 and if I remember correctly from when I released it, v1.1.1 also had two sets of files, one for USD and one for GBP.

I think the most likely cause of the problem is the database abstraction layer as I think all versions up to and including v1.1.1 use $dbi and instead of $db as they were released, probably more than two years ago.

More updated versions were released on my site last year in a variety of currencies but they are commercial ($5) to cover the cost of my bandwidth, support and I had intended to replace them completely with a newer, completely re-written module this year but time kept slipping away from me - sorry.
 
View user's profile Send private message Send e-mail
Display posts from previous:       
Post new topic   Reply to topic    Ravens PHP Scripts And Web Hosting Forum Index -> Blocks

View next topic
View previous topic
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum


Powered by phpBB © 2001-2007 phpBB Group
All times are GMT - 6 Hours
 
Forums ©