Ravens PHP Scripts: Forums
 

 

View next topic
View previous topic
Post new topic   Reply to topic    Ravens PHP Scripts And Web Hosting Forum Index -> eCommerce
Author Message
sak
Worker
Worker


Joined: Jul 06, 2005
Posts: 172

PostPosted: Wed Nov 04, 2009 10:35 am Reply with quote

I installed NOScart 2, and after debugging a few bugs, everything looked OK (store and admin worked).

HOWEVER, whenever a user clicks Add to Cart, they are immediately taken to an empty shopping cart every time. No products can ever be added to the cart - the cart always appears empty. Interestingly enough, the saved shopping cart feature in admin fills up with the items that I add (so it is on some level recognizing that I am adding things). I just can't get them to show up in my cart Bang Head Bang Head

I've been searching all over and alien has been helping me, but we haven't come to any conclusions yet.

Apache version 2.0.63
PHP version 5.2.10
MySQL version 5.0.81-community

Here are the changes I had to make per aliens instruction to get rid of errors (don’t mind that the lines are commented out – I do that in my change-tracking files):


Code:
First 31 lines of modules/catalog/index.php had to be commented out (all lines before line 12 already were commented out):


//$resultcat = sql_query("select categories_id,categories_name from categories_description where //categories_id='$categories_id'", $dbi);
//while(list($categories_id,$categories_name) = sql_fetch_row($resultcat, $dbi)) {
//}

//$result = sql_query("select manufacturers_id, manufacturers_name from manufacturers where //manufacturers_id='$manufacturers_id'", $dbi);
//while(list($manufacturers_id,$manufacturers_name) = sql_fetch_row($result, $dbi)) {

//if($manufacturers_name==""){
//$pagetitle = " - Product Catalog";
//}else{
//$pagetitle = " - Manufacturer - $manufacturers_name";



////////}
//}
//
//}
//



Code:
Modules/catalog/includes/application_top.php



///This is an oscommerce issue not Noscart
///
 navigation history
  if (tep_session_is_registered('navigation')) {
    if (PHP_VERSION < 4) {
      $broken_navigation = $navigation;
      $navigation = new navigationHistory;
      $navigation->unserialize($broken_navigation);
    }
  } else {
    tep_session_register('navigation');
    $navigation = new navigationHistory;
  }
  $navigation->add_current_page();


change to

navigation history
if (tep_session_is_registered('navigation')) { if (PHP_VERSION < 4) { $broken_navigation = $navigation; $navigation = new navigationHistory; $navigation->unserialize($broken_navigation);
} else {
$navigation = new navigationHistory;
}
} else {
tep_session_register('navigation');
$navigation = new navigationHistory;
}
$navigation->add_current_page();


Code:
Modules/catalog/admin/includes/classes/upload.php


change $this in line 31 to $thisxx

_________________
Only registered users can see links on this board! Get registered or login! Only registered users can see links on this board! Get registered or login! 
View user's profile Send private message Visit poster's website
nuken
RavenNuke(tm) Development Team


Joined: Mar 11, 2007
Posts: 2024
Location: North Carolina

PostPosted: Wed Nov 04, 2009 11:00 am Reply with quote

Your $dbi needs to be converted to $db like so.

Code:
$resultcat = $db->sql_query("select categories_id,categories_name from categories_description where categories_id='$categories_id'");

while(list($categories_id,$categories_name) = $db->sql_fetchrow($resultcat)) {
}

$result = $db->sql_query("select manufacturers_id, manufacturers_name from manufacturers where manufacturers_id='$manufacturers_id'");
while(list($manufacturers_id,$manufacturers_name) = $db->sql_fetchrow($result)) {

_________________
Only registered users can see links on this board! Get registered or login! 
View user's profile Send private message Send e-mail Visit poster's website
wHiTeHaT
Life Cycles Becoming CPU Cycles


Joined: Jul 18, 2004
Posts: 576
Location: Netherlands

PostPosted: Wed Nov 04, 2009 11:25 am Reply with quote

i assume it's a cookie and path problem.
btw this code looks like oscommerce
 
View user's profile Send private message Send e-mail Visit poster's website MSN Messenger
sak
PostPosted: Wed Nov 04, 2009 12:05 pm Reply with quote

yes, NOScart 2 is oscommerce ported to nuke.

I updated the db layer. Didn't resolve this problem, but at least that code doesn't have to be commented out anymore.


I thought the same, whitehat. ive been racking my brain trying to get it to work, changing the cookie domains to every combination I can think of. I'm so lost.
 
nuken
PostPosted: Wed Nov 04, 2009 12:28 pm Reply with quote

Have you turned on error reporting to see if any errors are being generated?
 
sak
PostPosted: Wed Nov 04, 2009 3:20 pm Reply with quote

I tried error reporting again after doing a fresh install. No errors on any pages that I can find.
 
wHiTeHaT
PostPosted: Thu Nov 05, 2009 11:48 am Reply with quote

do you have the problem on your localhost or on your live site?
If it is your localhost , do you run php 5xx?
 
bdmdesign
Worker
Worker


Joined: May 11, 2009
Posts: 154
Location: Winsen/Luhe; Germany

PostPosted: Fri Nov 06, 2009 4:49 am Reply with quote

Wich Raven Nuke Version do you use ??

This problem i know only too well.

If you use Ravennuke 2.4 please have a look in your mainfile:

Search:
Code:


if ($phpver >= '4.0.4pl1' && isset($_SERVER['HTTP_USER_AGENT']) && strstr($_SERVER['HTTP_USER_AGENT'],'compatible')) {
   if (extension_loaded('zlib')) {
      @ob_end_clean();
      ob_start('ob_gzhandler');
   }
} elseif ($phpver > '4.0' && isset($_SERVER


Now go to line 62 and change the code on this line to:

Code:


  //ob_start('ob_gzhandler');
  ini_set("zlib.output_compression", '6');


Now you must have it so:

Code:


if ($phpver >= '4.0.4pl1' && isset($_SERVER['HTTP_USER_AGENT']) && strstr($_SERVER['HTTP_USER_AGENT'],'compatible')) {
   if (extension_loaded('zlib')) {
      @ob_end_clean();
  //ob_start('ob_gzhandler');
  ini_set("zlib.output_compression", '6');
   }
} elseif ($phpver > '4.0' && isset($_SERVER['HTTP_ACCEPT_ENCODING']) && !empty($_SERVER['HTTP_ACCEPT_ENCODING'])) {


Backup your Mainfile before change the code.
I hope its works for NOScart 2, too.

@ wHiTeHaT: Wink He use PHP version 5.2.10, thats not the problem.


Best Regards


Peter

_________________
CMS-Version: pragmaMx 1.12.3.1.33.4.14 :: PHP-Version: 5.3.14 :: MySQL-Version: 5.5.23-log :: Server-Version: Apache/2.2.21 (Linux/SUSE)
Projekt: osc4pragmaMx- 2.3.2 in development 
View user's profile Send private message Visit poster's website
sak
PostPosted: Fri Nov 06, 2009 1:27 pm Reply with quote

you're like an angel, bdm Smile

I applied this fix and still no luck, however I'd like to try a few different settings in the config file first before giving up on this.

Did you have this same empty shopping cart problem with osc2nuke? And this change fixed it for you?
 
sak
PostPosted: Fri Nov 06, 2009 2:18 pm Reply with quote

I'm running RavenNuke 2.4. I've tried everything imaginable to get Noscart2 to work. No luck.
 
bdmdesign
PostPosted: Fri Nov 06, 2009 4:32 pm Reply with quote

Ok. osc2nuke dont works with RN 2.4 without changes in the Codes.

Have a look in this tread: Only registered users can see links on this board! Get registered or login!

If you need a working Shop Modul write me a PM please.

This fixe works with RN 2.3 and 2.4 but osc2nuke need more changes to get it works.

Best Regards

Peter
 
wHiTeHaT
PostPosted: Sat Nov 07, 2009 5:41 am Reply with quote

sak... do you run noscart on your localhost?
 
sak
PostPosted: Sun Nov 08, 2009 3:39 pm Reply with quote

My site runs off a professionally administrated server -- I don't run my own server. Is that what you mean? Noscart is running on the same server and account as nuke is, same database and all that stuff.
 
kenno
Worker
Worker


Joined: Jul 26, 2009
Posts: 117
Location: Scunthorpe, UK

PostPosted: Sun May 29, 2011 1:27 pm Reply with quote

Sak

Are you still using this NOScart?
Is it ok to use, any issues, does anyone have a download for this anywhere ?

Thanks Mark
 
View user's profile Send private message
Guardian2003
Site Admin


Joined: Aug 28, 2003
Posts: 6792
Location: Ha Noi, Viet Nam

PostPosted: Mon May 30, 2011 2:27 pm Reply with quote

Keep in mind this thread is 2 years old.
 
View user's profile Send private message Send e-mail
Display posts from previous:       
Post new topic   Reply to topic    Ravens PHP Scripts And Web Hosting Forum Index -> eCommerce

View next topic
View previous topic
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum


Powered by phpBB © 2001-2007 phpBB Group
All times are GMT - 6 Hours
 
Forums ©