Ravens PHP Scripts: Forums
 

 

View next topic
View previous topic
Post new topic   Reply to topic    Ravens PHP Scripts And Web Hosting Forum Index -> Installation Help
Author Message
lota
New Member
New Member


Joined: Jan 08, 2009
Posts: 12

PostPosted: Thu Jan 08, 2009 6:59 am Reply with quote

To give some background:
used phpnuke starting from 2002 until today (v7.7). so some nuke experience is available.

now i freshly installed ravennuke 2.3 into new folder and new DB.
Double checked uploaded files, seems to be everything ok so far.

1. install
while using the included htaccess i couldnt startup installsql.php ... so i removed it and installed everything

2. setup
started setup.php and filled all fields - did run fine

3. admin.php
now i try to start admin.php or index.php - just a blank page is displayed

while uploading again original htaccess file, error 500 is shown

commenting out # Options +FollowSymLinks gives again blank page, as not having the htaccess file present at all too

phpmyadmin shows my admin account and username is as user_name

also no errors are reported, just a blank page.
(config.php has display_errors = true)
Only registered users can see links on this board! Get registered or login!

thx for any help.
 
View user's profile Send private message
Susann
Moderator


Joined: Dec 19, 2004
Posts: 3191
Location: Germany:Moderator German NukeSentinel Support

PostPosted: Thu Jan 08, 2009 7:27 am Reply with quote

Yo need to change also rnconfig to $error_reporting = E_ALL;
to see some errors.

In my opinion you need to ask your host how to change:"DirectoryIndex" tell them you get an Internal Server Error with the original .htaccess.


The .htaccess works well for the most. I had never problems with this.


Last edited by Susann on Thu Jan 08, 2009 7:35 am; edited 1 time in total 
View user's profile Send private message
lota
PostPosted: Thu Jan 08, 2009 7:34 am Reply with quote

E_ALL done - still nothing appears with modified htaccess

now using std. htaccess getting error 500
Quote:
Serverfehler!

Die Anfrage kann nicht beantwortet werden, da im Server ein interner Fehler aufgetreten ist. Der Server ist entweder überlastet oder ein Fehler in einem CGI-Skript ist aufgetreten.

Sofern Sie dies für eine Fehlfunktion des Servers halten, informieren Sie bitte den Webmaster hierüber.
Error 500 Only registered users can see links on this board! Get registered or login!
Thu Jan 8 14:32:05 2009
Apache/2.2.9 (FreeBSD) DAV/2 mod_hcgi/0.5.6 mod_ssl/2.2.9 OpenSSL/0.9.8g



Quote:
php_admin-, php_value- und php_flag-Anweisungen in .htaccess-Dateien funktionieren nicht, sondern führen zu einem Error 500.
 
lota
PostPosted: Thu Jan 08, 2009 7:55 am Reply with quote

when page is visible i switched it to the old files (just move some subfolder on the ftp into the correct location and old system will run again...
 
jakec
Site Admin


Joined: Feb 06, 2006
Posts: 3048
Location: United Kingdom

PostPosted: Thu Jan 08, 2009 2:32 pm Reply with quote

As Susann said you need to ask your host, an Error 500 is a server error and is likely to a problem with the way your host has setup the server.
 
View user's profile Send private message
lota
PostPosted: Thu Jan 08, 2009 2:48 pm Reply with quote

ok, suzann has written me some more info trough pn. Only registered users can see links on this board! Get registered or login!

i can edit some php ini things by myself, but dont have any idea what i'm doing there.
So i'll ask for support from the hoster first.

strange thing is that phpnuke with nuke and sentinel runs fine
and
ravennuke not does startup at all.

I'll keep you informed about an progress.

many thanks for your help
lota
 
lota
PostPosted: Thu Jan 08, 2009 2:52 pm Reply with quote

while commenting out: # Options +FollowSymLinks it will show blank page instead error 500 ... askign the hoster now!
 
jakec
PostPosted: Thu Jan 08, 2009 4:07 pm Reply with quote

What happens if you comment out the other Options in the .htaccess?
 
lota
PostPosted: Fri Jan 09, 2009 1:04 am Reply with quote

jakec wrote:
What happens if you comment out the other Options in the .htaccess?


didnt comment out them with a system but commented out most of them, error 500 as long as above option is active ... and the other just will show blank page.

also installation worked only while not having the htaccess available.

no feedback from hoster so far
 
jakec
PostPosted: Fri Jan 09, 2009 1:22 am Reply with quote

So if you upload a blank .htaccess file that still doesn't work?
 
lota
PostPosted: Fri Jan 09, 2009 1:34 am Reply with quote

jakec wrote:
So if you upload a blank .htaccess file that still doesn't work?


i could do installation steps 1 and 2 ... but dont see anything (blank page) while accessing index.php or admin.php.

got some useless feedback from the hoster.

tables are there in phpmyadmin
 
Guardian2003
Site Admin


Joined: Aug 28, 2003
Posts: 6793
Location: Ha Noi, Viet Nam

PostPosted: Fri Jan 09, 2009 4:51 am Reply with quote

It sounds to me like your RavenNuke (tm) installation is inheriting rules from the htaccess file for your *nuke installation.
 
View user's profile Send private message Send e-mail
jakec
PostPosted: Fri Jan 09, 2009 6:47 am Reply with quote

So what did your host say?
 
lota
PostPosted: Fri Jan 09, 2009 7:46 am Reply with quote

ok, i just do the steps below to still have a running system as long as ravennuke is not running properly.

base directory is: Only registered users can see links on this board! Get registered or login!

while running php-nuke 7.7 it runs in above path - when it is not running i moved all files to a folder Only registered users can see links on this board! Get registered or login! to still have them available in any case.

same thing i do with ravennuke, while running it is in Only registered users can see links on this board! Get registered or login! while not running it is in Only registered users can see links on this board! Get registered or login!

both nuke use different sql user and db name to not get a mess.
Setup of both is ok, as php-nuke 7.7 wouldnt run while having the files present in correct directory and ravennuke installer tells me everything is ok with db connection and db is available and filled with some data.

i'm 10000% sure that i didnt mess up the files!


host said php is running as cgi and told me as per quote below to delete installation folder else it will not run...
Quote:
Once configuration is complete you should either remove the INSTALLATION
folder (preferred) or at the least RENAME it (to something no-one can guess).
You will not be able to access your site until you do, and, even more
importantly, someone could use the installSQL.php to completely wipe out your
RavenNuke(tm) site!


well, now renamed INSTALLATION to aa-INSTALLATION still nothing happens (in my opinion of course nothing happens as this shouldnt be the problem at all)

so lets begin again at the very beginning:
after editing config.php and transfering all files to the server ... i couldnt start Only registered users can see links on this board! Get registered or login! WHILE having present the htaccess file supplied trough ravennuke package. it did give me the error 500.

so for processing the installation with Only registered users can see links on this board! Get registered or login! i deleted the htaccess file and made this step and also used setup.php which did run fine so far as user has been built in the database.

going to the next step (using admin.php, didnt rename it!) - depending on have htaccess available or not i have a blank page or the error 500.

While php-nuke 7.7 didnt run not properly i got at least something to see on the screen and error messages, now i get nothing.

i use this: Only registered users can see links on this board! Get registered or login!
or i used this: Only registered users can see links on this board! Get registered or login!

according my understanding it is the full package...

so.. dont knwo what to do anymore Sad
 
Guardian2003
PostPosted: Fri Jan 09, 2009 8:13 am Reply with quote

Lets get a couple of things out of way right away.
When you install any version of *nuke the website address is stored in two seperate tables (nuke_config, nuke_bbconfig) and *nuke relies on those to work properly - if you move your installation to a different location you need to change those in the database or it will break.

Your hosting provider is correct about removing/renaming the INSTALLATION directory after you have completed the installation process, it also tells you to do this in the HowToInstall instructions.

The htaccess file that comes with RavenNuke (tm) would not stop you being able to install or use the product UNLESS your hosting provider does either;
1 not allow the use of htaccess files - unlikely as you say you have on for your *nuke 7.7

2 there are some directives in the htaccess file which your host does not allow - ask them to check it

3 there is a htaccess file higher up in another directory which is conflicting

You said that your phpNuke 7.7 did not run properly - what was the problem? This might help us find out if it is a proboem with the way your host handles htaccess files - Windows servers do not allow htacces for example.
 
lota
PostPosted: Fri Jan 09, 2009 8:28 am Reply with quote

1. installed nuke 7.7 and used it for a long time (2002 till today) in Only registered users can see links on this board! Get registered or login!
2. moved all files and folders to a subfolder in /nuke/aa-phpnuke
3. /nuke/ now only has 1 folder aa-phpnuke in it and nothing else
4. uploaded files of ravennuke to /nuke
5. installed as per descritption above
6. INSTALLATIOn folder renamed at the moment to aa-INSTALLATION

1 not allow the use of htaccess files - unlikely as you say you have on for your *nuke 7.7
nuke 7.7 uses nukesentinel with httpauth - system does run with htaccess files properly. also htaccess does work for other purposes

2 there are some directives in the htaccess file which your host does not allow - ask them to check it
i did, but answer was useless... if i could ask them a very specific question i may get a more reasonable feedback.

3 there is a htaccess file higher up in another directory which is conflicting
in / there is an empty htaccess file...

nuke 7.7 did run fine, asside of some successfull hacks in the past or spam all the time.

i would like to move to ravennuke as phpnuke developpment seems to be stopped - make site software ready for future.

==>
Links removed by Guardian
 
Guardian2003
PostPosted: Fri Jan 09, 2009 8:45 am Reply with quote

I removed the links, you do not want that information made public!

I can see your frustration, you have kept your cool despite that and you have done everything asked of you without question and without losing your cool.

Please use the email link under my post and let's see if I can sort this out for you Smile
 
lota
PostPosted: Fri Jan 09, 2009 8:49 am Reply with quote

thx for help, as i remove this files later i also would have removed the links.
 
lota
PostPosted: Thu Jan 15, 2009 10:53 am Reply with quote

Guardian2003 seems to be quite busy. anyone else who may help me?
 
Guardian2003
PostPosted: Thu Jan 15, 2009 11:23 am Reply with quote

I am busy but I did say I would help.
Unfortunately, you keep moving your installation around and I just do not have the time to move them back. Keep in mind that during installation, the database stores the url which is then used by the system, so if you move things about, the links will break.

I can help you diagnose the problem but I just don't have the time to go moving files and making changes in the database to reflect the new location etc as I have a long list of clients who are waiting for me to get to their own work.
 
lota
PostPosted: Thu Jan 15, 2009 11:40 am Reply with quote

Guardian2003 wrote:
I am busy but I did say I would help.
Unfortunately, you keep moving your installation around and I just do not have the time to move them back. Keep in mind that during installation, the database stores the url which is then used by the system, so if you move things about, the links will break.

I can help you diagnose the problem but I just don't have the time to go moving files and making changes in the database to reflect the new location etc as I have a long list of clients who are waiting for me to get to their own work.


dear guardian
i move the files because my page should be accessable sometimes.
Moving the files by ftp takes less than 30s per time.

After ravennuke will run in the public_html/nuke folder (where i have installed it), all old phpnuke files will be removed.

of course i understand your busy, no question about that.

Let me know in advance when you have time, i move files to the correct location and will be available in icq/msn/irc... whereever you would like to have me.

thank you

(today evening is bad...)
 
Guardian2003
PostPosted: Thu Jan 15, 2009 12:11 pm Reply with quote

No problem. I'll email you tomorrow and get something arranged.
 
Display posts from previous:       
Post new topic   Reply to topic    Ravens PHP Scripts And Web Hosting Forum Index -> Installation Help

View next topic
View previous topic
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum


Powered by phpBB © 2001-2007 phpBB Group
All times are GMT - 6 Hours
 
Forums ©