Ravens PHP Scripts: Forums
 

 

View next topic
View previous topic
Post new topic   Reply to topic    Ravens PHP Scripts And Web Hosting Forum Index -> Themes
Author Message
Cryonic
New Member
New Member


Joined: Oct 27, 2005
Posts: 9

PostPosted: Wed Dec 17, 2008 2:19 pm Reply with quote

Hi All,

I have a slight problem with my theme on my website. The problem is text alignment in IE7 however FireFox displays it fine but IE doesn't:

Only registered users can see links on this board! Get registered or login!

Also it seems to put a border around my login area on my header? It's like another css sheet is overriding mine?

Could someone point me in the right direction please?

Regards
Steve
 
View user's profile Send private message
mars
Worker
Worker


Joined: Jul 08, 2006
Posts: 123
Location: Bloomsburg,Pennsylvania

PostPosted: Wed Dec 17, 2008 5:12 pm Reply with quote

It isn't a CSS issue but a code issue, somewhere in there is a div with align set to center.

_________________
Only registered users can see links on this board! Get registered or login! 
View user's profile Send private message Visit poster's website
Raven
Site Admin/Owner


Joined: Aug 27, 2002
Posts: 17086

PostPosted: Thu Dec 18, 2008 7:20 am Reply with quote

It could be considered a CSS issue depending on how the code is written. In other words you might have <div id="div1"> and then div1 is defined in a stylesheet Smile
 
View user's profile Send private message
Guardian2003
Site Admin


Joined: Aug 28, 2003
Posts: 6793
Location: Ha Noi, Viet Nam

PostPosted: Thu Dec 18, 2008 9:33 am Reply with quote

Validate your CSS before you do anything else as you have errors.
 
View user's profile Send private message Send e-mail
Cryonic
PostPosted: Thu Dec 18, 2008 11:19 am Reply with quote

My First priority it for it to look right I will then sort out the accessibility etc.
 
Guardian2003
PostPosted: Thu Dec 18, 2008 11:44 am Reply with quote

No offence intended but you will never get it to look right when your CSS is failing to parse height and width attributes you are relying on for your layout.....................
I see you have fixed most of the errors and your doing a really good job with the theme.

I know your issue is in presentation under IE but if you have the developer plug-in for the Firefox browser it really does help, as you can see tables, cells and styles that might be applied as well as missing images and a ton of other useful things.
 
Cryonic
PostPosted: Thu Dec 18, 2008 12:01 pm Reply with quote

Thankyou Guardian! That Developer plug-in pointed me to the right direction here's the fix:

There is a cmxform.css in the "includes/jquery/css/" directory, i just added text-align="left" and that fixed it.

The border problem is also located there but if i remove the border it removes all borders from the form, so ill just add a 0px border in the <td> which the image located in.

Off to find more bugs and fix them Smile

Thanks alot everyone!
 
Guardian2003
PostPosted: Thu Dec 18, 2008 12:27 pm Reply with quote

Glad to be of service Smile
 
Display posts from previous:       
Post new topic   Reply to topic    Ravens PHP Scripts And Web Hosting Forum Index -> Themes

View next topic
View previous topic
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum


Powered by phpBB © 2001-2007 phpBB Group
All times are GMT - 6 Hours
 
Forums ©